JoomShaper Affiliate

Support Forums

Please search before post a new thread

David
David
Offline
Resolved
0 votes
Hello,

I've encountered several issues with the Helix framework and the docman extension.

1. Warning: Invalid argument supplied for foreach() in /www/plugins/system/helix/shortcodes/column.php on line 32

I believe i fixed this by changing

column.php:

foreach ($columnArray as $key=>$value) $html .='<div class="' . $value['class'] . '">' . do_shortcode($value['content']) . '</div>';
$html .='</div>';
$columnArray = array();
return $html;

to:

$columnArray = array();
foreach ($columnArray as $key=>$value) $html .='<div class="' . $value['class'] . '">' . do_shortcode($value['content']) . '</div>';
$html .='</div>';
return $html;


2. Can't select files within docman because the System - Helix framework change
Files.app.fireEvent('uploadFile', [row]);
to
Files.app.fireEvent('uploadFile', div class="row-fluid " >/div>;);
and thus destroying the upload function of DOCman.
*i had to remove the tags from the div, otherwise it won't show up on the forums.

When i disable the Helix framework everything works perfectly with another template, so the problem is within the Helix framework.

3. When i open the template in Joomla backend and close the template, without changing anything, both template.css and preset1.css revert back to original state. How can i disable that?

Edit1: Issue 3 was easy, i disabled LESS in advanced. Issue 1. and 2. still persist.

Sincerely
Dejjvid
Friday, January 24 2014, 12:51 PM
Share this post:

Accepted Answer

sem
sem
Offline
Wednesday, February 05 2014, 08:07 PM - #Permalink
Resolved
0 votes
Brilliant Kowshar! Brilliant. Works perfectly. Thank you so much.

sem
The reply is currently minimized Show
Responses (20)
  • Accepted Answer

    Kowshar
    Kowshar
    Offline
    Support
    Wednesday, February 05 2014, 06:32 PM - #Permalink
    Resolved
    0 votes
    Solution. Copy the column.php to your templates shortcodes directory. Now open the newly copied file then look for the line add_shortcode( 'row', 'row_sc' ); and replace with add_shortcode( 'sprow', 'row_sc' ); and save the file.

    Now, in order to use column shortcode you must need to use [sprow] instead of [row] in your article.

    Thanks
    Like
    2
    The reply is currently minimized Show
  • Accepted Answer

    sem
    sem
    Offline
    Wednesday, February 05 2014, 03:42 PM - #Permalink
    Resolved
    0 votes
    The error code in issue 1. also disappeared when i placed the empty shortcodes/column.php in the template directory


    Yeah - looking back at the thread now I see - but I never got that error on any of the desktop browsers I was testing on which is weird. It only popped up last night when I was testing functionality on an iPad - glad it's all related though. Fingers crossed for a definite fix because it's a shame to loose all that lovely HelixII styling potential but equally a problem to loose uploading files from the frontend. Catch 22.
    The reply is currently minimized Show
  • Accepted Answer

    sem
    sem
    Offline
    Wednesday, February 05 2014, 03:22 PM - #Permalink
    Resolved
    0 votes
    The error code in issue 1. also disappeared when i placed the empty shortcodes/column.php in the template directory.

    Is it working for you too Sem?
    Yep - the styling of the forms is all out of whack (wrong) but it functions now - you can now upload Docman and Fileman documents from the frontend! Thanks KOWSHAR!

    BUT, obviously it breaks any shortcodes that specify nice columns and stuff on the site. Kowshar - is there any way to put an exclude in the override?

    thanks, sem
    The reply is currently minimized Show
  • Accepted Answer

    David
    David
    Offline
    Wednesday, February 05 2014, 01:10 PM - #Permalink
    Resolved
    0 votes
    The error code in issue 1. also disappeared when i placed the empty shortcodes/column.php in the template directory.

    Is it working for you too Sem?
    The reply is currently minimized Show
  • Accepted Answer

    David
    David
    Offline
    Wednesday, February 05 2014, 12:28 PM - #Permalink
    Resolved
    0 votes
    Guys - just testing site on iPad and clicking the upload document button gave me this error. Don't know if that helps but the desktop web browsers didn't bother displaying anything specific.

    sem


    This is exactly the error i recieved but the error disappeared after i changed row on
    $columnArray = array();
    if you look in my first post and issue 1.

    But i have no idea if this is actually fixing the problem, or only hiding the error code. I'm not that good in php.. :D
    I'm gonna try to revert my changes and see if the empty shortcodes/column.php in the template folder fix issue 1. too.
    The reply is currently minimized Show
  • Accepted Answer

    David
    David
    Offline
    Wednesday, February 05 2014, 12:22 PM - #Permalink
    Resolved
    0 votes
    Hi,

    I didn't have a shortcode folder in shaper_helix_ii, but i created one and uploaded a empty column.php and it worked.

    I'm gonna play around and test some more before i'm completely satisfied but it looks promising.

    Thank you for the quick fix!
    The reply is currently minimized Show
  • Accepted Answer

    Kowshar
    Kowshar
    Offline
    Support
    Wednesday, February 05 2014, 11:58 AM - #Permalink
    Resolved
    0 votes
    Quick solution: Create an empty column.php file and copy to your templates shortcodes directory.
    Like
    1
    The reply is currently minimized Show
  • Accepted Answer

    sem
    sem
    Offline
    Wednesday, February 05 2014, 01:46 AM - #Permalink
    Resolved
    0 votes
    Guys - just testing site on iPad and clicking the upload document button gave me this error. Don't know if that helps but the desktop web browsers didn't bother displaying anything specific.

    sem
    Attachments:
    The reply is currently minimized Show
  • Accepted Answer

    David
    David
    Offline
    Tuesday, February 04 2014, 03:42 PM - #Permalink
    Resolved
    0 votes
    Hello,

    sem's description is spot on. Even if you change template, the issue is still there. You need to disable System - Helix Framework, then it works.

    See the screenshots i provided.


    I had to blur file content in the middle column.
    The reply is currently minimized Show
  • Accepted Answer

    sem
    sem
    Offline
    Tuesday, February 04 2014, 03:42 PM - #Permalink
    Resolved
    0 votes
    Hi - Here you go - PDF comparison of uploading a document and inserting a file - both are Joomla Tools extensions. Both protostar. One with Helix disabled. One without.

    sem

    edit: sorry the PDfs wouldn't upload. What David show's is exactly it. It includes FileMan too which is the Joomla tools file manager. If you guys could check it out as soon as possible, that would be brilliant and much appreciated. The offer of access to a test site still stands.
    The reply is currently minimized Show
  • Accepted Answer

    Kowshar
    Kowshar
    Offline
    Support
    Tuesday, February 04 2014, 01:26 PM - #Permalink
    Resolved
    0 votes
    Drop here two screenshot comparing with joomla default template and our Helix - II template.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, February 04 2014, 10:57 AM - #Permalink
    Resolved
    0 votes
    Ok, let us check the issue.
    The reply is currently minimized Show
  • Accepted Answer

    sem
    sem
    Offline
    Monday, February 03 2014, 06:36 PM - #Permalink
    Resolved
    0 votes
    Does it work with joomla standard template.


    Hi. Yes. All works with Protostar. I have a test site setup that I can give you access to if that would help diagnose what the problem is? You can't just select a different template though - you also need to disable the helix framework plugin. Once done, the lighbox interface for editor extend buttons (file/image/document) all work fine.
    sem
    The reply is currently minimized Show
  • Accepted Answer

    Monday, February 03 2014, 03:37 PM - #Permalink
    Resolved
    0 votes
    Does it work with joomla standard template.
    The reply is currently minimized Show
  • Accepted Answer

    David
    David
    Offline
    Monday, February 03 2014, 12:09 PM - #Permalink
    Resolved
    0 votes
    So turning off error reporting will fix issue 2. with DOCMan?
    The reply is currently minimized Show
  • Accepted Answer

    Kowshar
    Kowshar
    Offline
    Support
    Sunday, February 02 2014, 11:22 AM - #Permalink
    Resolved
    0 votes
    Just turn off error reporting from your global configuration.
    The reply is currently minimized Show
  • Accepted Answer

    David
    David
    Offline
    Friday, January 31 2014, 01:44 PM - #Permalink
    Resolved
    0 votes
    Anything new yet? I need to find a solution very soon.
    The reply is currently minimized Show
  • Accepted Answer

    Kowshar
    Kowshar
    Offline
    Support
    Monday, January 27 2014, 11:21 AM - #Permalink
    Resolved
    0 votes
    We are looking at this issue and will let you know as soon as possible.
    The reply is currently minimized Show
  • Accepted Answer

    David
    David
    Offline
    Sunday, January 26 2014, 11:44 PM - #Permalink
    Resolved
    0 votes
    After i changed row on
    $columnArray = array();
    i don't get the warning any more.

    I still have the issue with Docman and Helix framework, this is something the developers must fix, but it's doesn't seem like they answer threads very fast. I need to find a solution pretty quick, otherwise i have to abandon the framework and use another template. And that's pretty bad, considering i'm interested in buyíng templates and extensions from Joomshaper (for a few different projects), but if you can't support your products i won't spend $ on them.. I hope a developer show up soon.

    I will update this thread as soon as i find an answer.
    The reply is currently minimized Show
  • Accepted Answer

    salomon
    salomon
    Offline
    Sunday, January 26 2014, 11:59 AM - #Permalink
    Resolved
    0 votes
    Hello! I have exactly the same problem with my joomla website. Did you found any solution ? but for the Warning: glob() has been disabled for security reasons issues, you must erase the 'glob' string in your php.ini file.
    The reply is currently minimized Show
Your Reply
Scroll to Top