Updating Sp Page Builder To V-3-8-3 Breaks Jbdirectory - Question | JoomShaper

Updating Sp Page Builder To V-3-8-3 Breaks Jbdirectory

AD

Alain Desormiers

SP Page Builder 4 months ago

NOT THE FIRST TIME MY FRIENDS !!!!!!

Who is responsible for checking the health of an update before uploading it to "JOOMLA UPDATE"?

How horrible to get a call from a customer and be called incompetent because their website only displays 404 pages!

And here is that two companies: (cmsjunkie & joomshaper) put you in trouble several times a year; Why? Because the programmers at every company are in more of a hurry to deliver the goods than to thoroughly test their codes.

My notoriety takes a nasty blow with each incident.

Is this normal?

To fix this problem, I reinstalled version 3.8.0 in my computer archive since joomshaper does not offer the old versions for download. (Is this normal? - Why am I paying for a PRO subscription?)

0
34 Answers
J
joe
Accepted Answer
3 months ago

ssnobben,

I don't think they are going to 'fix' it; but, find a workaround:

  • "But no change is made mistakenly. So, dev team is searching to keep the change and not to conflict with J Business Directory."
0
S
ssnobben
Accepted Answer
3 months ago

Will this be resolved to work with Joomla Business Directory CMSjunkie soon?

pls escalate to fix it

thks

0
J
joe
Accepted Answer
3 months ago

George Bara of CMS Junkie just posted a fix for the E404 SP Page Breaker issue.

Here is his comment:

"If you have updated the SP Page Builder extension and you receive the 404 error, you will need to edit components/com_sppagebuilder/router.php and on line 108 delete the following section."

....................................................

else

{

throw new Exception(Text::_('JERROR_PAGE_NOT_FOUND'), 404);

}

CAN JOOMSHAPER CONFIRM THIS FIX?

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 3 months ago

Hello Chris Elliott

Please check your inbox. I have shared the file with you.

Best regards

0
CE
Chris Elliott
Accepted Answer
3 months ago

Please can you send me a copy of 3.8.2 Pro as have the same issue with 404 pages. My credentials are below.

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 3 months ago

Thanks joe for upvoting the issue. I really appreciate your concern. But the fact is it will take time. We have already captured the issue last week and working on it. We all understand that dev time changed something from 3.8.2 and thus creates this mess. But no change is made mistakenly. So, dev team is searching to keep the change and not to conflict with J Business Directory.

Yes, we have user site backups to test out the things. This is very helpful to find the root, obviously. And SPPB and Helix alpha state is not really true. No product in the world is absolutely stable like ours. We always try to keep it up with latest tech. There will be some issues or chance of improvement in every versions. This simply does not make the product Alpha or Beta.

Anyway, you have 3.8.2 and you can perfectly work with it. Basically, my suggestion is to avoid 3.8.3 whoever has J Business Directory on their site.

0
J
joe
Accepted Answer
3 months ago

Can we get an update on this issue?

Trying to make sure that the deveopers have the right informtion to correct the issue.

Users provide you with Akeeba backups, did they help to find the cause of the issue?

A template should be, work on it for a day or two, tweek it a few times afterwards, compain about a bug or two and then forget about the template for years.

I now feel that SPPB and Helix are in v Alpha; this is the honsest truth.

0
J
joe
Accepted Answer
3 months ago

Ofi,

I slightly disagree with your conclusion: "The issue is only concerned with SP Page Builder." This is a false statement.

Even the error messages in my Inspect Consol pointed the finger directly to Helix not SPPB, but likely coding in both.

My personal tests revealed when the bugged SPPB was installed my WHOLE websites had E404 Errors even pages NOT created with SPPB.

Bascially, the light in your office did not work (SPPB/Helix Ultimate) as well as the WHOLE building that your office is located (Joomla).

This is why CMS Junkie reported that their own directory's webpages received E404 errors. Bascially, SPPB is causing issues OUTSIDE SPPB created pages.

This is what everyone on the forums are saying: The 2nd tier links in their "directory" pages did not work. These pages are NON-SPPB created pages.

My test also revealed that the SPPB pages DID work, however, the 2nd tier links did not work.

When, Helix was DISABLED the issue STILL existed on the Default Joomla tempate on ALL the pages I tested, SPPB created and NON SPPB created pages. Bascially, testing a non created SPPB webpage on Joomla's default template.

That is why I asked the question as the problem EXISTED on a NON Created SPPB page on a NON created JoomShaper template.

This is an import factor for the develoers to understand; so, it does not happen to us again.

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 3 months ago

Template and SP Page Builder are different things. Of course, after uninstalling, your template (even if it is our Helix) will work. The issue is only concerned with SP Page Builder.

0
J
joe
Accepted Answer
3 months ago

I mean uninstall the higher bugged version and use the defaut Joomla 4 tempate. Will the Joomla 4 tempate work?

As noted above, CMS Junkie reported that if you keep the higher version installed and change to the default Joomla 4 template, the Joomla 4 template does not work:

  • "It seems that there is an issue with the SP Page Builder router. Please contact the SP Page Builder team to get more info. Even if the page builder is disabled, it still produces the error.""
0
A
Art
Accepted Answer
3 months ago

Hi, for me it worked just to install it over the current version. Now things work again.

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 3 months ago

I don't clearly get you. But both ways work fine.

  1. Uninstall, then install lower version.
  2. Direct install the lower version.
0
J
joe
Accepted Answer
3 months ago

My question was mainly for those who want to uninstall and not reinstall?

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 3 months ago

Easy and simple.

Uninstall first. 
Then install. 
0
J
joe
Accepted Answer
3 months ago

Can you confirm something for me?

If someone installs v3.83 and then uninstalls it, Will they still have the E404 issue?

I ask as an extension developer told me that the E404 problem exists even when the Joomla defaut tempate was selected.

Therefore, do you recommend someone with E404 problems to install v3.8.2 before uninstalling SPPB?

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 3 months ago

joe

Thanks for helping the community. You can ask free user to email us [email protected]. We will send the 3.8.2 lite version.

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 3 months ago

Hello Art

Please post a new question or email us at [email protected]. We will send you the 3.8.2 version.

Best regards

0
J
joe
Accepted Answer
3 months ago

On CMSJunkie's forum, a non-pro user indicated that they have no way to fix the E404 issues as JoomShaper is not making the rollback file avaialble to them:

  • "You cannot create a ticket on their website unless you are on a paid subscription. I tried creating an account, but the account will not allow me to post a question on the forum. So the solution being given here does not work, unless you are on a paid version."

Can you provide the non-pro rollback file in the hidden content and MAKE IT AVAILABLE ON YOUR WEBSITE for non-pro users?

0
A
Art
Accepted Answer
3 months ago

Hi Ofi Khan, same problem here. Can you fix our site, tell me where, what to fix or provide me with the roll back version? Kind regards, Art

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 3 months ago

Hello guys,

Dev team is working on the next update and will fix the issue there. Until then, please use SP Page Builder 3.8.2. Thanks for your patience and co-operation.

Best regards

0
J
joe
Accepted Answer
3 months ago

Please note this related thread:

0
J
joe
Accepted Answer
3 months ago

Please note this related thread:

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 3 months ago

Hello Swanworks

Apology for the inconvenience. I have fixed your site and replied to your post.

Best regards

0
S
Swanworks
Accepted Answer
4 months ago

Dear Ofi,

we have the same Problem and need fast a help! Please help us or give us a roll-back.

Our JPdirectory is not running and give us "company"-404-sites..

Greetings from germany. SWAN

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 4 months ago

Thanks joe for the update :)

0
J
joe
Accepted Answer
4 months ago

Please note a related thread found here:

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 4 months ago

Thanks for the confirmation. I have notified the developer about the thing. Some changes from 3.8.2 seems to create the conflict.

0
J
joe
Accepted Answer
4 months ago

Ofi,

I just downloaded an installed the prior SPPB. After clearing the cache, all apears to be working now.

I will continue following this ticket. Please let me know if you need anything.

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 4 months ago

joe,

I have commented on your post and gave the link there. Please take it from there.

Alan Davies,

I will share this thread with the developers for checking.

Best regards

0
J
joe
Accepted Answer
4 months ago

Here is my thread on the exact same subject:

CAN I GET THE ROLLBACK FILE AS WELL?

0
AD
Alan Davies
Accepted Answer
4 months ago

Hello, I have had the same issue with J-Directory and have had to roll back to a previous version of SP Pagebuilder to get the detail listing views in the directory. The suggestion from CMS Junkie is that it the router used by SP Pagebuilder that causes the issue. https://www.cmsjunkie.com/forum/j-businessdirectory

Please let me know if there is a solution for this so that I can use the update in the future.

Thank you,

Alan

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 4 months ago

Please check SP Page Builder 3.8.2 in the hidden content box.

0
AD
Alain Desormiers
Accepted Answer
4 months ago

Hello Ofi,

Before going to an AkeebaBackup,

Can I have V.3.8.2 or the direct url link to it.

So that I make the website in the same state before updating to v.3.8.3

You can follow my POSTS at CMS Junkie: https://www.cmsjunkie.com/forum/j-businessdirectory/updating-to-sp-page-builder-v.3.8.3-breaks-jbdirectory

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 4 months ago

Hello Alain Desormiers

My sincere apology for the inconvenience. It is not always possible to make the product compatible with every extension out there. But we would definitely consider your feedback and improve our product. Please update your site on localhost and create the issue. Then take a full site backup with Akeeba Backup in ZIP format and share here. Follow this tutorial if needed. I will share the backup with the developer team for checking. Thanks for your patience and co-operation.

Best regards

0