We’re with you. JoomShaper is offering a 20% Discount on all plans due to the impact of COVID-19.

Support Online : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

2 Problems with LMS 3.4.1

Featured Lock Resolved Issue
hi!

I upgraded the SP LMS to the newest version, it went well (but i have to delete it first). Now i have 2 issues with it.

1.) I can't make teachers. When i try to 'save' the new teacher profile it come up with an error log sais: 'Class: 'StringHelper" Not Found'. (you can see it on the first attachment)

2.) I can create courses but if i make the Lessons 'Published' the whole LMS system crushes and sais: "1054 Unknown column 'social_youtube' in 'field list' " (second attachment) and ofcourse without the Lesson the course does not work properly (third attachment). Not to mention that i can't find the Lesson Topic what i created for this course and lesson.

Can you help me with that guys?

I tried to delete - re-install the whole LMS, cleared the ceaches, Fixed the Database but nothing helped...

link: https://balazs-daniel.hu/kurzusok

Attachments (3)

  • lms-problem-1.png
    lms-problem-1.png 43.5 KB
  • lms-problem-2.png
    lms-problem-2.png 253.8 KB
  • lms-problem-3.png
    lms-problem-3.png 234.6 KB

10 Answers

Hi there,

Thanks for contacting us. Sorry for the inconvenience. Please follow the instructions.

1. Uninstall your Extension & re-install the LMS extension
2. If you found the second issue, please watch the video

https://drive.google.com/file/d/1lT4Iu-CVOo6bIMMjPLyfrbyGsKCmozlU/view

-Thanks


hi Toufiq!

Thank you! I tried both of your advices...unfortunately my knowledge is not enough for this video but i uninstalled the extension and than i went to my Php Admin, found a few file which has the name with 'splms' in it, i deleted them, installed the extension again and now it seems perfect! Thank you!

Toufiq - Staff

3 weeks ago #Permalink
Hi there,

Thanks for contacting us. Sorry for the inconvenience. Please follow the instructions.

1. Uninstall your Extension & re-install the LMS extension
2. If you found the second issue, please watch the video

https://drive.google.com/file/d/1lT4Iu-CVOo6bIMMjPLyfrbyGsKCmozlU/view

-Thanks

Orran

2 weeks ago #Permalink
I have the same problem. I'll try the same.

Orran

2 weeks ago #Permalink
But wait. If I uninstall I'll lose all the lessons that I spent a few days working on.

What to do?

Toufiq - Staff

2 weeks ago #Permalink
But wait. If I uninstall I'll lose all the lessons that I spent a few days working on.

What to do?


Hi there, Please watch the video.

https://drive.google.com/file/d/1lT4Iu-CVOo6bIMMjPLyfrbyGsKCmozlU/view

-Thanks

Orran

2 weeks ago #Permalink
But wait. If I uninstall I'll lose all the lessons that I spent a few days working on.

What to do?


Hi there, Please watch the video.

https://drive.google.com/file/d/1lT4Iu-CVOo6bIMMjPLyfrbyGsKCmozlU/view

-Thanks


I'm like the other guy. "my knowledge is not enough for the video." Also, my situation is different. As I explained, I've already spent time with the LMS and don't want to lose all my information by unintalling. Is there another solution?

thanks

Orran

2 weeks ago #Permalink
But wait. If I uninstall I'll lose all the lessons that I spent a few days working on.

What to do?


Hi there, Please watch the video.

https://drive.google.com/file/d/1lT4Iu-CVOo6bIMMjPLyfrbyGsKCmozlU/view

-Thanks


It's likely I'll make the situation worse. I can follow the mouse but there's no sound. You have a localhost. Is that the correct LMS site in your example?

Orran

2 weeks ago #Permalink
Hi Toufiq,

I did a video for you and the team this morning. It's only a few minutes. https://www.youtube.com/watch?v=IG-C-90qyUk

By the way, I know you have put a lot of time into your video and I appreciate that. But I've restored my backup and I'm waiting for the next update.

Thank you for being super!

Toufiq - Staff

2 weeks ago #Permalink
Hi Toufiq,

I did a video for you and the team this morning. It's only a few minutes. https://www.youtube.com/watch?v=IG-C-90qyUk

By the way, I know you have put a lot of time into your video and I appreciate that. But I've restored my backup and I'm waiting for the next update.

Thank you for being super!


Hi there, Thanks for your video. One of your lessons doesn't have a video or image. That's why occurred the problem. Thanks


There are no replies made for this post yet.
Be one of the first to reply to this post!

126

Templates

333261

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us