We’re with you. JoomShaper is offering a 20% Discount on all plans due to the impact of COVID-19.

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

A lot of issues on Helix framework with PHP 7.4

Featured Lock Resolved Issue
Please set your system settings to PHP 7.4 and see the warnings on less.inc.php
/public_html/plugins/system/helix3/core/classes/less.inc.php

There is another issue at:
/plugins/system/helix3/core/classes/menu.php

I am still working with the last one but for the prior one, chnage the curly brackets with [].

9 Answers

Paul Frankowski - Staff

More than a month ago #Permalink
Hi,
sorry, but this template is based on an old framework, helix3 was developed several years ago when nobody heard about PHP 7.4. I cannot help you in a quick time, the framework has to be updated by developers.
Maybe keep PHP 7.3

Hakan

More than a month ago #Permalink
Thank you for your response. I fixed everything by myself. It is not a big issue but there are around 6-8 things that needs to be changed. Turn on and of the plugins because some notifications only appear when the plugin is on for the first time. I am reporting to help you :-)

Paul Frankowski - Staff

More than a month ago #Permalink
Thank you
I hope that helix3 will get technical update soon

Hakan

More than a month ago #Permalink
Please get this line fixed as well then:
Notice: Undefined property: stdClass::$rating in /home/thehomew/public_html/templates/shaper_eventum/html/com_content/category/blog_item.php on line 60

When the ratings are not visible on an article kategory blog, you get this error. "Notice" as developers love to correct.

gmmillard

More than a month ago #Permalink
Can you please notify me when new version of Helix3 is out, as we have PHP errors too and need to turn OFF PHP 7.2 by Sept 2020 as it goes End Of Life.

Paul Frankowski - Staff

More than a month ago #Permalink
I will ask, I hope before Sep2020

gmmillard

More than a month ago #Permalink
Any update on this, I would like to turn off PHP 7.2 now, we only have one site on it and this is holding things up:

CSS for the menu is not coming through with PHP 7.4 and getting these errors as well.

Deprecated: Array and string offset access syntax with curly braces is deprecated in /home/afahd/public_html/components/com_sppagebuilder/helpers/css-parser.php on line 110

Deprecated: Array and string offset access syntax with curly braces is deprecated in /home/afahd/public_html/plugins/system/helix3/core/classes/lessc.inc.php on line 717

Deprecated: Array and string offset access syntax with curly braces is deprecated in /home/afahd/public_html/plugins/system/helix3/core/classes/lessc.inc.php on line 1768

Deprecated: Array and string offset access syntax with curly braces is deprecated in /home/afahd/public_html/plugins/system/helix3/core/classes/lessc.inc.php on line 2424

Deprecated: Array and string offset access syntax with curly braces is deprecated in /home/afahd/public_html/plugins/system/helix3/core/classes/lessc.inc.php on line 2478

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /home/afahd/public_html/plugins/system/helix3/core/classes/menu.php on line 89

Paul Frankowski - Staff

More than a month ago #Permalink
Right now I can help only with the last issue

1) Open in Edit mode: /plugins/system/helix3/core/classes/menu.php
2) Find line 89
3) add "2" after word "continue"
must be: continue 2

Paul Frankowski - Staff

More than a month ago #Permalink
Personally I also wait to Helix3 update to use higher version of PHP


There are no replies made for this post yet.
Be one of the first to reply to this post!

124

Templates

331331

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us