Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Anchor to row not working properly

Featured Lock Resolved Bug
Hello,

I use SP Page Builder and want to build a onepage website.
The menu of this website will redirect to a specify part of the page. To do that, I use menu Item with anchor based on the Section ID of the row.
As you can see on the following link, it's not working well:
https://cena-avocats.com

Thank you very much for your help.

18 Answers

Toufiq - Staff

More than a month ago #Permalink
Hi there,

Yes, you can do it using navigation addon for the smooth scroll. Besides, one-page Template needs custom javascript code.

-Thanks

cliffvt

More than a month ago #Permalink
I have the exact same problem - the anchor works but does not jump to the top of the row - it settles a bit down from the top - so for example I have a row containing a form add-on with a number of fields with section id #join. When i jump to that row using the #join tag - it jumps to the third row of the form rather than the top of the row where the form is - just like in the example in Simon's post : https://cena-avocats.com/fr/#noscompetences

Does it have something to do with the sticky menu bar perhaps?

Simon

More than a month ago #Permalink
Hi,

could you please help us with this problem?

Thank you for your answer.

Simon

More than a month ago #Permalink
Hello,

I didnt have any answer with this problem since a month :(
Could you please help me ?

Thank you

Toufiq - Staff

More than a month ago #Permalink
Hi there,

We are very sorry for the delay response. I have checked your site. But, No problem found there. Would you please share a screencast video about the issue?

-Thanks

Simon

More than a month ago #Permalink
Hi Toufiq, thank you for your answer.
If you go to the main page: https://cena-avocats.com/fr
Then clic on "L'équipe", then clic on "Nos compétences", then on "L"équipe", you'll see the problem.
For the menu of this website I use menu Item with anchor based on the Section ID of the row to redirect to a specify part of the page.
But it's not working properly.

Thank you for your help

Toufiq - Staff

More than a month ago #Permalink
Hi there,

Thanks for your reply. Helix ultimate is not one-page Template. If you need the one-page template.

You use these templates
https://www.joomshaper.com/joomla-templates/qubic
https://www.joomshaper.com/joomla-templates/onepage
https://www.joomshaper.com/joomla-templates/oneclip

-Thanks

Simon

More than a month ago #Permalink
Hi,

thank you for your answer.
For you, if I want to do a one page website, I can't use SP Page Builder?

I thought SP Page Builder can builder One Page with every template, no?

There is a lot of topics on your forum to do that:
https://www.joomshaper.com/forums/how-to-configure-anchor-link-in-pagebuilder
https://www.joomshaper.com/forums/how-to-set-anchor-to-the-midle-of-a-page-in-pagebuilder
https://www.joomshaper.com/forums/how-to-create-a-menu-link-to-anchor

I thing there is a bug, no?

Thank you for your help.

Pavel

More than a month ago #Permalink
Hi Toufiq, thank you for your answer.
If you go to the main page: https://cena-avocats.com/fr
Then clic on "L'équipe", then clic on "Nos compétences", then on "L"équipe", you'll see the problem.
For the menu of this website I use menu Item with anchor based on the Section ID of the row to redirect to a specify part of the page.
But it's not working properly.

Thank you for your help

The first thing to fix: the ID must be unique on the page. Using multiple objects with the same ID is not allowed.
Fix it, then the problem can be addressed more
http://dl4.joxi.net/drive/2019/08/22/0008/0401/545169/69/a5c6a60212.png

Simon

More than a month ago #Permalink
Hi Pavel, thank you for your answer.

I've fix the uniq ID, but the problem is still the same.

Thank you for your help.

Pavel

More than a month ago #Permalink
Hi Pavel, thank you for your answer.

I've fix the uniq ID, but the problem is still the same.

Thank you for your help.


Now you need to correctly place the content in the section, taking into account the height of the header. To do this, it is important for you to understand that clicking on the anchor link binds the section to the upper left corner of the browser.
Here is your section
http://dl4.joxi.net/drive/2019/08/22/0008/0401/545169/69/5c4ac82b8f.png
Everything works as it should. The problem is in the incorrect placement of content

Pavel

More than a month ago #Permalink
Fix it, then we can move on to the next fix step

Simon

More than a month ago #Permalink
Thank you Pavel for your answer.
I'm very sorry but I dont understand at all what you explain.
How can I Place the content. You mean that I have to add margin or padding?

acvmultimedia

More than a month ago #Permalink
Thank you Pavel for your answer.
I'm very sorry but I dont understand at all what you explain.
How can I Place the content. You mean that I have to add margin or padding?



We only use in our company 2 solutions:
1. SP Page Builder navigation addon to create the menu
2. Use ID in blank files with padding

I don´t know if it´s a solution for you.

bye

Toufiq - Staff

More than a month ago #Permalink
Thank you Pavel for your answer.
I'm very sorry but I dont understand at all what you explain.
How can I Place the content. You mean that I have to add margin or padding?



We only use in our company 2 solutions:
1. SP Page Builder navigation addon to create the menu
2. Use ID in blank files with padding

I don´t know if it´s a solution for you.

bye


Hi there, Your solution is perfect. Thanks

Simon

More than a month ago #Permalink
Hello,

I'm sorry to insist, but I did exactly what acvmultimedia explain and it's not working for me :(

If you go to the website here: https://cena-avocats.com/fr
Then clic on "L'équipe" https://cena-avocats.com/fr/#lequipe here it's working well. But if you clic on "Nos compétences" then again on "L'équipe", you'll see the problem.

On this website, I only use sp page builder on the Helix template.

Thank you for your help

Attachments (1)

  • 1.png
    1.png 470.4 KB

Toufiq - Staff

More than a month ago #Permalink
Hello,

I'm sorry to insist, but I did exactly what acvmultimedia explain and it's not working for me :(

If you go to the website here: https://cena-avocats.com/fr
Then clic on "L'équipe" https://cena-avocats.com/fr/#lequipe here it's working well. But if you clic on "Nos compétences" then again on "L'équipe", you'll see the problem.

On this website, I only use sp page builder on the Helix template.

Thank you for your help


Hi there,

Thanks for your explanation. You didn't use the navigation addon. You should use the navigation use instead of Helix menu & have to enable the smooth scroll feature from navigation addon of page builder.

-Thanks


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 148
Toufiq

Toufiq

Total Accepted Answers: 102
Sifat

Sifat

Total Accepted Answers: 83
Kamruzzaman Alam

Kamruzzaman Alam

Total Accepted Answers: 2
DS

Dustin Swayne

Total Accepted Answers: 1

116

Templates

299301

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us