Support Forums

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Articles - video preview/still not shown in SP PB

Featured Lock Resolved Bug
setup: Joomla 3.8.1, SP 2.5.4 + Helix Blog

i have article(s) that are positioned in a SP page in an addon with "Joomla article" as resource.
If I set a "video" type article in Helix Blog and provide an URL, the video preview/still is not shown above the article tite/intro, which is
1. pretty odd
2. ruins the layout since there'll be differented sized article boxes.

(If the artilce has a Helix Blog featured image - it has a play icon on it - but that's ok)

Is there a way to have the helixblog-assigned video prev/still shown?

Thank you

(BTW, in category blog view the articles as "leading article"-s show the same problem - but I suppose that has nothing to do with SP)

18 Answers

Toufiq - Staff

4 days ago #Permalink
Hello,

thank you for work -

1. can I get to know what was the trick? As I saw it applies for the whole category blog module. Will it be affected by a template upgrade/change?

2. Can you answer my 2. and 3. question too?(which seems to be the same problem) - why is the leading article duplicated (with two different dates )? Even if I set the number of leading items to "1" - the leading article appears in a big version, and a small version beside the big. (Screenshot attached)
see: http://dunakeszi.vagyok.com/index.php/video

Thank you for all your effort,
Tamas


Hi, Thanks for your reply. There was css problem. Current item showing left side because of that, its active. And active item will be there. Thanks

Toufiq - Staff

One week ago #Permalink
Hi, Please share your site url and share a screenshot that you have face the problem. Thanks

Tamas

One week ago #Permalink
Hi, Please share your site url and share a screenshot that you have face the problem. Thanks


Hello,

thank you for the quick response

This is an SPPB page with a featured article with Helix video set and image not set (for customer demo reasons the featured article is represented twice in two different block - it's not an error here)
http://dunakeszi.vagyok.com/index.php

Just discovered that even a simple SP builder Joomla article/Category block's article listing provides the same problem - see "Article with video and no feat image"
http://dunakeszi.vagyok.com/index.php

This is a blog layout with one leading article (as it's seen the normal articles display the video prev)
http://dunakeszi.vagyok.com/index.php/hirek



An other problem is - for some reason - the leading article is repeated in the same block here

regards,
Tamas

Toufiq - Staff

One week ago #Permalink
Hi,

There is thumbnail image missing.

https://prnt.sc/hiw7vo

-Thanks

Tamas

One week ago #Permalink
Please see http://dunakeszi.vagyok.com/error_news_page2.jpg

Maybe I was unclear:
if an article - that HAS HelixBlog video and does not have a HelixBlog feat image - is listed in a simple category blog in a simple way - the video preview is visible - (see right side of the image) - if this article is listed as a leading article or is displayed in an SP PBuilder block - the video preview is missing.

Since in the first case the video prev is clearly working - this feature is obviously is implemented. The question is why does it fail in the aformentioned positions?

Thank you,
Tamas

Toufiq - Staff

One week ago #Permalink
Hi, Could you send me the administrator access via pm? Thanks

Toufiq - Staff

One week ago #Permalink
Hi,

Thanks for your pm. Let me explain details.

1. Homepage post comes from article addon and that you want to do this feature doesn't exist (Article addon is overridden)
2. Video page comes from category blog and by default, it has this feature that you ask me.

-Thanks

Tamas

One week ago #Permalink
Hi,

thank you for checking the site and going into details. Though I find it odd I accept that this feature does not exist (my bad, could've checked the template more thoroughly). One more related issue:

You said video page is based on category blog - and that's why it works there.
If you check it
http://dunakeszi.vagyok.com/index.php/video

You find video preview-less articles again in the "leading articles" block where the video preview does not work

1. Is it because it's an SP PB block? (How? And why? The template takes over the leading-article layout too?)
2. Why are there 4 items in the block if I set 3 (you check the video main menu setting)
3. Why is the first article duplicated?

Sorry If I'm asking too basic (and annoying) questions, I'm kind of new to this Helix+Jshaper combo.

Thank you very much,
Tamas

Attachments (1)

  • leading_blovk.PNG
    leading_blovk.PNG 246.1 KB

Toufiq - Staff

One week ago #Permalink
Hi,

thank you for checking the site and going into details. Though I find it odd I accept that this feature does not exist (my bad, could've checked the template more thoroughly). One more related issue:

You said video page is based on category blog - and that's why it works there.
If you check it
http://dunakeszi.vagyok.com/index.php/video

You find video preview-less articles again in the "leading articles" block where the video preview does not work

1. Is it because it's an SP PB block? (How? And why? The template takes over the leading-article layout too?)
2. Why are there 4 items in the block if I set 3 (you check the video main menu setting)
3. Why is the first article duplicated?

Sorry If I'm asking too basic (and annoying) questions, I'm kind of new to this Helix+Jshaper combo.

Thank you very much,
Tamas


Hi, Send me the administrator access. Let me check, please. Thanks

Tamas

One week ago #Permalink
Hi,

thank you for checking the site and going into details. Though I find it odd I accept that this feature does not exist (my bad, could've checked the template more thoroughly). One more related issue:

You said video page is based on category blog - and that's why it works there.
If you check it
http://dunakeszi.vagyok.com/index.php/video

You find video preview-less articles again in the "leading articles" block where the video preview does not work

1. Is it because it's an SP PB block? (How? And why? The template takes over the leading-article layout too?)
2. Why are there 4 items in the block if I set 3 (you check the video main menu setting)
3. Why is the first article duplicated?

Sorry If I'm asking too basic (and annoying) questions, I'm kind of new to this Helix+Jshaper combo.

Thank you very much,
Tamas


Hi, Send me the administrator access. Let me check, please. Thanks


Same as yesterday, I didn't delete your user

Toufiq - Staff

One week ago #Permalink
Hi,

Thanks for your pm. Let me explain details.

1. Homepage post comes from article addon and that you want to do this feature doesn't exist (Article addon is overridden)
2. Video page comes from category blog and by default, it has this feature that you ask me.

-Thanks

Tamas

One week ago #Permalink
It's a previous answer of yours

Toufiq - Staff

One week ago #Permalink
It's a previous answer of yours


Hi, Sorry for my wrong reply. Please give me time to fix your issue. Thanks

Toufiq - Staff

One week ago #Permalink
Hi,

I would request to you that, please check now.

-Thanks

Tamas

One week ago #Permalink
Hello,

thank you for work -

1. can I get to know what was the trick? As I saw it applies for the whole category blog module. Will it be affected by a template upgrade/change?

2. Can you answer my 2. and 3. question too?(which seems to be the same problem) - why is the leading article duplicated (with two different dates )? Even if I set the number of leading items to "1" - the leading article appears in a big version, and a small version beside the big. (Screenshot attached)
see: http://dunakeszi.vagyok.com/index.php/video

Thank you for all your effort,
Tamas

Attachments (1)

  • leading_article_duplicate.PNG
    leading_article_duplicate.PNG 380.4 KB
Thanks for all your efforts!

Toufiq - Staff

1 day ago #Permalink
Thanks for all your efforts!


Hi, You are most welcome & Thanks


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 142
Toufiq

Toufiq

Total Accepted Answers: 63
Shibbir

Shibbir

Total Accepted Answers: 27
Rifat Wahid Alif

Rifat Wahid Alif

Total Accepted Answers: 5
Pavel

Pavel

Total Accepted Answers: 4

100+

Templates

200,000+

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam