Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Backend Editor Does Not Load

Featured Lock Resolved Issue
I'm using SP Page Builder 3.6.4 on Joomla 3.9.13. I've been editing a site for a while and suddenly the backend editor would not load for the "Home" page. Other pages will load that's why I cannot figure out the issue with this page. I've looked through the forums, and can't find a fix for this issue. Please help.

I've deleted cache several times, turned off cache in global settings and browser cache plugin.

Attachments (1)

  • SP_PageBuilder_3.6.4_No_Editor.png
    SP_PageBuilder_3.6.4_No_Editor.png 36 KB

15 Answers

Marlon

More than a month ago #Permalink
Thanks to Toufiq, I finally got this working. Spoiler, CloudFlare was the issue.

Toufiq installed my site on his server and I was able to see the working editor on his server. He pointed out that it was an issue with my SSL.

1) The site in question is a test site on a subdomain. I viewed the SSL site information in Chrome, and it displayed that the SSL was coming from CloudFlare. I knew that was incorrect.
2) At my web host, in the DNS Setting page, I deleted all of the CloudFlare DNS in the CNAME section.
3) DNS Setting page, deleted duplicate A Records to leave only one valid record, i.e; subdomain.main.com, ip address...
4) On the CloudFlare page, deleted all entries for the subdomain.
5) On the CloudFlare page, manually added back the subdomain (CloudFlare created all of the correct CNAME records).

Backend editor works, and SSL certificate information displays the correct certificate authority.

I hope that helps anyone trying to figure this out, because I couldn't understand why some pages worked and other didn't. I still don't understand, but the culprit for me was CloudFlare.

Mehtaz Afsana Borsha - Staff

More than a month ago #Permalink
Hi there,

Thanks for your query. Please turn off the JCE editor and check, please. And don't forget to clear cache

-Thanks

Marlon

More than a month ago #Permalink
I forgot to mention that I tried that previously, but I tried it again and it didn't work.

Attachments (1)

  • Disable_JCE.png
    Disable_JCE.png 48.4 KB

Pascal

More than a month ago #Permalink
Hi did you already solve this issue? I have exactly the same issue....
What php version have you installed?

Regards,
Pas

Marlon

More than a month ago #Permalink
Hi did you already solve this issue? I have exactly the same issue....
What php version have you installed?

Regards,
Pas


No it's not resolved yet, and I have a client's website I'm working on :( I'm waiting for a response from the development team. If it's resolved I'll put the resolution here. All other post's I've found here have not posted the resolution.

PHP 7.2

Mark Pownall

More than a month ago #Permalink
Hi did you already solve this issue? I have exactly the same issue....
What php version have you installed?

Regards,
Pas


No it's not resolved yet, and I have a client's website I'm working on :( I'm waiting for a response from the development team. If it's resolved I'll put the resolution here. All other post's I've found here have not posted the resolution.

PHP 7.2


i had the same problem i think.. and it was because global config Default Editor was set to none. once changed to a editor ever thing was working again.

Pascal

More than a month ago #Permalink
It's solved right now. Was a hosting issue after update some Mod-sec settings were set to default which blocked editor.
Maybe you can check this too.

Regards

Marlon

More than a month ago #Permalink
Hi did you already solve this issue? I have exactly the same issue....
What php version have you installed?

Regards,
Pas


No it's not resolved yet, and I have a client's website I'm working on :( I'm waiting for a response from the development team. If it's resolved I'll put the resolution here. All other post's I've found here have not posted the resolution.

PHP 7.2


i had the same problem i think.. and it was because global config Default Editor was set to none. once changed to a editor ever thing was working again.


Thank you Mark, but I have TinyMCE selected as the default editor and doesn't work.

What's even more strange is, I'm working from a template that has over 80 Page Builder pages and I'm only having this issue with one page, the page I've modified as the default home page. It's been so long that I don't remember what I updated before it stopped working. I looked at the entry in the database, but I can't figure out what to remove to set it back to a previous state :(

Marlon

More than a month ago #Permalink
It's solved right now. Was a hosting issue after update some Mod-sec settings were set to default which blocked editor.
Maybe you can check this too.

Regards


Mod Security? Can you be more specific, which module(s), what settings? I'll try anything at this point. I have a website I cannot complete.

Pascal

More than a month ago #Permalink
What I did is send this to my hosting;
https://www.joomshaper.com/documentation/sp-page-builder/sp-page-builder-3#documentation-heading-3_0

Check this part: If you cannot Save page settings

Hope this helps.

Regards.

Mehtaz Afsana Borsha - Staff

More than a month ago #Permalink
Hi,
Could you please disable all modules and custom plugins used on that affected page. Or If it's possible could you please give me your super admin access in my PM, So that I can check.
-Best Regards
Mehtaz

Marlon

More than a month ago #Permalink
Hi,
Could you please disable all modules and custom plugins used on that affected page. Or If it's possible could you please give me your super admin access in my PM, So that I can check.
-Best Regards
Mehtaz


Answer to your email. I can't export the page because I can't open it.
I've disabled every module assigned to that page but I still can't edit the page.

Marlon

More than a month ago #Permalink
Please, can someone on the development team please look into this issue? I've tried every suggestions and the page I'm editing no longer is accessible.

Marlon

More than a month ago #Permalink
Hello, my issue got lost in mix of all others. The backend editor no longer displays for a selected page, and I can no longer edit my clients site which I need to move it to production. Please can someone on the development team help with this issue. The OP was 11/29/2019, 27 days ago.


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 121
Toufiq

Toufiq

Total Accepted Answers: 112
Mehtaz Afsana Borsha

Mehtaz Afsana Borsha

Total Accepted Answers: 58
Ofi Khan

Ofi Khan

Total Accepted Answers: 56
Rashida Rahman

Rashida Rahman

Total Accepted Answers: 35

121

Templates

314345

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us