Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Background image is not displayed

Featured Lock Resolved Bug
Hello Support,

we use SP Page Builder Pro 3.6.7 on Joomla 3.9.14 and the Template Shaper Helix 2.5.6 and activate a startpage with row option / style / background image and enable a image. But no image is displayed although selected. On other pages this is displayed correctly, but not on this page...

Whats wrong?

The code on the page with incorrect background-image // SP Page Builder Pro 2.5.6

<link href="/cache/com_templates/templates/shaper_helix3/9c889121914c8513c4bee1b6bcb2f622.css" rel="stylesheet" type="text/css" />
<style type="text/css">
body{font-family:Open Sans, sans-serif; font-weight:300; }
h1{font-family:Open Sans, sans-serif; font-weight:800; }
h2{font-family:Open Sans, sans-serif; font-weight:600; }
h3{font-family:Open Sans, sans-serif; font-weight:normal; }
h4{font-family:Open Sans, sans-serif; font-weight:normal; }
h5{font-family:Open Sans, sans-serif; font-weight:800; }
h6{font-family:Open Sans, sans-serif; font-weight:800; }
#sp-top-bar{ background-color:#f5f5f5;color:#999999; }
#sp-bottom{ background-color:#f5f5f5;padding:100px 0px; }
</style>

The code on the page with correct background-image // SP Page Builder Lite 3.2.9

<link href="/cache/com_templates/templates/shaper_helix3/eb1ba0e9bb44f137cd4b1b8666559d2b.css" rel="stylesheet" type="text/css" />
<style type="text/css">
.sp-page-builder .page-content #section-id-1485801530{padding: 170px 0;background-image:url(/images/feature-bg1.jpg);background-repeat:no-repeat;background-size:cover;

....
....

body{font-family:Open Sans, sans-serif; font-weight:300; }
h1{font-family:Open Sans, sans-serif; font-weight:800; }
h2{font-family:Open Sans, sans-serif; font-weight:600; }
h3{font-family:Open Sans, sans-serif; font-weight:normal; }
h4{font-family:Open Sans, sans-serif; font-weight:normal; }
h5{font-family:Open Sans, sans-serif; font-weight:800; }
h6{font-family:Open Sans, sans-serif; font-weight:800; }
#sp-top-bar{ background-color:#f5f5f5;color:#999999; }
#sp-bottom{ background-color:#f5f5f5;padding:100px 0px; }


The settings are the same, could it be the SP Page Builder version?

Greets
Martin

10 Answers

Toufiq - Staff

More than a month ago #Permalink
Hi there, Please don't use both compression mode. Use one of the compression. Thanks


Hi. I know. Just informed you about the nature of the problem, if you do not know it


Hi there, Noted. We will fix it as soon as possible. This issue comes from Helix. Thanks

Toufiq - Staff

More than a month ago #Permalink
Hi there,

Sorry for the inconvenience. Please share your site URL to check the issue.

-Thanks

Martin

More than a month ago #Permalink
Hello,
the address would be http://www.mas-systems.de
Thanks for the support
Greets
Martin

Toufiq - Staff

More than a month ago #Permalink
Hi there,

Thanks for your reply. Please turn off the css & javascript compression from the template manager.

-Thanks

Martin

More than a month ago #Permalink
Hi Toufiq,
after switching off the two functions, the integration has worked again. Is this a general problem or how can this fact be pointed out?
Greets
Martin

Toufiq - Staff

More than a month ago #Permalink
Hi Toufiq,
after switching off the two functions, the integration has worked again. Is this a general problem or how can this fact be pointed out?
Greets
Martin


Hi there, Maybe it was a caching issue. Thanks

Pavel

More than a month ago #Permalink
Hi there, Maybe it was a caching issue. Thanks

Not caching issue. When turning on Production Mode in Builder and css compression in the template, all background images are beginning to have the wrong path. Including those added through the code in the file custom.css

Toufiq - Staff

More than a month ago #Permalink
Hi there, Maybe it was a caching issue. Thanks

Not caching issue. When turning on Production Mode in Builder and css compression in the template, all background images are beginning to have the wrong path. Including those added through the code in the file custom.css


Hi there, Please don't use both compression mode. Use one of the compression. Thanks

Pavel

More than a month ago #Permalink
Hi there, Please don't use both compression mode. Use one of the compression. Thanks


Hi. I know. Just informed you about the nature of the problem, if you do not know it


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 119
Mehtaz Afsana Borsha

Mehtaz Afsana Borsha

Total Accepted Answers: 70
Toufiq

Toufiq

Total Accepted Answers: 66
Rashida Rahman

Rashida Rahman

Total Accepted Answers: 39
Ofi Khan

Ofi Khan

Total Accepted Answers: 39

121

Templates

315577

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us