Support Online : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Background Parallax not working after update

Featured Lock Resolved Issue
Up until I installed the latest version of the software (3.2.5), parallax backgrounds were working fine. Now they're not. Checked all the usual caches and cookies.

Anyone else experience this?

28 Answers

Paul Frankowski - Staff

More than a month ago #Permalink
You're welcome.
Yes, today update SPPB Pro 3.2.6 fixed issue. sorry that you had to wait 5 days.
---
Quick tip:
Check settings of Row background image. Clear cache etc.

Lyle MacVey

More than a month ago #Permalink
Yes, same issue

Andrew

More than a month ago #Permalink
I have exactly the same

Nayem Majhar - Staff

More than a month ago #Permalink
Guys, could you mention the template name? We changed parallax system and we saw that some of our users faced trouble. Hope we will provide the solution by Monday or Tuesday. Thanks for patience.

Andrew

More than a month ago #Permalink
Guys, could you mention the template name? We changed parallax system and we saw that some of our users faced trouble. Hope we will provide the solution by Monday or Tuesday. Thanks for patience.


I'm using Helix Ultimate template. See https://www.joomshaper.com/forums/background-sections-are-not-working-properly-after-update-sp-page-builder-to-3-2-5

Steve

More than a month ago #Permalink
Same here. Helix Ultimate. Page Builder 3.2.5

Lyle MacVey

More than a month ago #Permalink
Yes, same issue. Helix Ultimate 1.0.2 , PageBuilder Pro 3.2.5, no custom CSS.
Example Test; If you create a new page using sample section templates without any edits, the bg image is shown and parallax works. Once you change the default backgrounds to a new image and save, it breaks with only a white bg being shown.

Lyle MacVey

More than a month ago #Permalink
Yes, same issue. Helix Ultimate 1.0.2 , PageBuilder Pro 3.2.5, no custom CSS.
Example Test; If you create a new page using sample section templates without any edits, the bg image is shown and parallax works. Once you change the default backgrounds to a new image and save, it breaks with only a white bg being shown.


The problem is that the related background data-image-src path is not being formed correctly when parallax is enabled.

In the latest SPP build, when parallax is turned on, the code will build the image path reference relative to the spp component path, where your image probably does not reside and results in; https://www.misahualliamazonlodge.com/index.php/component/sppagebuilder/images/pictures/img_toucan_org.jpg

A quick end user fix, until the code correction comes out, is the following;
in the Row Options, Style, Background Image location path, you can either prefix with "/" or enter the complete URL;

after prefixing with a "/"
/images/pictures/img_toucan_org.jpg (corrects the issue)
This ensures reference to the web root path.
https://www.misahualliamazonlodge.com/images/pictures/img_toucan_org.jpg

Ralph-Uwe Scherer

More than a month ago #Permalink
Yes, same issue. Helix Ultimate 1.0.2 , PageBuilder Pro 3.2.5, no custom CSS.
Example Test; If you create a new page using sample section templates without any edits, the bg image is shown and parallax works. Once you change the default backgrounds to a new image and save, it breaks with only a white bg being shown.


The problem is that the related background data-image-src path is not being formed correctly when parallax is enabled.

In the latest SPP build, when parallax is turned on, the code will build the image path reference relative to the spp component path, where your image probably does not reside and results in; https://www.misahualliamazonlodge.com/index.php/component/sppagebuilder/images/pictures/img_toucan_org.jpg

A quick end user fix, until the code correction comes out, is the following;
in the Row Options, Style, Background Image location path, you can either prefix with "/" or enter the complete URL;

after prefixing with a "/"
/images/pictures/img_toucan_org.jpg (corrects the issue)
This ensures reference to the web root path.
https://www.misahualliamazonlodge.com/images/pictures/img_toucan_org.jpg



This did not work for me. I tried both the entire url and the "/" before the path and it is still not working. Helix Ultimate template.

Lyle MacVey

More than a month ago #Permalink
The only other real thing that I could have you check is your ultimate template advanced settings. If you are compressing java script you might want to excluded the following;
main.js,sppagebuilder.js,jquery.min.js

I have found a variety of issues occur if these are not excluded.

Ralph-Uwe Scherer

More than a month ago #Permalink
Hi Lyle,

I am not compressing javascript or css. Another interesting observation: If I disable parallax and do add the / in the url, i.e., "/images/2018/05/03/jerryleelewisstarclub.jpg" it also does not work. Right now it is working with Parallax disabled and using the following url for the background image: images/2018/05/03/jerryleelewisstarclub.jpg

http://wadesnyder.com/

Oh well, hopefully a fix is on the way.

Nayem Majhar - Staff

More than a month ago #Permalink
Can anyone send me admin access and let me check the issue.

pgypps

More than a month ago #Permalink
same on mine..

IT Admin

More than a month ago #Permalink
same issue for me using latest SP release and Helix Ultimate. Adding the "\" before the image path did not fix it.

IT Admin

More than a month ago #Permalink
same issue for me using latest SP release and Helix Ultimate. Adding the "\" before the image path did not fix it.
I tried "/" and it didn't work. Sorry for the typo.

RoyB

More than a month ago #Permalink
Experiencing the same issue using Melvin. It still persists when I turn off "parallax background". Interestingly, it appears to work when using the front page editor, but not when previewing or viewing the page. See attached.[attachment]Screen Shot 2018-07-16 at 11.44.13 AM.png[/attachment]

RoyB

More than a month ago #Permalink
Can anyone send me admin access and let me check the issue.
Are you still looking for admin access? I can DM you mine.

Nayem Majhar - Staff

More than a month ago #Permalink
Can anyone send me admin access and let me check the issue.
Are you still looking for admin access? I can DM you mine.


Thanks for your assistance. Right now, we don't need further admin access. Hope we will release fix tomorrow. Parallax system is very complex when you have to support several devices at the same time. We are working to make more efficient parallax in the best possible way.

Thank You

IT Admin

More than a month ago #Permalink
I installed the latest update and it appears to be working now! I had to remove the image, save it, and re-add it back for it to appear though. Thanks for the prompt resolution!

Ralph-Uwe Scherer

More than a month ago #Permalink
Yes. Working again. Thanks.

Pavel

More than a month ago #Permalink
No, it does not work properly - fixed one bug returned another bug https://www.joomshaper.com/forums/how-to-fix-parallax#reply-149904

Paul Frankowski - Staff

More than a month ago #Permalink
@Pavel , it's old Chrome bug.
This should help:


.sp-page-builder .sppb-section { will-change: transform;}

---
Source from 2015: https://www.fourkitchens.com/blog/article/fix-scrolling-performance-css-will-change-property/


btw
I wonder which value is better transform or auto ??

Pavel

More than a month ago #Permalink
@Pavel , it's old Chrome bug.

Hi, Paul. No, it's not. I practically do not use Chrome. The background does not disappear, but shifts

Paul Frankowski - Staff

More than a month ago #Permalink
Today I was able to fix that problem using only Row settings and above custom css line.
But I agree that feature still needs small improvements and using a high images. I hope upcoming update will bring more fixes. Thanks for review.

Andrew

More than a month ago #Permalink
Last update SPPB 3.2.6 works great to me. Thanks a lot to the staff.

Pavel

More than a month ago #Permalink
Last update SPPB 3.2.6 works great to me.

Must be you just did not use it in the mode in which it works badly

Paul Frankowski - Staff

More than a month ago #Permalink
yes, some people are just lucky.


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 115
Toufiq

Toufiq

Total Accepted Answers: 100
Mehtaz Afsana Borsha

Mehtaz Afsana Borsha

Total Accepted Answers: 60
Ofi Khan

Ofi Khan

Total Accepted Answers: 50
Rashida Rahman

Rashida Rahman

Total Accepted Answers: 33

121

Templates

314615

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us