Support Forums

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Bug on Safari last update

Featured Lock Resolved Bug
Hi, I use MACRO template and on safari browser for iphone and for macbook, updated at last version, the off canvas menu seems to be always open but without click on it, (and it has a transparent background).

Please, see the images attached


Can you help me to fix this problem?
Thank you

Attachments (2)

  • Image-1.jpg
    Image-1.jpg 204.6 KB
  • IMG-20190525-WA0003.jpg
    IMG-20190525-WA0003.jpg 57.3 KB

10 Answers

Sifat - Staff

More than a month ago #Permalink
Hi,
Thanks for your query. I found you've published the offcanvas module in bottom. http://prntscr.com/ntulv2
Please remove that and it'll solve the issue.

-Best Regards

Caterina

More than a month ago #Permalink
Hi, thanks for you reply.
How can i do that?
From module section seems to be ok: the menu module is publish in offcanvas position.

Thanks

Attachments (1)

  • Schermata 2019-05-27 alle 15.40.46.png
    Schermata 2019-05-27 alle 15.40.46.png 32.1 KB

Sifat - Staff

More than a month ago #Permalink
Please publish only one offcanvas module and select the language to all http://prntscr.com/nu9uu9
Or select different language for different offcanvas module http://prntscr.com/nu9vpw

-Thanks

Caterina

More than a month ago #Permalink
Hi, i tried to do that but the problem still exsists.
I also tried to disable all additional modules on canvas position and to enable only one menu (the desktop main menu) but nothing changes.
Before safari updating, all worked fine.
Thanls

Sifat - Staff

More than a month ago #Permalink
Please use this css into your custom css and let me know if that helps.

.offcanvas-menu .offcanvas-inner {
-webkit-transform-style: preserve-3d;
}


-Thanks

Caterina

More than a month ago #Permalink
Hi Sifat, unfortunately it doesn't work :(

Sifat - Staff

More than a month ago #Permalink
Hi Sifat, unfortunately it doesn't work :(

I didn't find the code anywhere in your files http://prntscr.com/nvtand. I think you replaced it in wrong place. Please follow this screencast and use this css there.

.offcanvas-menu .offcanvas-inner {
-webkit-transform-style: preserve-3d !important;
}

Caterina

More than a month ago #Permalink
Hi, we try the code con thepole.it, we try with important too but it doesn't work.

Than we deleted it; but if you want to check we reinsert the code on custom css.

Thanks

Caterina

More than a month ago #Permalink
Hi, we found what caused the problem:
all animation effects above the fold lets the error happens. So we disabled all animation effect for the row or the column or the addons that stays above the fold and the problem doesn't happen anymore. Also some slider's effects causes this problem. Do you think is there a way to fix this problem wothout disable the effects?
thanks

Sifat - Staff

More than a month ago #Permalink
Yes that's what i was thinking. Some animation may conflict. You need to disable those and that should resolve the issue.

-Thanks


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 128
Sifat

Sifat

Total Accepted Answers: 81
Toufiq

Toufiq

Total Accepted Answers: 66
Pavel

Pavel

Total Accepted Answers: 6
Sohan

Sohan

Total Accepted Answers: 5

114

Templates

293399

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us