We’re with you. JoomShaper is offering a 20% Discount on all plans due to the impact of COVID-19.

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Can't add sections - have valid PRO licence

Featured Lock Resolved Issue
I have a valid SP page builder PRO licence, and I know it sort of is working because the pro addons are available. But all sections just say "pro" in the corner and there's no way to add them to a page.

Suggestions? I cleared cache, and nothing works so far...

20 Answers

Paul Frankowski - Staff

More than a month ago #Permalink
Hi,
1) Re-install with SP Page Builder Pro again.
2) Clear browser cache deeply
3) Fill email and license key in Options
---
Read SP PB Manual > FAQ section

ssnobben

More than a month ago #Permalink
Hello I also got the same problem now with Joomla 3.9 and SP Pagebuilder Pro 3.3.5 and its very very strange bcs now I cant add sections :(

Paul Frankowski - Staff

More than a month ago #Permalink
Maybe you should clean browser cache deeper, in most cases Chrome keeps old files very strong.

Always check on 2 different browsers before asking the questions.

Miguel

More than a month ago #Permalink
Hi, I have the same problem. I'followed all your indications but the sections don't appears.
I can't access pages templates either
Regards,

Paul Frankowski - Staff

More than a month ago #Permalink
1) make sure that you updated SPPB pro
2) Enable this and check if you see any error

max_errors.png

3) Share screenshot as well

Attachments (1)

  • max_errors.png
    max_errors.png 13.1 KB

Miguel

More than a month ago #Permalink
I attached the screenshot. The same thing happens in Chrome and in Firefox. What you'll see in the screen shot happens indefinitely.
I'm using SP Builder Pro 3.5.0

Attachments (1)

  • screenshot01.png
    screenshot01.png 81.4 KB

Paul Frankowski - Staff

More than a month ago #Permalink
The last questions:
1) Are you able to see/load Page Templates?
2) Your hosting is from which country?
(they may block API from Joomshaper)

Miguel

More than a month ago #Permalink
Answers:
1) No
2) Argentina

Until the last update I could see everything perfectly.
On the other hand, I've another site where I haven't yet updated SPBuilder and there I can see the sections and templates

Paul Frankowski - Staff

More than a month ago #Permalink
3.4.11 and 3.5 nothing was touched in that area.
Anyway... please click my avatar and send me access (URL, Super User) to that site where you have problems, I will ask our developer for help. Gracias

Paul Frankowski - Staff

More than a month ago #Permalink
Thanks, according to SPPB documentation and suggested PHP configuration on your hosting
PHP file_get_contents() function - is not available or locked
PLEASE ask your hosting support to enable / unlock this
I cannot change that from Joomla admin.

why.png

Attachments (1)

  • why.png
    why.png 42.4 KB

Miguel

More than a month ago #Permalink
Hello,
I've communicated with my hosting and they tell me that this function is not disabled, that it can be corroborated with a phpinfo.
https://kumvisual.com.ar/phpinfo.php
They ask me to tell them what the error based on what is shown on the screen.
I've activated the option to show "maximum" errors and I can't see the errors as to tell them what the problem is.
I want to help me see what is wrong to communicate to the technical service of my hosting.
Thank you

Paul Frankowski - Staff

More than a month ago #Permalink
Please check "Integration" tab inside SP Page Builder you will see the error message. Errors must be set to Maximum. That's why I asked you to fix file_get_contents() function - you can take a screenshot and talk with hosting support again.

Look below this is a 403 error message from your website, they have to fix it - otherwise, you cannot use all PRO features. Sorry, it's beyond us. We deliver software, not hosting / PHP settings.
look.jpg

Attachments (1)

  • look.jpg
    look.jpg 138.7 KB

Miguel

More than a month ago #Permalink
Hi, this is the answer of the hosting technical service:
"The error is a FORBIDEN, on the part of the destination server, I verified that the port 443 of the remote site is open and that the file_get_contents is not blocked, I tried from another of our servers and connects well. For some reason the plugin server has blocked us, I suggest you contact the developer to inform him of this FORBIDDEN and to see how to solve it."

Paul Frankowski - Staff

More than a month ago #Permalink
Ok, thanks, today is Sunday so I cannot do anything, but tomorrow I will ask our developer.

Paul Frankowski - Staff

More than a month ago #Permalink
Please deliver us your website IP address
we will try to "unlock"

---
If possible we need also access to FTP

Use Private Message to send me access

Paul Frankowski - Staff

More than a month ago #Permalink
yes, the issue was fixed yesterday, as our developer promised.
Integration - OK

Let me talk with a developer about rest

Miguel

More than a month ago #Permalink
Hi Paul, I'd like to know if there are any news.
Regards,

Paul Frankowski - Staff

More than a month ago #Permalink
FIXED, sorry for delay,
Integration - OK
Page Templates - OK
Sections Library - OK (but it loads slow, so you have to wait 60 sec)

ok-1.jpg

ok-2.jpg

Attachments (2)

  • ok-1.jpg
    ok-1.jpg 138.6 KB
  • ok-2.jpg
    ok-2.jpg 136.8 KB

Miguel

More than a month ago #Permalink
It works perfectly! :D
Thank a lot!


There are no replies made for this post yet.
Be one of the first to reply to this post!

123

Templates

327847

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us