Support Forums

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Cant edit Frontend

Featured Lock Resolved Issue
When i click edit frontend in SP3 i get 404.
Example:
Try to edit: https://www.itc-solution.de/oxo-connect
SP3 opens: https://www.itc-solution.de/produkte/telefonanlagen/oxo-connect/16-oxo-connect

I use sh404sef for making short urls. With SP2 i had no problems.

for better understanding please see Video: http://take.ms/BTu9b

27 Answers

Toufiq - Staff

3 weeks ago #Permalink
Hi, Send me administrator access via pm. Thanks

Rapha73

3 weeks ago #Permalink
you have PM

Thanks

Rapha73

3 weeks ago #Permalink
Hi Toufiq,
yesterday i sent PM with admin account.
Please help.

Toufiq - Staff

3 weeks ago #Permalink
Hi,

Thank you for your pm. Please turn off SEF URL and try to edit front end. Maybe you missed the setup SEP.

https://prnt.sc/hb89vq

-Thanks

Rapha73

3 weeks ago #Permalink
Hi,

can you please explain why i should turn off SEF URL?
This is one of the best joomla feature.
Thank you.

Toufiq - Staff

3 weeks ago #Permalink
Hi,

can you please explain why i should turn off SEF URL?
This is one of the best joomla feature.
Thank you.


Hi, I just said it for test front-end edit. I have include maybe you have miss the SEF settings properly. I didn't say you turned off forever SEF feature.

You can watch the video

https://www.youtube.com/watch?v=xMUAbMPnlpw

-Thanks

Rapha73

3 weeks ago #Permalink
Hi Toufiq,
when i disable SEF settings for a test it works.
Whats the next step?
Thanks.

Toufiq - Staff

3 weeks ago #Permalink
Hi Toufiq,
when i disable SEF settings for a test it works.
Whats the next step?
Thanks.




Hi, Did you see my last reply? Thanks

Rapha73

3 weeks ago #Permalink
Yes. But i dont know what you mean. You sent me a link with a 2 year old video.

My problem is that i cant edit with SP3 frontend when i have turn on SEF. Before and with SP2.X it works.

Rapha73

3 weeks ago #Permalink
hello.....please help

Toufiq - Staff

2 weeks ago #Permalink
hello.....please help


Hi, Please turn off this extension. Then check again.

sh404SEF

-Thanks

Rapha73

2 weeks ago #Permalink
Hi Toufiq,
thanks for helping me.
After turn off sh404SEF it works. But i have to turn on again. I need this extension.
Next step?

Toufiq - Staff

2 weeks ago #Permalink
Hi Toufiq,
thanks for helping me.
After turn off sh404SEF it works. But i have to turn on again. I need this extension.
Next step?


Hi, Thanks for your reply. After turn on did, you face the problem? Thanks

Rapha73

2 weeks ago #Permalink
Hi,
Yes. Please have a look at this video.
http://take.ms/GoK6E
I startet with turn of sh404SEF.

Toufiq - Staff

2 weeks ago #Permalink
Hi,
Yes. Please have a look at this video.
http://take.ms/GoK6E
I startet with turn of sh404SEF.



Hi, Thanks for your reply. I have added this topic to our working board. We will try to compatibility with this product. Thanks

Rapha73

2 weeks ago #Permalink
Hi Toufiq,
i cant see your working board :D
When you will fix this problem? sh404SEF ist very popular extension.
I can not believe that I'm the only one with the problem.
Thanks

Toufiq - Staff

2 weeks ago #Permalink
Hi Toufiq,
i cant see your working board :D
When you will fix this problem? sh404SEF ist very popular extension.
I can not believe that I'm the only one with the problem.
Thanks


Hi, I know the problem and i have forward it to our developer team. Thanks
3 weeks without fix. Any news?

Toufiq - Staff

4 days ago #Permalink
Hi, Developer informed that we didn't provide this extension compatibility. That's why you have to turn off this sh404SEF extension when you need to front-end edit. Thanks
Sorry, I do not believe you. You need 3 weeks for this answer?

sh404SEF is the most popular and longest developed Joomla seo extension.
You should have to work on SP3 compatibility.

Sorry, I do not believe you. You need 3 weeks for this answer?

sh404SEF is the most popular and longest developed Joomla seo extension.
You should have to work on SP3 compatibility.


Hello,

It was a technical problem so we have to check it carefully. It requires time. That's why we take 3 weeks. We have to make sure this issue is not created by our page builder. Finally, we found this issue is not created by our page builder. We just call Joomla router to build pretty link for editing.

Think you have created a page called Test and the page id is 10. So the front-end editing link will be http://www.example.com/index.php/component/sppagebuilder/10-test/edit

But this link is not working with sh404SEF. I think you need to ask sh404SEF support for this reason.


Thanks
As i wrote in #1 there is no problem with SP2. Only with your new SP3!
And you say go to sh404SEF support?
I think it is better you check SP3 and ask sh404SEF support what you have to do.
Hi

Can I please and two cent to the discussion, your stating that the frontend editor doesn’t work because of sh404SEF but my client sites does not have this installed and yet it still doesn’t work. The start of this thread you state to disable the Joomla SEF. So clearly there is an issue with the SPB3 router

Can you please investigate this as it is becoming a costly problem for our business
As i wrote in #1 there is no problem with SP2. Only with your new SP3!
And you say go to sh404SEF support?
I think it is better you check SP3 and ask sh404SEF support what you have to do.


Hello,

SP Page Builder 2 front-end editing link wasn't pretty link.

SP Page Builder 2: http://www.example.com/index.php?option=com_sppagebuilder&view=form&id=10&layout=edit
SP Page Builder 3: http://www.example.com/index.php/component/sppagebuilder/10-test/edit

I think You can see the difference between them.

Let me explain.

We are calling

$app = JApplication::getInstance('site');

for Joomla Application. Then we call

$router = $app->getRouter();

for getting Joomla Router then we are telling please pretty

$front_link = 'index.php?option=com_sppagebuilder&view=form&tmpl=componenet&layout=edit&id=10';
$router->build($front_link)

this link.

That's it. So please ask them maybe they can give a solution.

Toufiq - Staff

3 days ago #Permalink
Hi

Can I please and two cent to the discussion, your stating that the frontend editor doesn’t work because of sh404SEF but my client sites does not have this installed and yet it still doesn’t work. The start of this thread you state to disable the Joomla SEF. So clearly there is an issue with the SPB3 router

Can you please investigate this as it is becoming a costly problem for our business


Hi, Thanks for your reply. Did you report to us? I don't see your forum post. Your previous query was the text editor and it has been fixed already. Thanks
Hi Raju,
thank you. Please understand my situation.
I am not an Joomla dev. Thats why i bought some products from your company and also from wbamp/sh404SEF.
I think its much better when you talk with sh404SEF Team.

Do you want to do that for us as a customer?


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 143
Toufiq

Toufiq

Total Accepted Answers: 51
Shibbir

Shibbir

Total Accepted Answers: 28
Rifat Wahid Alif

Rifat Wahid Alif

Total Accepted Answers: 4
Pavel

Pavel

Total Accepted Answers: 3

100+

Templates

200,000+

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam