Support Forums

Support Online : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Contact form doesn't send maessages

Featured Lock Resolved Bug
Hi, I set up the contact form addon on my site https://www.sos-tegno.com/ but when I try to send a message with the form the send button loads and then nothing happen, no message sent.

I have no idea how to fix the problem.

Thank you.

17 Answers

Sifat - Staff

More than a month ago #Permalink
Hi,
Thanks for your query. Would you please mention which template you are using? Also please check if your template has an override of this addon. You can check this from this location templates/shaper_macro/sppagebuilder/addons/ajax_contact
If so then you can rename the folder and check if it works or not.

Also please check if you've entered the recipient email address http://prntscr.com/lqff8z

-Best Regards

Roberto Corrias

More than a month ago #Permalink
Hi, the template is Lt Law and I checked the path you sent me, no override of the addon (see image attached).

I inserted the recipient email address as per image attached.

I also tried leaving FROM NAME and FROM MAIL fields empty, still no mail sent.

When I push the button to send the email from the contact form first the button loads, but then no message (MESSAGE SENT) appear.

Attachments (2)

  • Cattura 1.PNG
    Cattura 1.PNG 584.3 KB
  • Cattura.PNG
    Cattura.PNG 495.3 KB

Sifat - Staff

More than a month ago #Permalink
Hi,
Thanks for your reply. Would you please make sure you are using latest version of pagebuilder. Also please check the issue using joomla's default template. To do so please select the template to protostar http://prntscr.com/lrvwz9 and check if the issue yet exists or not.
Let me know your testing result.

-Best Regards

Igor

More than a month ago #Permalink
Hello, Sifat!

A have same issue.
Message not sent.
1. I use Kidzy template
2. I use latest version of SP Page Bulder - 3.3.7
2. What do I need to check in this path: templates/shaper_macro/sppagebuilder/addons/ajax_contact ? (see screen)
3. I changed my templay to "protostar" and check to resend message, but it did not help

Also I have next issue:
1. Phone field not show in Kidzy template, but show in protostar template (screen)
2. Google captcha show but not requered field then click Send button, i.e. i can send message without click on captcha field

Attachments (3)

  • ajax_contact.JPG
    ajax_contact.JPG 26.1 KB
  • phone_not_show.JPG
    phone_not_show.JPG 91.9 KB
  • phone_show.JPG
    phone_show.JPG 65.9 KB

Grzegorz

More than a month ago #Permalink
Hello,

I have the same problem :(

template: HelixUltimate - 1.0.5
SP PB pro: 3.3.7
J!: 3..9.1
reCaptcha: v2
typical addon "Contact":
- with default captcha (question-answer) - working good
- with reCaptcha - doesn't work, no email sent

Sifat - Staff

More than a month ago #Permalink
I changed my templay to "protostar" and check to resend message, but it did not help

Hi,
Thanks for your reply. Since this doesn't work with the default template then it's sure that the issue is from your server side. May be incorrect PHP version or Joomla. We prefer you to use at least php 7.1
You can check from your joomla backend to check if the PHP mailing is working or not.

-Best Regards

Sifat - Staff

More than a month ago #Permalink
no email sent

Hi,
Thanks for your reply. Would you please share what you meant by no email sent? Is the success message isn't showing or you are not receiving the mail?

Igor

More than a month ago #Permalink
I changed my templay to "protostar" and check to resend message, but it did not help

Hi,
Thanks for your reply. Since this doesn't work with the default template then it's sure that the issue is from your server side. May be incorrect PHP version or Joomla. We prefer you to use at least php 7.1
You can check from your joomla backend to check if the PHP mailing is working or not.

-Best Regards


Hello, Sifat!

I checked my backend server settings:
1. I opened General settings->Server (see screen 1_php_mail.JPG)
2. Then click on button Send test message (see screen 2_php_mail.JPG)
3. Then checked my mailbox - message received (see screen 3_php_mail.JPG)

So, BackEnd PHP mail system is working.

But why not sent from your contact form?

Attachments (3)

  • 1_php_mail.JPG
    1_php_mail.JPG 146.8 KB
  • 2_php_mail.JPG
    2_php_mail.JPG 101.6 KB
  • 3_php_mail.JPG
    3_php_mail.JPG 52.2 KB

Grzegorz

More than a month ago #Permalink
no email sent

Hi,
Thanks for your reply. Would you please share what you meant by no email sent? Is the success message isn't showing or you are not receiving the mail?


Hi,

Both,
Success message isn't showing and I'm not receiving the email.

Sifat - Staff

More than a month ago #Permalink
But why not sent from your contact form?

Hi,
Would you please check the template override folder from this location templates/shaper_kidzy/sppagebuilder/addons/ajax_contact
Please rename or delete the folder temporarily and check if it's working or not.

-Thanks

Sifat - Staff

More than a month ago #Permalink
Success message isn't showing and I'm not receiving the email.

Hi,
Please PM me your super admin access along with a temporary email address( with access ) thus i can check that myself.

-Thanks

Igor

More than a month ago #Permalink
But why not sent from your contact form?

Please rename or delete the folder temporarily and check if it's working or not.



Hello!

I renamed folder templates/shaper_kidzy/sppagebuilder/addons/ajax_contact to templates/shaper_kidzy/sppagebuilder/addons/ajax_contact_tmp

After that, my site not load and an error was appear:


Fatal error: Cannot redeclare class SppagebuilderAddonAjax_contact in ...addons/ajax_contact_tmp/site.php on line 413

Sifat - Staff

More than a month ago #Permalink
Hi,
Please cut that folder from that location and paste to anywhere thus you can reuse that folder again.
Let me know the test result.

-Thanks

Igor

More than a month ago #Permalink
Hello!

I moved the folder to another location, the site started to work.
But sending a message from the form does not occur.
Simply form fields are cleared without notice that the message has been sent.
The line of the phone appeared, the Google captcha does not check.

Sifat - Staff

More than a month ago #Permalink
Hi,
Please PM me your super admin access along with a demo mail access thus i can check that with the demo mail.
Make sure you've used the demo mail as php mailer mail.

Igor

More than a month ago #Permalink
Hello!

I moved the folder to another location, the site started to work.
But sending a message from the form does not occur.
Simply form fields are cleared without notice that the message has been sent.
The line of the phone appeared, the Google captcha does not check.


Hello, Sifat
I wrote you internal message to contact with me.
When will you contact with me?

Sifat - Staff

More than a month ago #Permalink
Hi,
Thanks for your reply. And i'm extremely sorry for the unexpected delay. Please check my reply on your PM.

-Best Regards


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 105
Sifat

Sifat

Total Accepted Answers: 104
Toufiq

Toufiq

Total Accepted Answers: 36
Pavel

Pavel

Total Accepted Answers: 4
J

johnny

Total Accepted Answers: 3

100+

Templates

200,000+

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us