Support Forums

Support Online : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

cURL error: Could not resolve host: .api.mailchimp.com

Featured Lock Resolved Issue
Hello,

I have a current issue with mailchimp API on my website Sprida.co.uksprida.co.uk

I have added an active up to date API key from mail chimp vai Account > Extras > API Keys
and I grabbed the list ID from Audience > View Contacts > Settings > Audience name & defaults

Whereby it says:

Some plugins and integrations may request your Audience ID.

Typically, this is what they want: dcc0c66693.

I have already followed:
https://www.joomshaper.com/forums/curl-error-couldn-t-resolve-host-api-mailchimp-com

It's obviously not a DNS error. How do I fix this issue please?

21 Answers

nspiremedia

More than a month ago #Permalink
Also just to point out it is working via a form API on this page with the same details: https://sprida.co.uk/growthcentre

Toufiq - Staff

More than a month ago #Permalink
Hi there,

Sorry for the inconvenience. I have forward this issue to our developer team. Please hold on for the feedback from Devs Team.

-Thanks

Toufiq - Staff

More than a month ago #Permalink
Hi there,

Please confirm that your curl is enabled. For curl information, you can contact your hosting provider.

Thanks

nspiremedia

More than a month ago #Permalink
Yes, curl is enabled.

And just to point out, as I explained in my original post it is working via a form API on all my page with the same details. The only place I am getting that error is in the footer.

I am also getting COM_SPPAGEBUILDER_ADD_CONTACTNAME on this page only:
https://sprida.co.uk/blog/7-tips-for-improving-your-copywriting

Toufiq - Staff

More than a month ago #Permalink
Hi there,

Thanks for your reply. Please make sure that your MailChimp list is correct. Could you send me the Joomla administrator access via PM?

-Thanks

nspiremedia

More than a month ago #Permalink
I have DM you. :(

Toufiq - Staff

More than a month ago #Permalink
Hi there,

Thanks for your PM. I have replied to you previous day for the FTP access. Please check your PM.

-Thanks

Toufiq - Staff

More than a month ago #Permalink
Hi there,

I have added our MailChimp API Key & list id. It works fine. Please check & let me know.

-Thanks

nspiremedia

More than a month ago #Permalink
I still don't think you understand my point. It's working on every page just not in the footer!

nspiremedia

More than a month ago #Permalink
This does not add it to our mailchimp list!

Toufiq - Staff

More than a month ago #Permalink
This does not add it to our mailchimp list!


Hi there,

Yes, That's the point. Because of that, Now there are using our API key & List ID. That's why does not add it to your MailChimp list. Please use the valid PI key & List ID. I hope your problem will be solved.

Note: We added the API key to show you that works fine. Now, you need to use the valid API key & List ID.

-Thanks

nspiremedia

More than a month ago #Permalink
Toufiq,

You still need to deal with my second question:

I am also getting COM_SPPAGEBUILDER_ADD_CONTACTNAME on this page only:
https://sprida.co.uk/blog/7-tips-for-improving-your-copywriting

See screenshot!

error.png

Attachments (1)

  • error.png
    error.png 247.1 KB

Toufiq - Staff

More than a month ago #Permalink
Hi there,

Add this language code inside the /language/en-GB/en-GB.ini file.


COM_SPPAGEBUILDER_ADDON_AJAX_CONTACT_NAME = "Name"
COM_SPPAGEBUILDER_ADDON_AJAX_CONTACT_EMAIL="Email"


-Thanks

nspiremedia

More than a month ago #Permalink
I added it to:

Editing file "/en-GB.tpl_shaper_languageschool.ini" in template "shaper_languageschool".

Still no change?

nspiremedia

More than a month ago #Permalink
Add it via that host and now it is working - Thanks!

nspiremedia

More than a month ago #Permalink
Can you tell everyone how you fixed the CURL Error: Could Not Resolve Host: .Api.Mailchimp.Com so I can select best answer for future?

JadeNg

2 weeks ago #Permalink
Hello support, I have this problem even after updating the SP Page Builder Pro. I have killed the old account and checked again but still same error.

I spoke to SiteGround and they said it is the addon problem in SP Page Builder not from the hosting side.

My website is: txkeyboards.com/
Please scroll down to the bottom for Subs bar.

Thank you so much!

Toufiq - Staff

2 weeks ago #Permalink
Hello support, I have this problem even after updating the SP Page Builder Pro. I have killed the old account and checked again but still same error.

I spoke to SiteGround and they said it is the addon problem in SP Page Builder not from the hosting side.

My website is: txkeyboards.com/
Please scroll down to the bottom for Subs bar.

Thank you so much!


Hi there,

Thanks for your reply. Please make sure that you have used the correct API key & list id of Mailchimp.

Thanks

JadeNg

2 weeks ago #Permalink
Hello support, I have this problem even after updating the SP Page Builder Pro. I have killed the old account and checked again but still same error.

I spoke to SiteGround and they said it is the addon problem in SP Page Builder not from the hosting side.

My website is: txkeyboards.com/
Please scroll down to the bottom for Subs bar.

Thank you so much!


Hi there,

Thanks for your reply. Please make sure that you have used the correct API key & list id of Mailchimp.

Thanks


Hi there, I have triple-checked it already. I only have 1 list and 1 API key...

Here's what the technical support on SiteGround told me:

In it the line that has the URL is:
$url = 'https://' . $dataCenter . 'http://.api.mailchimp.com/3.0/lists/'. $mclistid .'/members/' . $memberId;

As you can see the plugin is supposed to put a data center prefix in front of the URL, but for some reason does not do so. This is the only file that references the mailchimp API, as it is not present anywhere else in the database or site files, the SP builder module is the only thing that has it. As such you will need to contact the module developer and see what me cause this behaviour, as they would be likely to have seen this issue before and should be able to offer a solution.

Toufiq - Staff

2 weeks ago #Permalink
Hello support, I have this problem even after updating the SP Page Builder Pro. I have killed the old account and checked again but still same error.

I spoke to SiteGround and they said it is the addon problem in SP Page Builder not from the hosting side.

My website is: txkeyboards.com/
Please scroll down to the bottom for Subs bar.

Thank you so much!


Hi there,

Thanks for your reply. Please make sure that you have used the correct API key & list id of Mailchimp.

Thanks


Hi there, I have triple-checked it already. I only have 1 list and 1 API key...


Hi there, Please send me the Joomla administrator access via PM. Thanks


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 128
Sifat

Sifat

Total Accepted Answers: 83
Toufiq

Toufiq

Total Accepted Answers: 40
Pavel

Pavel

Total Accepted Answers: 6
Sohan

Sohan

Total Accepted Answers: 4

114

Templates

292637

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us