We’re with you. JoomShaper is offering a 20% Discount on all plans due to the impact of COVID-19.

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

custom.css loads after sppagebuilder.css on pages that are joomla article menu links only

Featured Lock Resolved Bug
Hello.
I am using estate template and pagebuilder on a website that is under construction. Large site. I have found that on the pages that are joomla article links and the articles are plain text the custom.css and custom.js are loaded before pagebuilder css and js files.

In the pages that are joomla artcle links, but the articles are created with pagebuilder this is not happening.

Link with joomla article - (custom files in wrong position) https://newnautilia2.nautilia-yachting.com/yacht-sales/yachts-management

Link with joomla article developed with pagebuilder - (custom files in right position) https://newnautilia2.nautilia-yachting.com/why-us/services

Really need help because there are multiple overrides in custom files.

Thank you in advance for your help.

7 Answers

Paul Frankowski - Staff

3 weeks ago #Permalink
Follow my steps
1) Rename file name from custom.css into override.css
2) In Template Helix Options > Custom Code > Before </ head > put below code


<link href="/templates/shaper_estate/css/override.css" rel="stylesheet" type="text/css" />


In this basic way, this would be the last file loaded from the < head > area.
---
I described this method also in Helix documentation (some time ago) in tip how to use two custom.css files.

Paul Frankowski - Staff

3 weeks ago #Permalink
Hi,
to be honest I have no idea why it displays it in this changed order.
I cannot change the Helix code itself, as you may know, but I can figure out an alternative method to solve it.

Paul Frankowski - Staff

3 weeks ago #Permalink
BTW
Why you load font-awesome v4.7.0 from cdnjs.cloudflare.com ?
It doesn't make sense for me.
This template use FA 5, SPPB uses FA 5 + legacy mode.
And you load an old icon library. Maybe it's from widgetkit, hmm?
(Following…)
Since this is a transition from yootheme to joomshaper, once it is ready i will uninstall widgetkit. I have already changed all the galleries.

Maybe it is. But, since this problem is on other client sites also, i believe programmers should take a look at it.
Thank you for the workaround.

Paul Frankowski - Staff

3 weeks ago #Permalink
It has to be checked and improved inside Helix template,
I can only suggest dev team.


There are no replies made for this post yet.
Be one of the first to reply to this post!

126

Templates

333617

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us