Support Forums

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Fatal error site.php on line 124

Featured Lock Resolved Issue
Hi,

After I installed the Medico template, the administrator works fine but the site doesn't work. It gives me this error:

Fatal error: Can't use function return value in write context in /home/affordableserver/public_html/http://desertmilagros.net/components/com_sppagebuilder/addons/carousel/site.php on line 124

My Hosting PHP Version 5.4.45. I do not want to update it to 7.0 or 7.1 cause my other website might be down. Any suggestions please,

Raid

7 Answers

Paul Frankowski - Staff

More than a month ago #Permalink
Hi,
sorry, but I have to say it.
PHP Version 5.4.45 -- is not supported (!), also by Us, and 90% of companies.
Use at least PHP 5.6. Then we can talk.


medico.png

Attachments (1)

  • medico.png
    medico.png 36.5 KB

Paul Frankowski - Staff

More than a month ago #Permalink
BTW
You are building sites since 2014 or maybe sooner, you should know that upcoming Joomla 4.0 may not even RUN on old PHP. Then what?

PHP 5.4 is full of security bugs, it doesn't matter ?

raidtariq

More than a month ago #Permalink
Hi,

OK. So I will need to upgrade my hosting php to 7.0. However, just your thought here, If I will upgrade the php to 7.0, does the older Joomla website will still run without any problems?

I have about 12 websites on my hosting and to upgrade not a fun if it will blow out all the other website!

Does the older Joomla platform will still running if I will upgrade the PHP version?

Thanks,



Hi,
sorry, but I have to say it.
PHP Version 5.4.45 -- is not supported (!), also by Us, and 90% of companies.
Use at least PHP 5.6. Then we can talk.


[attachment]medico.png[/attachment]

Paul Frankowski - Staff

More than a month ago #Permalink
PHP 5.6 is "safe" for most sites, no problems with legacy.
PHP 7 was big step, so they may be problems with OLD sites, no updated. But you know better what you have there.
----
You can talk with hosting support, maybe there is way to change PHP version only for one site.

raidtariq

More than a month ago #Permalink
Hi,

Thanks for your support. Your opinion is very important to me. Yes, I will call my hosting which is Godaddy and see the options. However, one more question that you might be able to help me with.

I see in the cPanel that I can change the PHP version to: 5.4, 5.5, 5.6, 7.0, 7.1, and 7.2.

Now, if I will change the PHP version to "5.6" and let assuming the old Joomla websites get an issue with it and stopped working. Then, I can downgrade the PHP to 5.4 again, then I am assuming the websites will start running again without getting any issue as it was before. Is that correct?

If yes, then I can change the PHP version and do a test and see if the old websites will work correctly. If not, then I can simply downgrade the PHP version again and everything will works fine.

Thanks,
RAID




PHP 5.6 is "safe" for most sites, no problems with legacy.
PHP 7 was big step, so they may be problems with OLD sites, no updated. But you know better what you have there.
----
You can talk with hosting support, maybe there is way to change PHP version only for one site.

Paul Frankowski - Staff

More than a month ago #Permalink
If your sites do not work with PHP 5.6 - which is also old PHP version, it means that's you have to consider upgrade those other sites.

Joomla Developer Team recommend to use PHP 7.1 or PHP 7.2 for Joomla 3.8.13+
that's why all users see warning message if they have old PHP version.

-----

For test purpose please switch to PHP 7.0 (for 5min) and test Medico template.
Sorry, but I cannot help you with your hosting settings. We cannot jump over PHP limitations.

raidtariq

More than a month ago #Permalink
Alright, I will see which options to go with. Thanks for the support.


If your sites do not work with PHP 5.6 - which is also old PHP version, it means that's you have to consider upgrade those other sites.

Joomla Developer Team recommend to use PHP 7.1 or PHP 7.2 for Joomla 3.8.13+
that's why all users see warning message if they have old PHP version.

-----

For test purpose please switch to PHP 7.0 (for 5min) and test Medico template.
Sorry, but I cannot help you with your hosting settings. We cannot jump over PHP limitations.


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 127
Sifat

Sifat

Total Accepted Answers: 83
Toufiq

Toufiq

Total Accepted Answers: 71
Pavel

Pavel

Total Accepted Answers: 6
Rifat Wahid Alif

Rifat Wahid Alif

Total Accepted Answers: 5

114

Templates

293291

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us