Support Forums

Support Online : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Fixed layout problem in phone browsers..!

Featured Lock Resolved
Hi Joomshaper team the same problem appear in the last templates , as the headline in my website when the layout changed to the fixed the left side of the website hidden how i can fix this problem in the next time ..!!
image from the iphone browser attached ..

THE WEBSITE URL:
http://sudanvolunteers.org/affv
---------------------
THANK U ..

Attachments (1)

  • IMG_0326.PNG
    IMG_0326.PNG 653.3 KB

19 Answers

Rifat Wahid Alif - Staff

More than a month ago #Permalink
well,
i have fixed it in your site. please check it.

Rifat Wahid Alif - Staff

More than a month ago #Permalink
Hi,
you can use responsive layout, otherwise add this code in the bottom of your 'theme.less' file

.fixed{
.body-innerwrapper{
overflow-x: inherit
}
}

Yusuf Saleh

More than a month ago #Permalink
Hi
i am changed to responsive layout .. and added the code in the "theme.less" and no changes !

Rifat Wahid Alif - Staff

More than a month ago #Permalink
please pm me admin access.

Yusuf Saleh

More than a month ago #Permalink
i am sent u the admin access .. thank u

Rifat Wahid Alif - Staff

More than a month ago #Permalink
fixed it. please check your site.

Yusuf Saleh

More than a month ago #Permalink
Hi Rifat thank u for solve 90% from this issue ..
how i can solve the 10% from the same issue .. u can see the image attached ..

Thank u ..

Attachments (1)

  • Untitled-2.png
    Untitled-2.png 231 KB

Yusuf Saleh

More than a month ago #Permalink
Thank u Rifat .. good work its working good now :)

Rifat Wahid Alif - Staff

More than a month ago #Permalink
You are always welcome

Guy Walder

More than a month ago #Permalink
Hello,

I've got the same issue on several of your templates and even posted a forum support thread that got 0 responses from you guys. Can you please post the code to fix this issue?

Regards,

Guy.

Yusuf Saleh

More than a month ago #Permalink
Guy Walder wrote:

Hello,

I've got the same issue on several of your templates and even posted a forum support thread that got 0 responses from you guys. Can you please post the code to fix this issue?

Regards,

Guy.



Hi Guy
Joomshaper team in vocation .. they will coming some and u will get the respond ..

Rifat Wahid Alif - Staff

More than a month ago #Permalink
Hi Guy Walder,
Could you please share your url ?

Guy Walder

More than a month ago #Permalink
Hello Rifat,

Currently I've got two site which are built using your templates that have the non-responsive mobile width issue:
1. http://www.mahash.co.il
2. http://www.rosmanlog.guywalderonline.com/index.php/he

Had an issue with another template of yours in this url: http://www.rosmandeli.guywalderonline.com and managed to solve it by adding this code:

@media (min-width: 980px) and (max-width: 1199px) {	
.container {
max-width: 940px;
}
}

@media (min-width: 768px) and (max-width: 979px) {
.container {
max-width:940px;
}
}

@media (max-width:767px) {
.container {
max-width:480px;
min-width:280px;
}
}

@media (max-width: 480px) {
.container {
max-width:480px;
min-width:280px;
}
}


But, A. it's not perfect and B. I didn't manage to use this solution on the other two sites.

Thank you in advance for your help,

Guy.

Rifat Wahid Alif - Staff

More than a month ago #Permalink
Hi Guy Walder,
if you don't want to use responsive layout then you have to make the layout fixed from template settings 'basic' tab.

Guy Walder

More than a month ago #Permalink
Hi Rifat,

The template is set to Fixed on all three sites!!! Please see attached screen shots for all three sites template manager -> basic.
The problem is with some wrong handling of the screen width when it's set to 1170px. When set to 940px it's o.k.
But, as I wrote in my previous post, I wish my sites to stay with 1170px width.

Please help me fix this bugs in my sites/your templates.

Guy.

Attachments (3)

  • RosmanDeli.jpg
    RosmanDeli.jpg 165.3 KB
  • RosmanLog.jpg
    RosmanLog.jpg 162.6 KB
  • Mahash.jpg
    Mahash.jpg 172.9 KB

Rifat Wahid Alif - Staff

More than a month ago #Permalink
Hi,
if you use fixed layout then '@media' won't work. anyway, for your first sie (http://www.mahash.co.il/)

you have to overwrite 'overflow-x: hidden;' from body

put this css in your theme.less file:

html, body {
overflow-x: inherit !important;
}

body.fixed{
min-width: 1170px;
}


for second & third (http://rosmanlog.co.il/index.php & http://www.rosmandeli.guywalderonline.com/)

html, body {
overflow-x: inherit !important;
min-width: 1170px;
}


- Thanks for your understand

Guy Walder

More than a month ago #Permalink
Hello Rifat,

Thank you for your solution. That worked for all three sites.

Guy.

Rifat Wahid Alif - Staff

More than a month ago #Permalink
Guy Walder.
You are always welcome :)


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Leaderboard (30 days)

Sifat

Sifat

Total Accepted Answers: 122
Paul Frankowski

Paul Frankowski

Total Accepted Answers: 90
Toufiq

Toufiq

Total Accepted Answers: 32
Al Mamun

Al Mamun

Total Accepted Answers: 3
J

johnny

Total Accepted Answers: 3

100+

Templates

200,000+

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us