Support Forums

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Font is not Roboto

Featured Lock Resolved
I am using Minima template. While Roboto font is set (in fact, I haven't changed anything from default) some browsers (windows 7 for example) show Time Roman. Please help.

site is http://yapicentral.com

4 Answers

Jakir hasan - Staff

More than a month ago #Permalink
Hi alecd4,
Please PM your admin access

Thanks

alecd4

More than a month ago #Permalink
Here is what I found out: my site uses https. But template has

link rel="stylesheet" href="http://fonts.googleapis.com/css?family=Roboto:400,100,300,700"


Note http: for gogle url. It must be https:// when URL protocol is https:// As a result font download fails silently of Firefox, gives an error message on IE.

How to fix it?

alecd4

More than a month ago #Permalink
To fix I modified helix.php

self::getInstance()->document->addStyleSheet("https://fonts.googleapis.com/css?family="; . $name);

adding s to http above.

IMHO you should always use https for google fonts regardless of document's protocol.

Any comments?

Jakir hasan - Staff

More than a month ago #Permalink
Hi, You can add font easily from template parameter . See the screenshot https://www.copy.com/s/k8YgXvW1YpYV/font.png

thanks


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Sifat

Sifat

Total Accepted Answers: 152
Paul Frankowski

Paul Frankowski

Total Accepted Answers: 90
Toufiq

Toufiq

Total Accepted Answers: 19
Al Mamun

Al Mamun

Total Accepted Answers: 3
Pavel

Pavel

Total Accepted Answers: 3

112

Templates

289089

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us