Support Forums

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Fonts not loading correctly when using redirected domain name

Featured Lock Resolved Bug
Through .htaccess domain [p] redirect http://customdomain.com, I use a different Domain url then is actually used.

This causes the Google fonts not to load in the menu bar.

Only when the full domain is used http://realdomain.com/cms/etc
the social icons and offcanvas icon are loaded correctly.

7 Answers

Paul Frankowski - Staff

More than a month ago #Permalink
Hi,
if that case you have to (probably) add manually to template path to your fonts according to Google Fonts Creator.
1) Go to fonts.google.com - find your font
2) Select and click Use it
3) You will get a ready code to paste
4) Copy and paste into Custom Code section from Template settings
It may help. If will not you have to wait until you will use final domain without temporary redirection in htaccess,

Rakesh

More than a month ago #Permalink
I placed this code

<link href="https://fonts.googleapis.com/css?family=Open+Sans" rel="stylesheet">

in the Custom Code field: Before </head> but that didn't fix my problem.


It is actually for my final domain, it will stay like this, it's not something temporary.

Still hope there is a fix for this.

Paul Frankowski - Staff

More than a month ago #Permalink
Maybe you should use redirection for Domain panel not via .htaccess.
Please use PM and send me link to your website where you have problem maybe it will help me.
--
I checked Google Fonts FAQ, but there was no info what to do if fonts not work. So it's somehow related with domain redirection.

Rakesh

More than a month ago #Permalink
Pingdom is also giving many error relating to Page Builder:
http://www.DOMAINl/cms/components/com_sppagebuilder/assets/fonts/fontawesome-webfont.woff?v=4.7.0

Will send you the link through PM.

Paul Frankowski - Staff

More than a month ago #Permalink
Have you tried to make redirection via Domain/hosting panel , not via htaccess - it must be a main reason why FontAwesome and Google Fonts are not loaded properly.

Joomla tries to load links from:: /cms/ of current domain.

---
Really please make a real - working redirection, not Duck Tape one !!
Hosting support will help you, I cannot.

Rakesh

More than a month ago #Permalink
I am using htaccess redirect so the URL doesn't change in the address bar, the actual URL needs to stay hidden.

Hope it is clear.

Paul Frankowski - Staff

More than a month ago #Permalink
In that case all links are badly loaded. I am not sure if we can fix it. Because this is not software issue.
---
But you can in Hosting panel change used folder to this one where your final domain is parked.
Please talk with hosting support , how to do this in smart way.


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 227
Sifat

Sifat

Total Accepted Answers: 115
Toufiq

Toufiq

Total Accepted Answers: 92
Pavel

Pavel

Total Accepted Answers: 5
Rifat Wahid Alif

Rifat Wahid Alif

Total Accepted Answers: 4

100+

Templates

200,000+

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us