Support Forums

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

freeslider sp1 has changed

Featured Lock Resolved
i downloaded a new version of free slider sp1
i can no longer specify its width from the module manager??

why did you remove this
because now my slides don't fit the page properly

7 Answers

Jakir hasan - Staff

More than a month ago #Permalink
We have provided responsive support for freeslider sp1 only for this removed fixed width from freeslider sp1 . If you need fixed width slide, you can fixed specific div width for slides.

Steve Loftin

More than a month ago #Permalink
I have an issue with this as well. I have played around with changes to the slide divs, and I can fix the div widths, but no matter what I do, the slide content is set at 940px somewhere in code that I cannot find. It causes the slides to be off center when you stretch the div. I discovered this when I used Firebug and saw that the width for the slides is set automatically in code somewhere at 940px. And when they slide, you see code for "left: 0" change to "left: 940px". Since none of the CSS files seem to contain these settings, where is this setting located? Javascript somewhere possibly? If it is, I can't find that as well. Where is the slide getting the setting of 940px from?

I have searched and searched the CSS for this....

Where is it getting the following information that I see in Firebug? I am using the Zaara template, although I don't know if that matters.

element.style {
width: 940px;
display: none;
margin: 0px;
padding: 0px;
overflow: hidden;
opacity: 1;
position: absolute;
float: none;
height: 340px;
z-index: 0;
left: 940px;
top: 0px;

This is from the style.css stylesheet in modules/mod_freeslider_sp1/assets/css/style.css

.fs-sp1{position:relative}
.fs-sp1-content{background:none}
.fs-sp1-inner{padding:10px}
.fs-sp1-image{float:right;margin:0 0 0 40px}
.fs-sp1-desc{overflow:hidden;position:relative}
h2.fs-sp1-title{font-size:18px;line-height:normal;letter-spacing:normal;margin:5px 0}
.fs-sp1-controllers{height:auto;position:absolute;bottom:10px;left:45%;z-index:1}
.fs-sp1-prev,.fs-sp1-next,.fs-sp1-controllers span,.fs-sp1-controllers span.active{display:block;float:left;height:12px;margin-right:3px;width:12px;cursor:pointer}
.fs-sp1-controllers span,.fs-sp1-controllers span.active{text-indent:-9999px}
.fs-sp1-controllers span{background:url(../images/btn-slider.png) no-repeat scroll 0 0}
.fs-sp1-next{background:url(../images/next.png) no-repeat scroll 0 0}
.fs-sp1-prev{background:url(../images/prev.png) no-repeat scroll 0 0}
.fs-sp1-controllers span.active{background:url(../images/btn-slider-active.png) no-repeat scroll 0 0}

There is no setting for 940px in the custom.css stylesheet as well.

It seems as if you guys missed something in the code when you removed the width editor from the module manager for freeslider.

Steve

We have provided responsive support for freeslider sp1 only for this removed fixed width from freeslider sp1 . If you need fixed width slide, you can fixed specific div width for slides.

Ehsan Riyadh

More than a month ago #Permalink
Probably element.style comes from module parameter. For width You can find -> module manager -> free slider sp1 -> on the right side you can see parameters.

Steve Loftin

More than a month ago #Permalink
No. As per Jakir, the width has been removed from the module manager. That's why I'm asking where to fix the 940px width that appears to be set by default, but that I cannot find in any of the files.

Probably element.style comes from module parameter. For width You can find -> module manager -> free slider sp1 -> on the right side you can see parameters.

Kawshar Ahmed - Senior Staff

More than a month ago #Permalink
Width is no longer required thats why we removed width from the parameter. If you still need to use width then wrap the module in a div then set width for that div.
Thanks

Steve Loftin

More than a month ago #Permalink
OK guys.. please listen.

As Arthur said on January 27th, and as I am trying to tell you guys now... when you guys removed the width parameter in the new version of freesilder, it caused the slides to not format properly by default. As Arthur said, the slides now do not fit the page properly and we both mean "by default". For instance, in Shaper Zaara, I had not changed the width parameter at all. The slides were the correct width with the rest of the page divs and the format of the template. I downloaded the latest version of freeslider to correct some issues with the slider function that you guys corrected. With your changes, you guys removed the width parameter... now the slides are shorter on the right side and do not align with the template. This is now by default and it looks broken. Apparently the width is needed if we want the template to look correct in a standard browser. Removing the width parameter broke something that makes the slides too short on the right side, and this makes the template look incomplete.

And now you guys are telling us we have to deal with it by fixing this issue ourselves, by adding a new div wrapper. Should we have to add a new div wrapper to make the default template function correctly in a browser? I don't think that is an appropriate answer.

Please re-read Arthur's comment: "why did you remove this because now my slides don't fit the page properly".

He is trying to tell you guys something and so am I.

I have done this to show you... I have installed a clean version of the Zaara template on a new site. I've included the before and after by taking a screen shot of the page with the old version of freeslider that comes in the install package, and the page issue after importing the new version of freeslider. I hope this helps you guys understand what we are seeing.

The first attachment is the screenshot from a fresh install. The other is after freeslider was updated. The issue is obvious.

I'm getting far behind on projects trying to fix template errors. Please help.

Thanks...

Steve

Attachments (2)

  • zaara_fresh-install.jpg
    zaara_fresh-install.jpg 171 KB
  • zaara_freeslider-updated.jpg
    zaara_freeslider-updated.jpg 173.5 KB

Kawshar Ahmed - Senior Staff

More than a month ago #Permalink
Hi, remove all codes from custom.css file and add below codes.
Get the code
Now save and refresh your browser and see if its working or not.
Regards


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Sifat

Sifat

Total Accepted Answers: 141
Paul Frankowski

Paul Frankowski

Total Accepted Answers: 90
Toufiq

Toufiq

Total Accepted Answers: 25
Pavel

Pavel

Total Accepted Answers: 4
Al Mamun

Al Mamun

Total Accepted Answers: 3

113

Templates

289591

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us