Support Online : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Front Page Editor Not Working - Possible Solution

Featured Lock Resolved Issue
This post is more for the JoomShaper community and to ease the work given to the support team around what appears to be a frequent issue; the front-end editor not working. I had this problem as well, and after doing some testing with my hosting provider's lead CTO, we found the following.

Are You Using A CDN?
I use CloudFlare and although I was enabling the production mode on their website, it wasn't working. I had to go to the DNS area and turn off the service one-by-one for everything. I have since been told I only need to bypass the A records.

Turn Off Rocket Loader
According to the hosting provider, they found scripts injected in my website, which might be the reason the front-end editor is not working. They suggested turning this off, and if it works, you would not need to manipulate the CDN settings.

Subdomains Are Affected
We found that although I had a CDN for the main website, it also affected the subdomain as well. This means that even though you have signed up for a CDN for your website, it's going to trickle down to everything associated.

WAIT
I also found even though I turned off GZIP, Joomla Cache, CSS compression, Java compression, the CDN, cleared my browser's cache, and placed the website in development mode in SP Pagebuilder, nothing happened.

Even though the CDN told me to wait 30 seconds for the changes to take effect, I found it was more like 5 minutes. So wait for everything to turn off before working on your site.

Joom Shaper Support Team
I would like to publicly thank Toufiq, Paul, and Sifat for their patience and willingness to work with me through private messages to help me solve this issue.

53 Answers

Toufiq - Staff

More than a month ago #Permalink
Hi there,

First of all, Thank you so much for this kind of tips for all of our users. Every user should check these points before posting on our forum. Also, the User should check the third-party plugins.

Some other points should check.
1. PHP version
2. Third party extensions
3. Memory limit (depends on hosting)
4. Shared hosting blocked resource from mod_security
5. Console error check from the browser inspect element
6. Should check the Joomla default Template

-Thanks

martin

More than a month ago #Permalink
I have the same mistake.

Donna

More than a month ago #Permalink
I have the same mistake.


I am having this same issue. What version of PHP does Page Builder work with?

I am on the line with InMotion Hosting. They upgraded my platform to EasyApache 4 and PHP 5.3

I can no longer access any of my SP Page Builder pages. Please help.

Donna

More than a month ago #Permalink
OK, just upgraded to PHP 7.0 and it seems to be working again.
thank you,
Donna

martin

More than a month ago #Permalink
PHP-Version 7.2.16
spb pro 3.4.7

It still doesnt work.
on a few pages

Donna

More than a month ago #Permalink
I've got it working as long a I log on through the front end. The SP PageBuilder pages link to frontend editing don't work at all.

So basically I have to log in to the front end to edit any pages built with SP PageBuilder, cannot get there anymore from logging into the backend as superuser and accessing the Page Builder section and clicking on the Frontend Edit button.

Mike

More than a month ago #Permalink
Hi Donna,

I would submit a separate support ticket to grab the attention of the support team, as this post was made by me to help them out, and may not be followed by them due to the amount of new incoming tickets coming in.

By chance, are you able to see your pages in the back end of SP Page Builder, and when you click to open them, are they blank - meaning no content, add-ons, modules, etc.?

Donna

More than a month ago #Permalink
Mike,

I can see them and the layout structure. It's just that the button that you would click to edit in the frontend produces an error to the screen. It's a bar with the text in it that states:
error screen.jpg

But at this point, I am able to login from the frontend to edit.

Attachments (1)

  • error screen.jpg
    error screen.jpg 487.2 KB

Donna

More than a month ago #Permalink
I should mention that I am using the lastest SP Page Builder with Helix Ultimate.

Easy Apache 4
PHP 7.0

And I have to admit the rest of what is on the list is alien to me. I'm sure I am not the only one using a hosting package and expect it to work without fully understanding all the stuff behind the scenes.

Thanks
Donna

Mike

More than a month ago #Permalink
Donna,

I sent you a PM.

Mike

ssnobben

More than a month ago #Permalink
"..expect it to work without fully understanding all the stuff behind the scenes."

Yes you should then have some support you with these issues bcs the setup for any software to use with its hosting environment is important and necessary

Donna

More than a month ago #Permalink
Just like you don't need to be a coder to use our templates type advertising???

blue_Shift

More than a month ago #Permalink
I gave up - there were script conflicts with a module I use that could only be coming from SPPB, as the same site build in straight Helix Ultimate worked very well. I put everything in modules so front end editing - though not nearly as slick as SPPB's looks to be - is at least available (and my module code now works, too).

Visually, the two sites are identical - and Ultimate is really quite good.

Rick Nelson

More than a month ago #Permalink
I have the same mistake.


I am having this same issue. What version of PHP does Page Builder work with?

I am on the line with InMotion Hosting. They upgraded my platform to EasyApache 4 and PHP 5.3

I can no longer access any of my SP Page Builder pages. Please help.


I had this on one site only. SiteGround hosting said my error was PHP 5.3 issue. switched the site to 5.1 and worked fine.

ssnobben

More than a month ago #Permalink
Hello you should tell your hosting provider to upgrade to php 7.2.17!


PHP 5. is stone age and have bad implication on Joomla for speed, security and general functions.

Upgrade your hosting now and be in line with normal Joomla requirements!

blue_Shift

More than a month ago #Permalink
Above, I noted that I needed to remove SPPB from a site because front end editing didn't work. But I installed it on one of my bigger sites that has a more page-based structure, and everything works as advertised. :)

Marcin

More than a month ago #Permalink
Hi there,
I had the same mistake.
Plugins: System - SEF - Status: Disabled
It works
PHP 7.2.14

Donna

More than a month ago #Permalink
Interestingly enough, you are correct. Disabling the SEF makes the link work in the backend to frontend Editor.

My issue is that I want to have the SEF enabled. Is this something that Joomshaper techs are working on???

Toufiq - Staff

More than a month ago #Permalink
Interestingly enough, you are correct. Disabling the SEF makes the link work in the backend to frontend Editor.

My issue is that I want to have the SEF enabled. Is this something that Joomshaper techs are working on???


Hi there, Thanks for your reply. Please watch the video & read the blog post. I hope this video & blog post will help you.

https://www.youtube.com/watch?v=xMUAbMPnlpw&t=33s

https://www.joomshaper.com/blog/make-your-joomla-site-seo-friendly

-Thanks

Selim Özbay

More than a month ago #Permalink
For my website:
Unpublish JCH
Clean cache
and it works fine...

Toufiq - Staff

More than a month ago #Permalink
For my website:
Unpublish JCH
Clean cache
and it works fine...


Great :)

scottdavis50

More than a month ago #Permalink
With all due respect, why on Earth do developers do this???? Why change things up so much? Why not ask the community what they want instead of guessing? Please read about Steve Jobs: It's all about the user experience.

Why can't I edit an SP Pagebuilder module in the back end? Also, now it won't allow me to create side by side tables. Only horizontal. It amazes me that technology no longer moves forward. It's all about pushing out a product and making money. Additionally, I find it unacceptable that we have to purchase the product AND come up with the solutions. Please fix issues prior to releasing. Totally unacceptable.

martin

More than a month ago #Permalink
I'm afraid he's right.
your product is great, but some updates are unhelpful and even counterproductive.

Donna

More than a month ago #Permalink
I agree. This was working with SEF enabled and then it stopped. This is an important feature and this bug should be fixed ASAP! It use to work and yet I'm not seeing anything posted here from the authors of the software.

Prestomaniac

More than a month ago #Permalink
I was having the same issue. If you are forcing HTTPS that's the problem. It was for me anyway. I turned off Force https and it worked. That needs to be fixed as google now requires https.

Scott Eagle

More than a month ago #Permalink
it can be a number of things but fr me many times has been php 5.6 vs 7.1 or 7.2 I would try changing php before anything else. I have literally moved a site built on 7.1 to a new server and page builder kept getting 500 error. I switched to 5.6 and all is well.. To me that does not make sense but I would first try php version and sef url and check .htaccess. TRY SWITCHING PHP FIRST wether up or down.

Donna

More than a month ago #Permalink
I was having the same issue. If you are forcing HTTPS that's the problem. It was for me anyway. I turned off Force https and it worked. That needs to be fixed as google now requires https.


Apparently that is also my issue. I have switched to SSL so that I am now https:// and have a redirect. However, I have read that one should not re-write the php.configuration $live site line. I'm at a loss. I can get in the front end to edit by logging in on the front end, but it would be nice to be able to edit through the backend pagebuilder.

Toufiq - Staff

More than a month ago #Permalink
I was having the same issue. If you are forcing HTTPS that's the problem. It was for me anyway. I turned off Force https and it worked. That needs to be fixed as google now requires https.


Apparently that is also my issue. I have switched to SSL so that I am now https:// and have a redirect. However, I have read that one should not re-write the php.configuration $live site line. I'm at a loss. I can get in the front end to edit by logging in on the front end, but it would be nice to be able to edit through the backend pagebuilder.


Hi there, You can edit backend from Joomla administrator area. Did you try? And is there any problem. Thanks

Donna

More than a month ago #Permalink
I was having the same issue. If you are forcing HTTPS that's the problem. It was for me anyway. I turned off Force https and it worked. That needs to be fixed as google now requires https.


Apparently that is also my issue. I have switched to SSL so that I am now https:// and have a redirect. However, I have read that one should not re-write the php.configuration $live site line. I'm at a loss. I can get in the front end to edit by logging in on the front end, but it would be nice to be able to edit through the backend pagebuilder.


Hi there, You can edit backend from Joomla administrator area. Did you try? And is there any problem. Thanks


Not sure what you are asking. I cannot get to the frontend edit from the backend. Are you saying I should edit the php.config file from the Joomla admin area?

David Burgoa

More than a month ago #Permalink
Hi there,

First of all, Thank you so much for this kind of tips for all of our users. Every user should check these points before posting on our forum. Also, the User should check the third-party plugins.

Some other points should check.
1. PHP version
2. Third party extensions
3. Memory limit (depends on hosting)
4. Shared hosting blocked resource from mod_security
5. Console error check from the browser inspect element
6. Should check the Joomla default Template

-Thanks

-----------------------------------------------------------------------------------------------------------------------------------------------------
Hi,

I am very new to website development. I am unable to use the FrontEnd Editor. I get this message. If someone could do a dummy step-by-step to fix this issue it will be greatly appreciated.

Our company has used Joomla for a while, but the person left and none of us understands it. I found the SP Page Builder to kind of simplify the task of adding stuff, editing etc. through the FrontEnd Editor.

Attachments (1)

  • Untitled.jpg
    Untitled.jpg 104.9 KB

Donna

More than a month ago #Permalink
Interestingly enough, you are correct. Disabling the SEF makes the link work in the backend to frontend Editor.

My issue is that I want to have the SEF enabled. Is this something that Joomshaper techs are working on???


Hi there, Thanks for your reply. Please watch the video & read the blog post. I hope this video & blog post will help you.

https://www.youtube.com/watch?v=xMUAbMPnlpw&t=33s

https://www.joomshaper.com/blog/make-your-joomla-site-seo-friendly

-Thanks


I tried this per the blog and it destroyed my links. I had to turn of the "rewriting" or none of my links work.

Toufiq - Staff

More than a month ago #Permalink
Interestingly enough, you are correct. Disabling the SEF makes the link work in the backend to frontend Editor.

My issue is that I want to have the SEF enabled. Is this something that Joomshaper techs are working on???


Hi there, Thanks for your reply. Please watch the video & read the blog post. I hope this video & blog post will help you.

https://www.youtube.com/watch?v=xMUAbMPnlpw&t=33s

https://www.joomshaper.com/blog/make-your-joomla-site-seo-friendly

-Thanks


I tried this per the blog and it destroyed my links. I had to turn of the "rewriting" or none of my links work.


Hi there, Thanks for your reply. You apply the wrong process of SEO friendly. Please fix your SEO from the htaccess file. Thanks

Donna

More than a month ago #Permalink
I did. I also tried to copy/paste the htaccess file here for you to see, unfortunately that didn't work.

I did comment out the two lines per the direction, went in and changed to YES on rewrite and nothing worked so I had to turn off the Rewrite in global configuration.

Donna

martin

More than a month ago #Permalink
It's the hoster.
i still have the problem. i don't know where the mistake is.
now i am building the homepage on my localhost.

Toufiq - Staff

More than a month ago #Permalink
It's the hoster.
i still have the problem. i don't know where the mistake is.
now i am building the homepage on my localhost.


Hi there, Thanks for your reply. Please upload your site live server and share with me your URL. Thanks

martin

More than a month ago #Permalink
i have send;)

Toufiq - Staff

More than a month ago #Permalink
i have send;)


Hi there, I will check next working day. Thanks

martin

More than a month ago #Permalink
the problem with editing in the frontend is still there.
both at the hoster and via my localhosthttp://prntscr.com/o7vf8b

Andy

More than a month ago #Permalink
Hi All

I have also had a problem with the front end editor, i was getting 404 error when trying to access any of my pages, for me the problem turned out to be a problem with search engine friendly urls (SEF) being rewritten incorrectly, I have Artio JoomSEF plugin installed which seemed to be causing the problem, When I switched SEF off or switched off the plugin, everything was working again.

So third party SEF plugins may cause conflicts

Hope this help somebody

Andy :)

pizzoferro

More than a month ago #Permalink
Good morning, I also have the same problem.
Abcmare.it Website

I tried to clear the cache.
I do not use JCH.
PHP Version 7.3.3
I don't use CDN.
What can I do?

Grazie

Brian Craigie

More than a month ago #Permalink
Do you use Admintools on the site? It can cause these issues if the security is too tight.

martin

More than a month ago #Permalink
nope

pizzoferro

More than a month ago #Permalink
Do you use Admintools on the site? It can cause these issues if the security is too tight.

NO
can anyone provide support?

Brian Craigie

More than a month ago #Permalink
Uncommenting rewritebase in .htaccess fixed it for me. Before you do so, ensure you use the htaccess that was supplied with Joomla. It is called htaccess.txt and you rename it (or copy it) to .htaccess and then edit it.

pizzoferro

More than a month ago #Permalink
Uncommenting rewritebase in .htaccess fixed it for me. Before you do so, ensure you use the htaccess that was supplied with Joomla. It is called htaccess.txt and you rename it (or copy it) to .htaccess and then edit it.

Grazie!!
Good advice.
I restored the original joomla htaccess, re-entered some 301 and for now everything works.
Thanks again

ssnobben

More than a month ago #Permalink
I have the same problem and will investigate my Joomla master htaccess file that been working for 6 years :(

Have same problem too and dont know if anyone have Joomla bad page cache plg & htaccess problem to solve.

Tips to not use Joomla plg cache is to check if your web hoster have Litespeed caching thats a good stable speed improvement for Joomla and use a Joomla litespeed plg & com. Joomla standard plg caching not working well still.. :'(

https://www.litespeedtech.com/products/cache-plugins/joomla-acceleration
https://openlitespeed.org/kb/litespeed-cache-for-joomla-on-openlitespeed/

Download latest version - download zip
com https://github.com/litespeedtech/lscache-joomla
Plg https://github.com/litespeedtech/lscache-joomla

Rod Martin

More than a month ago #Permalink
This is AN ONGOING ISSUE.

Turn Search Engine Friendly URL's OFF and Front end editing works fine.
Turn it on - and you get the 404 page not found error

the link becomes /edit/3 (or whatever the ID is)... and it just fails.

this really really needs to get fixed.

Donna

More than a month ago #Permalink
This is AN ONGOING ISSUE.

Turn Search Engine Friendly URL's OFF and Front end editing works fine.
Turn it on - and you get the 404 page not found error

the link becomes /edit/3 (or whatever the ID is)... and it just fails.

this really really needs to get fixed.


I totally agree. Spend some time fixing issues that exist instead of continuing to produce more templates.

Alexander van Aken

More than a month ago #Permalink
I didn't read the post carefully, but I can remember having this when I used a plugin code tag inside like {rsform 4} which results in non editeble frontend..

Toufiq - Staff

More than a month ago #Permalink
I didn't read the post carefully, but I can remember having this when I used a plugin code tag inside like {rsform 4} which results in non editeble frontend..


Hi there, The Page Builder doesn't support the shortcode. For the shortcode occurred the problem of front end editing. Thanks

ayko

More than a month ago #Permalink
Hello,

same issue on my site.
No Frontend-editing possible anymore and js-error:

"Uncaught ReferenceError: initialState is not defined"


already checked:
- turn off all caching and caching plugins
- clean all caches
-disabling SEF and htaccess usage
- usage of original htaccess
- disabling Gzip
- used chrome and firefox for tests

PHP-Version: 7.2.22-he.0 (updated to 7.3 meanwhile)
no CDN
no rocket Loader

Admintools:
What I need to do if I use admintools in the free basic version? (.. see comment one month ago regarding admintools)

best regards,
Frank

update 19.09.2019:
Toufiq solved it.
Solution-steps:
- reinstall sp page builder component/plugin (optional)
- disabling gzip

Toufiq - Staff

More than a month ago #Permalink
Hello,

same issue on my site.
No Frontend-editing possible anymore and js-error:

"Uncaught ReferenceError: initialState is not defined"


already checked:
- turn off all caching and caching plugins
- clean all caches
-disabling SEF and htaccess usage
- usage of original htaccess
- disabling Gzip
- used chrome and firefox for tests

PHP-Version: 7.2.22-he.0
no CDN
no rocket Loader

Admintools:
What I need to do if I use admintools in the free basic version? (.. see comment one month ago regarding admintools)

best regards,
Frank


Hi there, Sorry for the inconvenience. Could you send me the administrator access via PM? Thanks
This is AN ONGOING ISSUE.

Turn Search Engine Friendly URL's OFF and Front end editing works fine.
Turn it on - and you get the 404 page not found error

the link becomes /edit/3 (or whatever the ID is)... and it just fails.

this really really needs to get fixed.


I totally agree. Spend some time fixing issues that exist instead of continuing to produce more templates.


Same situation over here. Even Toufiq was in the backend of the site and could't fix it!!

Still waiting for a fix after install the last release (3.6.2), but JoomShaper just ignore the comments of those of us that can't fix through the suggested "work arounds". WORK AROUNDs are NOT a real fix! However, I tried all the suggestions and nothing worked neither.

Only disabling SEF works, but then you have a site with horrible URLs! That's not a fix form a modern website!!!

The real problem in in the root code of PB. It's an issue with the edit links that PB generate to the frontend edit..

PBuilder generate an edit link to: http://website.com/page/edit/PageNumber, when should send to http://website.com/component/sppagebuilder/?view=form&layout=edit&tmpl=component&id=pagenumber.

Can we expect a real solution?


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 132
Toufiq

Toufiq

Total Accepted Answers: 103
Sifat

Sifat

Total Accepted Answers: 68
RV

RAFFAELE VIOLA

Total Accepted Answers: 2
DS

Dustin Swayne

Total Accepted Answers: 1

116

Templates

299825

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us