We’re with you. JoomShaper is offering a 20% Discount on all plans due to the impact of COVID-19

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Τhe OG image, title and tags is not working.

Featured Lock Resolved Issue
I m using latest SP Page builder and Floox. I have set up the OG properly and when i run a test of the site it shows that it is all good:
my website: https://www.ioniancars.gr/
Tested here: http://www.opengraphtester.com/test/
but when i try to upload in facebook, it shows some random images from site.
What is going on? I think it may be Floox that blocks as in every site that i use it i see the same problem but how and the most important, HOW can we fix this?

8 Answers

Paul Frankowski - Staff

More than a month ago #Permalink
Hi,
use that tool to debug problems:
https://developers.facebook.com/tools/debug/sharing/

---
in Page there are OG settings, remember to choose image.

Agg Gio

More than a month ago #Permalink
Yes i know. Here are my settings:
https://prnt.sc/ne09xq
but when i try the debug tool you proposed, i see no image.

In the code i also see the og image:
https://prnt.sc/ne0b5a

Something very strange is happening on every site that i use Floox.

Paul Frankowski - Staff

More than a month ago #Permalink
We do not have control what FB reads and what not if the proper code is there.
---
But I have idea
add this

<meta property="og:image" content="https://www.ioniancars.gr/images/ionianCarsOG.jpg" />

inside template settings, in Custom code > In Head

KE Comm

More than a month ago #Permalink
I have the issue that my Opengraph meta tags are not showing at all.
Do I need a Facebook app ID for it in order to work?

Paul Frankowski - Staff

More than a month ago #Permalink
Do I need a Facebook app ID for it in order to work?

It's a question for Facebook support, not for us,
but as I know not. Check FB developer tool - the link is above.

Anytime you can disable OG from SPPB from Options,
and install an extra plugin for this.

KE Comm

More than a month ago #Permalink
I think I found the problem. I installed the component TAGZ, which has a setting to suppress OG data from other components and plugins, which was enabled.

Now it seems to work just fine without FB App ID.

Sorry and thanks!

Paul Frankowski - Staff

More than a month ago #Permalink
I always repeat, the more extra extensions you'd install, the more time it would take to find a source of problems.

OG always worked without FB App ID


There are no replies made for this post yet.
Be one of the first to reply to this post!

123

Templates

327072

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us