Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

"Helix Blog Options" tab not available when editing from frontend

Featured Lock Resolved Task
Hi,

NB : this concerns all Helix3 templates

One of the big advantages I see in Helix templates is that "Helix Blog Options" tab in the Articles.
That way, people can nicely add videos, images etc, with a nice & uniform layout for the whole site.

But unfortunately, that tab is NOT available when editing from front-end...
... that is particularly sad because end-users do edit from front-end, not from back-end.

Could you please correct for this in the next version (or tell how can I workaround already) ?

Txs !

Marc

50 Answers

Toufiq - Staff

More than a month ago #Permalink
Hi,

Thanks for your query. This feature does not exist in front end. I would request to you that, please create a issue in our github repository.

http://gihub.com/joomshaper

-Thanks

Marc Dechèvre

More than a month ago #Permalink
done ! :-)
txs
Marc

Toufiq - Staff

More than a month ago #Permalink
Marc Dechèvre wrote:

done ! :-)
txs
Marc


Hi, You are most welcome & Thanks

kmaciej

More than a month ago #Permalink
Hi
Is anything changed in this topic? I see that it is marked as solved - but despite several helix3 updates the "Blog options" tab still isn't visible from the front editing

Best regards

Marc Dechèvre

More than a month ago #Permalink
Hi kmaciej
You're right : this issue is not solved yet it seems.
See my feature request on Github : https://github.com/JoomShaper/Helix3/issues/40

@JoomShaper : when will the "Blog options" be available in front-end ?
I know you were busy with the new PageBuilder at that time, but now it should come as a priority :-)

Toufiq - Staff

More than a month ago #Permalink
Hi,

Thanks for your reply. We will add post format in front end as soon as possible. Hopefully, it will be added asap. Please keep in touch with us.

-Thanks

Marc Dechèvre

More than a month ago #Permalink
Txs a lot !
That will be great :-)

Toufiq - Staff

More than a month ago #Permalink
Txs a lot !
That will be great :-)


Hi, You are most welcome & Thanks

iamtoast

More than a month ago #Permalink
I know this thread is a bit old now, but I was wondering if this was ever addressed/ resolved? I ask because I have a team of editors that need to add the blog image, but currently that involves having back end access. I don't want all the editors for the Newedge template being in the backend of the website.

Kind regards,
Chris

Toufiq - Staff

More than a month ago #Permalink
Hi,

Please following the instruction.

1. Update Helix3 plugin
2. Download the attachment and replace the below file location
templates/shaper_newedge/html/com_content/form/

-Thanks

Attachments (1)

  • edit.zip 2.6 KB

Marc Dechèvre

More than a month ago #Permalink
Txs Toufiq,
See the following exchange : https://www.facebook.com/groups/helix.framework/?multi_permalinks=1296372023818003&comment_id=1305435076245031¬if_id=1507282347234846¬if_t=like

Actually, your edit.php file is still not showing the Tabs of the Custom Fields...
Can you please fix that ?
Txs !

Toufiq - Staff

More than a month ago #Permalink
Txs Toufiq,
See the following exchange : https://www.facebook.com/groups/helix.framework/?multi_permalinks=1296372023818003&comment_id=1305435076245031¬if_id=1507282347234846¬if_t=like

Actually, your edit.php file is still not showing the Tabs of the Custom Fields...
Can you please fix that ?
Txs !


Hi, Send me your site access via pm. Thanks

Marc Dechèvre

More than a month ago #Permalink
Just send me the right edit.php for Helix template (I am not allowed to created new users : that site is about to go in Production)
It will also take you (and me) less time.
I will take care of the copy-paste (the issue is universal anyway, not linked to my sites. I use Helix Framework on tens of sites...).

Txs !

Toufiq - Staff

More than a month ago #Permalink
Hi, Please send me the FTP login details via pm. Thanks

Toufiq - Staff

More than a month ago #Permalink
Just send me the right edit.php for Helix template (I am not allowed to created new users : that site is about to go in Production)
It will also take you (and me) less time.
I will take care of the copy-paste (the issue is universal anyway, not linked to my sites. I use Helix Framework on tens of sites...).

Txs !


Hi, Please try to upload the image now from the front end and let me know. Thanks

Marc Dechèvre

More than a month ago #Permalink
Txs Toufiq.
I never spoke op uploading an image (?).
I have just checked : the Custom Fields Tabs are still not there. Can you FIX that ?
Txs

Toufiq - Staff

More than a month ago #Permalink
Hi, I have replied you via pm. Thanks

Marc Dechèvre

More than a month ago #Permalink
Txs Toufiq,
Here is the screenshot here as well, so that everybody can follow :

As you know, since 3.7, Joomla has Custom Fields. When editing (front-end and backend), Joomla shows natively an extra Tab for the created Fields.
Here is the screenshot of a website made with Helix : when I disable Helix's edit.php file, then the Fields Tab does indeed normally appear. But with Helix's edit.php file, it does not appear (and some other things are also missing from Helix's edit.php file since the native one has evolved, like for integrating Captcha etc. See the differences for yourself).

So here is the screenshot :

https://screenpresso.com/=XSPrd

iamtoast

More than a month ago #Permalink
Txs Toufiq,
Here is the screenshot here as well, so that everybody can follow :

As you know, since 3.7, Joomla has Custom Fields. When editing (front-end and backend), Joomla shows natively an extra Tab for the created Fields.
Here is the screenshot of a website made with Helix : when I disable Helix's edit.php file, then the Fields Tab does indeed normally appear. But with Helix's edit.php file, it does not appear (and some other things are also missing from Helix's edit.php file since the native one has evolved, like for integrating Captcha etc. See the differences for yourself).

So here is the screenshot :

https://screenpresso.com/=XSPrd


I'm not staff, but I believe the reason behind that is, when creating a custom field captcha, etc., it saves to the edit.php file. When the new file is uploaded, it's a regular edit.php file, with the new Helix tab, so it doesn't have one's custom fields (as it would be impossible to).

I don't have any custom fields, so I didn't notice any differences. I believe the way to resolve this would simply be to have the code for the Helix part and add it to the edit.php file. Then, it should simply add to whatever is already there, thus solving this problem. It's just a theory though.

Chris.

Marc Dechèvre

More than a month ago #Permalink
Hi Chris,
You have the point : JoomShaper should just take 5 minutes to update their edit.php file looking at what has changed in Joomla's original edit.php file...
Or even better : JoomShaper should check whether it is still necessary to override Joomla's native edit.php.

So I try to be patient and I wait for the solution and eventually for the update :-)

pepperstreet

More than a month ago #Permalink
... JoomShaper should just take 5 minutes to update their edit.php file looking at what has changed in Joomla's original edit.php file... Or even better : JoomShaper should check whether it is still necessary to override Joomla's native edit.php.


Totally agree with you. Actually, the custom fields tab is loaded by 1 line in the original edit.php
The "issue" is, that the Helix3 edit.php has a manually hard-coded tabs-set.
If you just insert the Joomla code line it does load the extra tabs, but they do not integrate into the existing Helix tabs.
It's in the final markup and output, just hidden.

Toufiq - Staff

More than a month ago #Permalink
Hi,

I have solved your problem. Please check now.

templates/shaper_helix3/html/com_content/form/edit.php

-Thanks

Attachments (1)

  • edit.zip 2.3 KB

Marc Dechèvre

More than a month ago #Permalink
Hi !
Excellent : the Custom Fields Tab does now indeed appear in front-end edition. Excellent ! Txs Toufiq :)

One issue which is left now : when you click on the Tab "Images and Links" in front-end edition, there is an issue with the Modal (you cannot exit anymore). One of your colleagues has produced a new frontend-edit.less the other day, but it seems it does not solve the issue with your edit.php.

And finally, one question : as soon as the Modal issue is solved, when do you update Helix Framework, Helix Template and all the other Templates so that front-end edition is possible for all ?

Txs for the good work,

Marc

Toufiq - Staff

More than a month ago #Permalink
Hi, Problem solved.Thanks

Marc Dechèvre

More than a month ago #Permalink
Txs Toufiq.
You say "problem solved", but is it the .less file or the edit.php file you have just fixed for that modal issue ?

Please post the right file here, so that I can correct it on all my sites.

Marc

PS : by the way, when do you release a fixed version of all all your templates ?

Toufiq - Staff

More than a month ago #Permalink
Hi,

Please check your custom.css file last line CSS code.

-Thanks

Marc Dechèvre

More than a month ago #Permalink
OK, so here is the FIX so that everybody having the issue can enjoy the solution
/* added by JoomShaper to avoid the modal issue with front-end editing */
.input-prepend a.modal.btn {
position: relative;
}

Again, can you please tell us when JoomShaper will release a FIXED version of Helix and of the other templates (regarding the issues of (i) Custom Fields and (ii) of Modal) ?

Toufiq - Staff

More than a month ago #Permalink
OK, so here is the FIX so that everybody having the issue can enjoy the solution
/* added by JoomShaper to avoid the modal issue with front-end editing */
.input-prepend a.modal.btn {
position: relative;
}

Again, can you please tell us when JoomShaper will release a FIXED version of Helix and of the other templates (regarding the issues of (i) Custom Fields and (ii) of Modal) ?


Hi, We will let you know via blog post. Thanks

Marc Dechèvre

More than a month ago #Permalink
Hi,
Front-end edition still does not work correctly !
It still does not show the Custom Fields TAB.
Can you please have it fixed in next release of Helix Framework ?
Txs !

Toufiq - Staff

More than a month ago #Permalink
Hi,

Download the edit.php file and replace the below location

templates/shaper_helix3/html/com_content/form/edit.php

add this css code inside custom.css file

a.modal.btn {
position: relative;
}


Here is working fine.
https://prnt.sc/hywzks

-Thanks

Attachments (1)

  • edit (1).zip 2.3 KB

Marc Dechèvre

More than a month ago #Permalink
Txs Toufiq,
Very nice of you.

But the most important now : can you please include that fix in the next Helix3 Framework ?
Because otherwise I have to do that manually on tens of sites everytime (as I have done so far) :)
Txs very much indeed !

Toufiq - Staff

More than a month ago #Permalink
Txs Toufiq,
Very nice of you.

But the most important now : can you please include that fix in the next Helix3 Framework ?
Because otherwise I have to do that manually on tens of sites everytime (as I have done so far) :)
Txs very much indeed !


Hi, We will fix it next update. Thanks

webfeuerflo

More than a month ago #Permalink
This is not fixed in the latest version!! I had to change the edit.php file and the css on 2.5!

pepperstreet

More than a month ago #Permalink
Please correct me if I am wrong… but as far as I can tell, the issues are still present in the latest release:
Helix3 v.2.5.2

- No Custom Fields tab
- Modal windows content messed up / bad styling (media, articles, menus etc.)
- Blog Options tab / all Post formats options show up at the same time

Sorry, I am losing my faith…

Marc Dechèvre

More than a month ago #Permalink
Txs for the feedback @pepperstreet.
I am also tired of waiting for these fixes.
Please JoomShaper, fix these issues : you are wasting more time on the forum giving the workarounds than fixing those issues for good ;)

Toufiq - Staff

More than a month ago #Permalink
Hi there,

I have checked Helix3 2.5.2 version and its working fine.

http://prntscr.com/j4rjq9

-Thanks

pepperstreet

More than a month ago #Permalink
I have checked Helix3 2.5.2 version and its working fine.


Please, do me a favor and enable Joomla core article images and also custom fields.
Maybe I get different results because of using all 3 features together...!?
Also check the editor's modal windows / XTD-buttons!

Thanks in advance.

UPDATE:
One issue I found with Helix3 v2.5.2 edit.php is the CORE IMAGES tab. The media field seem to load the OLD MOOTOOLS stuff, modal and JUI Bootstrap2! Probably this causes the weird Blog Options parameter display.
Also check the PROTOSTAR template for reference. Apparently there are 3 field overrides in ../HTML/layouts/joomla/form/field/.., including MEDIA field.

Marc Dechèvre

More than a month ago #Permalink
Hi Toufiq,
You're saying that everything is fine, but I do not see the Custom Fields tab on your screenshot ;)
(plus please also check the other points also mentionned by pepperstreet of course)

Toufiq - Staff

More than a month ago #Permalink
Hi there,

Here is the initial solution.

https://drive.google.com/file/d/1cnp1LtoNlSVVldcBdNfQq6Yn6Z51uNba/view

-Thanks

Marc Dechèvre

More than a month ago #Permalink
Thank you Toufiq.
Excellent, so your video does confirm :
1. for the modal window, there is an issue with the CSS
2. for the Custom Fields to appear in front-end, edit.php should be deleted or fixed

So please, this is the point : can you correct 1. and 2. for the next release :
- of Helix Template
- and also of all the other templates (same issues !)

Txs
:)

Toufiq - Staff

More than a month ago #Permalink
Thank you Toufiq.
Excellent, so your video does confirm :
1. for the modal window, there is an issue with the CSS
2. for the Custom Fields to appear in front-end, edit.php should be deleted or fixed

So please, this is the point : can you correct 1. and 2. for the next release :
- of Helix Template
- and also of all the other templates (same issues !)

Txs
:)


Sure, We will fix it next update. Thanks

Marc Dechèvre

More than a month ago #Permalink
Excellent
(I have already been told sereral time this, so hopefully the next release will be the good one ;) )

Toufiq - Staff

More than a month ago #Permalink
Excellent
(I have already been told sereral time this, so hopefully the next release will be the good one ;) )


Hi, We will do it asap. Thanks

pepperstreet

More than a month ago #Permalink
Hi, We will do it asap. Thanks

Thanks for confirmation and quick tests in your video…
although ALL of these issues has been explained and reported a long time ago! ;)

Please, apart from basic working functionality…
do not forget about the visual presentation!
See media field button style and tooltips.
Most importantly do not forget about the modal windows!
FYI – there are 2 different modals: One from the media field, and another from the TinyMCE editor!

Toufiq - Staff

More than a month ago #Permalink
Hi, We are in the testing mode new fix. It will release soon. Thanks

pepperstreet

More than a month ago #Permalink
I have tested the EDIT.PHP posted in the forum by "Rifat",
and also the latest release of HELIX3 v2.5.3.

I have still a display issue with BLOG OPTIONS parameters:
The POST FORMATS parameters are displayed all at the same time.
This happens on NEW article submissions, where NO format has been selected before.
As soon as I select a specific format, the other format options are hidden.
On EDIT everything is normal.

I guess it should default to "Standard" post format.
The issue is re-creatable in FRONTEND only.

helix3_v253_blogoptions_frontend_issue.png

Attachments (1)

  • helix3_v253_blogoptions_frontend_issue.png
    helix3_v253_blogoptions_frontend_issue.png 56.4 KB

Toufiq - Staff

More than a month ago #Permalink
I have tested the EDIT.PHP posted in the forum by "Rifat",
and also the latest release of HELIX3 v2.5.3.

I have still a display issue with BLOG OPTIONS parameters:
The POST FORMATS parameters are displayed all at the same time.
This happens on NEW article submissions, where NO format has been selected before.
As soon as I select a specific format, the other format options are hidden.
On EDIT everything is normal.

I guess it should default to "Standard" post format.
The issue is re-creatable in FRONTEND only.

[attachment]helix3_v253_blogoptions_frontend_issue.png[/attachment]


Hi, I have checked also & it's working fine.

https://drive.google.com/file/d/1b3Y3CDsyEARuEY6YwLcijqeHdtFfCCGP/view

-Thanks

pepperstreet

More than a month ago #Permalink
Please, re-read my previous comment. Apparently this happens on NEW articles, only. You can't see the issue while EDITING.

The backend seem to enable the default STANDARD post format.
The FRONTEND does not.

Toufiq - Staff

More than a month ago #Permalink
Please, re-read my previous comment. Apparently this happens on NEW articles, only. You can't see the issue while EDITING.

The backend seem to enable the default STANDARD post format.
The FRONTEND does not.


Hi there, Yes got it the problem. Hold on for the next release. Thanks


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 107
Toufiq

Toufiq

Total Accepted Answers: 66
Sifat

Sifat

Total Accepted Answers: 47
Mehtaz Afsana Borsha

Mehtaz Afsana Borsha

Total Accepted Answers: 21
Rashida Rahman

Rashida Rahman

Total Accepted Answers: 17

118

Templates

305705

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us