Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Helix II Issue - Can't login to the backend

Featured Lock Resolved Issue
Dear JoomShaper,

I use all your templates for websites, and I love them. I am having an issue with one, however,


It is the Helix II Template - I can't login to the backend. When I go to login under Joomla administrator, it goes straight to the front end of the website.

Upon response, I will provide the url to the site in question via private message.

Sincere Thanks,

Brent

20 Answers

Paul Frankowski - Staff

More than a month ago #Permalink
why v2.2 , not 2.5 hmm?
UPDATE

Sometimes I don't understand users. We give them updates and they ..."do not need" them, but want to remove issue. :p 2.5.png

Attachments (1)

  • 2.5.png
    2.5.png 14.6 KB

Paul Frankowski - Staff

More than a month ago #Permalink
Hi Brent,
are you sure it's problem related with front-end template,
or maybe your site was hacked, or you installed extra plugin which damaged login?
Joomla template cannot block login to joomla admin, not this area of privileges.

Think harder, and tell me :
1) When last time you succeed login into admin
2) Did you installed or updated something after
3) What template you have there, name & developer. Or it's our old theme. I'm curious.

---
Beside You have SPPB Subscription only. Which means that template support if any, is limited.

Brent Robinson

More than a month ago #Permalink
Hi Brent,
are you sure it's problem related with front-end template,
or maybe your site was hacked, or you installed extra plugin which damaged login?
Joomla template cannot block login to joomla admin, not this area of privileges.

Think harder, and tell me :
1) When last time you succeed login into admin
2) Did you installed or updated something after
3) What template you have there, name & developer. Or it's our old theme. I'm curious.

---
Beside You have SPPB Subscription only. Which means that template support if any, is limited.


Paul,

It is the Helix II Template from JoomShaper.
I have just been updating it as Joomla updates have come out. I stay on top of it, but I have not added any plugin, module, etc.

A few weeks ago the problem occurred.

I am going to be upgrading to the higher SPPB for multiple sites in the next week as I am building another site.

The website is http://www.elvistreeclimber.com

Any help is appreciated, I am in the dark and need to update the contact form.

Sincerely,

Brent Robinson

Brent Robinson

More than a month ago #Permalink
Paul,

It is the Helix II Template from JoomShaper.
I have just been updating it as Joomla updates have come out. I stay on top of it, but I have not added any plugin, module, etc.

A few weeks ago the problem occurred.

I am going to be upgrading to the higher SPPB for multiple sites in the next week as I am building another site.

The website is http://www.elvistreeclimber.com

Any help is appreciated, I am in the dark and need to update the contact form.

Sincerely,

Brent Robinson

Paul Frankowski - Staff

More than a month ago #Permalink
As far as I understand, you have there SPPB installed. It may be clue...
I am not sure if this help, but please try.
DELETE that folder : administrator\modules\mod_sppagebuilder_admin_menu

and try to login again.

Brent Robinson

More than a month ago #Permalink
I don't have SPPB on this site, it just stopped working.

Paul Frankowski - Staff

More than a month ago #Permalink
In that case maybe you have damaged core files.
Download Joomla package, the last version, and upload/replace via FTP all files from folders:

/administrator
/plugins

If this will not help you have to hire someone to unlock your site (it can cost some $).
Or find backup from time where all worked as it should (cheaper)

I had similar cases , but here I could give you only basic tips.

Brent Robinson

More than a month ago #Permalink
Hey Paul,

So I used many different akeeba backups of the Helix II Template I have and now I can get into the backend, however, when I update any of them to Joomla 3.8.8 I get these errors on Sucuri Site Checker:

Site Issue Found
https://www.elvistreeclimber.com/404testpage4525d2fdc
Definition
warning.500_internal_error?1
Site Issue Found
https://www.elvistreeclimber.com/404javascript.js
Definition
warning.500_internal_error?1
Please any help?

Thanks,

Brent

Paul Frankowski - Staff

More than a month ago #Permalink
File "404javascript.js" is not from Joomla nor our products , it means that "probably" your site was infected.
Please contact with Sucuri support.

Brent Robinson

More than a month ago #Permalink
It was not Securi, they are notorious for false warnings. The problem is the Helix II template is incompatible with new version of Joomla.

The file /public_html/templates/shaper_helix_ii/error.php
has an error due to the head.php file no longer being a Joomla core file and was recently removed from Joomla core.

I was hoping for more guidance, this is a client's site and had been working until the update.

Paul Frankowski - Staff

More than a month ago #Permalink
please delete "error.php" file from template folder and check again.
Don't worry in that case Joomla will use default error view.

Helix II is very old product, soon we probably we stop support it. I strongly suggest to consider migration to new helix.

Brent Robinson

More than a month ago #Permalink
please delete "error.php" file from template folder and check again.
Don't worry in that case Joomla will use default error view.

Helix II is very old product, soon we probably we stop support it. I strongly suggest to consider migration to new helix.


I will definitely be upgrading to one of your newer templates, but is there a comment I could add to the code adjust for the head.php file for now?

I just want the 500 errors to be corrected

Sincere Thanks,

Brent

Paul Frankowski - Staff

More than a month ago #Permalink
1.You have the last Helix II template version installed?
2.Please share/upload screenshot with error. I can ask developer.

Brent Robinson

More than a month ago #Permalink
1.You have the last Helix II template version installed?
2.Please share/upload screenshot with error. I can ask developer.


Securi shows the result in the screenshot. When I go back to older versions of Joomla with Akeeba (before 3.8.8), Securi no longer shows this error, but after the new update is the only time I get this.

The problem is the Helix II template is incompatible with new version of Joomla and the file

/public_html/templates/shaper_helix_ii/error.php

has an error due to the head.php file no longer being a Joomla core file and was recently removed from Joomla core.

Just hoping for comment code to adjust this or another correction.

Sincerely,

Brent

Attachments (2)

  • Securi 50 Internal Error.jpg
    Securi 50 Internal Error.jpg 304.4 KB
  • Elvis Errors.jpg
    Elvis Errors.jpg 776.8 KB

Paul Frankowski - Staff

More than a month ago #Permalink
Do you still see error without "error.php" file?
Why you don't want o tell me what exactly Helix II version you have ??

Brent Robinson

More than a month ago #Permalink
Do you still see error without "error.php" file?
Why you don't want o tell me what exactly Helix II version you have ??


Paul

the verision of Helix II Template is 2.2

When I temporarily delete the error.php file I do NOT get the error messages anymore.
What does this tell us? How can we fix this?

Thanks for your help :)

Brent

Brent Robinson

More than a month ago #Permalink
why v2.2 , not 2.5 hmm?
UPDATE

Sometimes I don't understand users. We give them updates and they ..."do not need" them, but want to remove issue. :p [attachment]2.5.png[/attachment]


I did not know there was an update, thank you for notifying me. If I knew, I most certainly would have. How should I update the template without removing all the changes I built/my existing website?

Sincerely,

Brent

Brent Robinson

More than a month ago #Permalink
why v2.2 , not 2.5 hmm?
UPDATE

Sometimes I don't understand users. We give them updates and they ..."do not need" them, but want to remove issue. :p [attachment]2.5.png[/attachment]


OK, so I updated to Helix II 2.5 and still getting the same errors.

Please help

Sincerely,

Brent

Paul Frankowski - Staff

More than a month ago #Permalink
in that case securi is too sensitive, so in that case just delete error.php OR contact with them and ask for template or site scan. Online scanners are quite blind.


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 110
Sifat

Sifat

Total Accepted Answers: 61
Toufiq

Toufiq

Total Accepted Answers: 47
Mehtaz Afsana Borsha

Mehtaz Afsana Borsha

Total Accepted Answers: 14
Rashida Rahman

Rashida Rahman

Total Accepted Answers: 12

118

Templates

303051

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us