We’re with you. JoomShaper is offering a 20% Discount on all plans due to the impact of COVID-19.

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Helix multilanguage: Menu French not showing

Featured Lock Resolved Issue
Hello
I set up a multilanguage site (german and french) with Helix Ultimate. Everything works fine so far – except one thing: the french menu is not showing… I checked everything and couldn't find an error. The off canvas menu is correctly showing, but not the regular one.

Could you help? https://neu.swissbowling.org

Thanks
Alexandra

14 Answers

Sifat - Staff

More than a month ago #Permalink
Hi,
I've just created two additional clone of your template http://prntscr.com/ktvqdc
Then assigned the specific language for them. like this http://prntscr.com/ktvr3i
And now the issue is solved.

-Thanks

Sifat - Staff

More than a month ago #Permalink
Hi,
Thanks for your query. Please check this tutorial https://www.joomshaper.com/blog/step-by-step-tutorial-for-creating-a-multilingual-joomla-site
Hope this will help you.

-Best Regards

graustufen

More than a month ago #Permalink
Hi, I have already read these tutotirial – but there is no solution for my problem; and beside: I already checked every step of the tutorial. Any other suggestions?

Alexandra

Sifat - Staff

More than a month ago #Permalink
Please PM me your admin access.
click on my avatar to get that option

-Thanks

HDcms

More than a month ago #Permalink
Hello,
I have the same problem.
I just redo the installation on a new blank site (just SPPB). I do not know now if I have to set differently each style having a different language version
I followed the tutorial for a multilingual joomla site
It works well with protostar
With Helix, I tried a lot of possibilities.
http://www.onsort.eu/fr/
Either I always see the same menu, even if I change my language
Either I have no menu that appears
Regards

Sifat - Staff

More than a month ago #Permalink
Hello,
I have the same problem.

Hi,
Please create additional two clones of your template http://prntscr.com/ktvqdc
Then assigned the specific language for them. like this http://prntscr.com/ktvr3i
Make sure you've assigned the menus properly from the menu-assignment option http://prntscr.com/kv8iro


-Thanks

HDcms

More than a month ago #Permalink
Hello,
I already did that.
Regards

Sifat - Staff

More than a month ago #Permalink
Hello,
I already did that.
Regards

Please PM me your super admin access.
click on my avatar to get that option

HDcms

More than a month ago #Permalink
Hello
ok thanks for this solution (which I had not tested)
As I understand it, I have to modify the template option in French for example and I have to import it for another language (because if I use the general template, nothing is visible)
Regards

Alexander

More than a month ago #Permalink
Hi Sifat,
May I bother you with the same issue?
I followed the instructions step by step, yet my English menu is not showing.
This is the site; http://www.3dconsult.com/sunny_property
Please let me know what you did so I'll learn for the next time.

Sifat - Staff

More than a month ago #Permalink
Hi Sifat,
May I bother you with the same issue?
I followed the instructions step by step, yet my English menu is not showing.
This is the site; http://www.3dconsult.com/sunny_property
Please let me know what you did so I'll learn for the next time.

Hi,
Thanks for your reply. Please check this tutorial https://www.joomshaper.com/blog/step-by-step-tutorial-for-creating-a-multilingual-joomla-site
Then just follow the steps shown in my above reply.
Let me know if it works.

-Best Regards

Alexander

More than a month ago #Permalink
Hello again Sifat.
I followed and rechecked all the steps. I'm adding some screen shots to show I did so.
I really don't know where I went wrong. I even added step (7) a Template for each language that I found in the Helix3 documentation (https://www.joomshaper.com/documentation/helix-framework/helix3#how-to-create-a-multilingual-site).
The English menu is still not showing.
Maybe it has to do that pages generated by SP PageBuilder are not attached to categories?
I don't have a clue and would appreciate your helping me out.

Thank you for your consideration.

Alexander

Attachments (5)

  • Step-4.jpg
    Step-4.jpg 77.5 KB
  • Step-5a.jpg
    Step-5a.jpg 76.9 KB
  • Step-5a2.jpg
    Step-5a2.jpg 82.6 KB
  • Step-6.jpg
    Step-6.jpg 74.4 KB
  • Step-7.jpg
    Step-7.jpg 83.5 KB

Sifat - Staff

More than a month ago #Permalink
Hi,
Would you please PM me your admin access?
click on my avatar to get that option

-Thanks


There are no replies made for this post yet.
Be one of the first to reply to this post!

124

Templates

330988

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us