We’re with you. JoomShaper is offering a 20% Discount on all plans due to the impact of COVID-19.

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Helix/PageBuilder website not loading in IE!

Featured Lock Resolved Issue
I'm not sure if this is a recent development since updating to the latest PB and Helix Ultimate or if it's been an issue for a while. In any case, our Foot Levelers website will not finish loading in IE. Here's a screenshot of the site trying to load in IE 10 on Windows 7...

The interesting thing is the HTML is completely loading but the loading spinner never goes away. You can see the loading spinner in this screenshot...
Screen Shot 2019-05-16 at 9.04.26 AM.png

I've tested in a few versions of IE and they're all like that but I'm not able to test in a wide variety. Anyone else experiencing this or have an idea of why the spinning loader animation isn't going away in IE?

Attachments (1)

  • Screen Shot 2019-05-16 at 9.04.26 AM.png
    Screen Shot 2019-05-16 at 9.04.26 AM.png 35.3 KB

9 Answers

Paul Frankowski - Staff

More than a month ago #Permalink
Hi,
Edge - OK
IE11 - problem

If I may suggest, disable preloader from template settings (!)
less= better

footlev

More than a month ago #Permalink
Disabling the preloader seems to have helped. Thanks!

Rein

More than a month ago #Permalink
I had the same issue and jumped into this.

Not only did the preloader stay on the screen even when the page was already loaded, also the sticky menu wasn't sticky anymore after the update from Helix Ultimate.

Also some scripts from other components stopped function properly.

During my search with dev tools I found that the main.js from Helix Ultimate contained on line 207:


scrollBar.css({width: `${scrollPercent}%` })


Changing this to :


scrollBar.css({width: "${scrollPercent}%" })


Solves all mentioned issues in IExplorer 11

Paul Frankowski - Staff

More than a month ago #Permalink
Thanks, I will inform developers

Allen

More than a month ago #Permalink
I I updated to Helix Ultimate Framework 1.1.2 released in January 2020. The file was not fixed per above.

Applying the code change recommended fixed the issue indeed.

This bug must have fallen through the cracks. Just FYI for the developers.

Paul Frankowski - Staff

More than a month ago #Permalink
Indeed, Preload code wasn't touched. Sorry, just do not use it or make above customization.

Allen

More than a month ago #Permalink
Hi Paul,

Actually, I implemented the tiny code change recommended by Rein above, and the preloader works just fine on all browser's I've tested. Try using IE on https://www.certifiedinfosec.com/. It works :-)

Maybe the developers could implement the fix so future user's don't have to find this post, and you won't get more requests from users who did not fine this post?

Unless the fix breaks something I am not aware of?

Paul Frankowski - Staff

More than a month ago #Permalink
From my side, I was able to add to the bug-list only.


There are no replies made for this post yet.
Be one of the first to reply to this post!

126

Templates

334002

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us