Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

HTTPS

Featured Lock Resolved Bug
Hi,

When I enter the URL of the project they are always linking to https:// and not the actual url http://
the originating site where the portfolio is does have https:// on it.
Any ideas ??

11 Answers

Top

More than a month ago #Permalink
right I found the culprit! It was Admin Tools, SEO and Link settings the convert all links to https was set to YES.
Thanks for trying to help and I apologise for wasting your time.

Paul Frankowski - Staff

More than a month ago #Permalink
Hi,
can you tell me from where you have this problem: component or module view ?
---
Please add this into .htaccess :

RewriteCond %{HTTPS} !=on
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]


after : RewriteEngine On

Top

More than a month ago #Permalink
Hi Paul,

Thanks for getting back to me.
The problem is on the frontend as shown here - 'link removed'
if you click on 'view project' you will see what happens, this is the same on all portfolio pages.
I have added your idea above to htaccess but it makes no change.
Thanks

Paul Frankowski - Staff

More than a month ago #Permalink
Thanks for link, this will help me to solve a problem

Paul Frankowski - Staff

More than a month ago #Permalink
In meantime please:
1) remove my code from .htaccess , probably you don't need this anyway.
2) Answer: You set HTTPS in Global Configuration only, or you used 3th party plugin as well ?

Top

More than a month ago #Permalink
In meantime please:
1) remove my code from .htaccess , probably you don't need this anyway.
2) Answer: You set HTTPS in Global Configuration only, or you used 3th party plugin as well ?

sh404sef is installed and running, but the not set to htpps

Paul Frankowski - Staff

More than a month ago #Permalink
I made test on my site with is also have HTTPS.
all links from "View project" are ok, real URL.
--
I used SP Simple Portfolio 1.4

Paul Frankowski - Staff

More than a month ago #Permalink
Are you able to disable sh404sef for a test purpose (short period), clear CMS cache and check again.

Top

More than a month ago #Permalink
ok, I have narrowed it down abit, it appears to happen on ALL external links.

I did a test link on that page, I manually inserted into the text field and that also sends to https and not http, soo it is something going on with the site it self.

Paul Frankowski - Staff

More than a month ago #Permalink
No problem, it was also good lesson for me, good to know about Akeeba Tools and https "problem".


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 138
Toufiq

Toufiq

Total Accepted Answers: 61
Shibbir

Shibbir

Total Accepted Answers: 27
Rifat Wahid Alif

Rifat Wahid Alif

Total Accepted Answers: 5
Pavel

Pavel

Total Accepted Answers: 4

100+

Templates

200,000+

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam