Support Forums

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Images do not show in Freeslider SP1 ...

Featured Lock Resolved
Hi,

I use the free slider sp1 module, but the images in the articles do not show in the slider... Text, title and read more are there, but the slider keeps telling me there's no graphic available... When I click on the (missing) graph, or the title or read more, the article shows WITH the graphic however.

Any suggestions?

48 Answers

mehdi

More than a month ago #Permalink
I have this problem too
Is it solve for you?

Jessica

More than a month ago #Permalink
I am also having the same problem. Everything loads fine except the images. Even when I check the window activity, no errors are present.

sharon

More than a month ago #Permalink
me too...where are they???

Kawshar Ahmed - Senior Staff

More than a month ago #Permalink
Drop your site url that I can see the problem. Thanks

datta

More than a month ago #Permalink
I am also having same problem, Local version of site works fine but live version does not show images in slide show.

George

More than a month ago #Permalink
Same issue.

http://www.martincsi.com.php5-21.websitetestlink.com/

Have tried .png and .jpg images in the /root/ directory, /images/ and /images/stories/

Have tried with and without alignment (float) styles

Have tried with / without Images linked

Have tried turning off images and then resetting image parameters in 'Data Source'

Have tried with / without readmore links, and with images above / below readmore.

Have tried with absolute links to the site (disabled tinymce) as well as to external images on other sites.

Source code from a browser appears as:

<img src="/" alt="" class="fs-sp1-image" />


Source code in HTML view of Article Manager:

<img src="/images/stories/racing.png" border="0" alt="Martin Stories" style="border: 0; float: right;" />


It seems that somehow the functionality that pulls image data from the article is getting mixed up and inserting a generic "/" value instead.

George

More than a month ago #Permalink
Anyone else having a similar experience? I've tried a broad range of tests and don't seem to be able to get images to appear ... something keeps changing their src to a "/" ... I very much enjoy the style of the current slider but may have to change out if I can't get it to work.

Kawshar Ahmed - Senior Staff

More than a month ago #Permalink
Drop ur site url that I can take a look.

Kawshar Ahmed - Senior Staff

More than a month ago #Permalink
Your site is in offline.

George

More than a month ago #Permalink
oops! PM'd a username and password to your account.

Paulo Ries

More than a month ago #Permalink
From what I saw there an error in calling the image:

helper.php : $ item-> images
default.php : $ item-> image

I changed everything for $ item-> images and it worked here: D

Kawshar Ahmed - Senior Staff

More than a month ago #Permalink
I forgot to ask, did u update the module?

George

More than a month ago #Permalink
No ... it was a fresh download though last weekend, is there a newer version?

Kawshar Ahmed - Senior Staff

More than a month ago #Permalink
Ok, email me ur access. PM system is not working.

Kawshar Ahmed - Senior Staff

More than a month ago #Permalink
Free Slider SP1 version 1.2 has been released. Please update now. Image source bug has been fixed :)

Leonardo

More than a month ago #Permalink
I just install the module, but don't work the link to image.

HTML Code: <img class="fs-sp1-image" alt="" src="/">

[]'s

Kawshar Ahmed - Senior Staff

More than a month ago #Permalink
Can you give the url where you installed the module?

Leonardo

More than a month ago #Permalink
The module is active in this url

The articles in the freeslider are the same featured articles

Kawshar Ahmed - Senior Staff

More than a month ago #Permalink
Please email me your admin access. I need to see your article image source in order to solve the issue. Thanks

Leonardo

More than a month ago #Permalink
I send to you the login as PM

Kawshar Ahmed - Senior Staff

More than a month ago #Permalink
Please use email.

Kawshar Ahmed - Senior Staff

More than a month ago #Permalink
Problem solved. Please download again. Thanks

Leonardo

More than a month ago #Permalink
Thanks !

Work perfectly now ! =)

Bahman Soltani

More than a month ago #Permalink
How to add images to be shown in this module?

George

More than a month ago #Permalink
Kowshar - thank you! I've been unexpectedly away, but will install the new version now and report back!

George

More than a month ago #Permalink
Updated my module files and it's now working perfectly ... thanks again for the great support!

dc10555

More than a month ago #Permalink
Just downloaded the latest files and can't seem to get images to display, My articles are just basic text and one image to the right or left nothing complicated, is there something special I need to do to my image ( special tags?) in order for my article image to show in the module? I'm using the 1.6 version if that is any help, I'd really appreciate it since this module is pretty much perfect other than this problem. B)

EDIT

Hmmm, It seems externally linking the images from a different site seemed to have caused this issue, All is resolved now, Thank you for an awesome mod! :D

Robin

More than a month ago #Permalink
I am having the same problem as everyone else on here. However it needs to be said I am new to Joomla and learning fast, but I may be just missing something. I have an image in the article and when Free slider is operating it only shows the text and no image. Given that there does not appear to be an area in FS to difine what image I am assuming it is meant to draw the image from what is in the article. I am using 1.5 and downloaded this morning.
Cheers
Rob

Robin

More than a month ago #Permalink
As a follow on, I have been able to get some images coming up by placing them in a table in the article, however not all images although they are JPG and roughly the same size and showing.
Cheers
Rob

recosimo

More than a month ago #Permalink
Let me say, I appreciate the free module. You have done great work here!

I'm having the same issue as most of the people in this forum topic. My articles load on to the slide, but the images do not. I tried different image formats and no success. Could you please help me to get it to work with images?

the site is: http://www.dpmgcloud.com/

Thank you

Kawshar Ahmed - Senior Staff

More than a month ago #Permalink
Check your image source. Try to put image on same server.

recosimo

More than a month ago #Permalink
I have the image saved in the joomla folder folder /images. I'm not sure if i understand save server. The hosting company provides me with the server.

Termos

More than a month ago #Permalink
The reason of dissapearing images is here:

.../modules/mod_freeslider_sp1/helper.php


There is a function, called cText, that strips all tags in the article text, accept those, mentioned on line 220 in a variable, called $allowed_tags.
All you need to do is add any tag you want to the list (<img>, <div> or else) and it will be shown in the slider.

Change line 220 from this:
$allowed_tags = '<b><i><a><small><h1><h2><h3><h4><h5><h6><sup><sub><em><strong><u><br>';

to this:
$allowed_tags = '<img><div><b><i><a><small><h1><h2><h3><h4><h5><h6><sup><sub><em><strong><u><br>';


Enjoy ;)

recosimo

More than a month ago #Permalink
the helper.php only goes up to line 170 on my dreamweaver.

I did find the line you mentioned starting on line #138:

case 2 :
$allowed_tags = '<p><span><img><div><b><i><a><small><h1><h2><h3><h4><h5><h6><sup><sub><em><strong><u><br></>';
$text = strip_tags( $text, $allowed_tags);
$text = $text;
break;

I made the changes as you suggested, however the image still does not show.

Termos

More than a month ago #Permalink
I think you also need to chose option "No limit" for parameters "Limit title as" and "Limit description as" in module parameters (Case 2 obviously is responsible for "No limit" option).

recosimo

More than a month ago #Permalink
Let me say thanks for the support but still no luck.

Ok, I set the parameters to no limits, for both, title and description. The image is shown in the article because the article has no limits. HOWEVER, the "no image.jpg" still shows on the right corner of the slider.

What else may it be?

Kawshar Ahmed - Senior Staff

More than a month ago #Permalink
Please make sure that your article has image. Also check your image path.

Herman Ortega

More than a month ago #Permalink
Are you able to see other images that are contained in the /images folder? It may be a permissions issue.

On one of my Joomla sites I had to put the images the /stories folder in order for them to be seen. I still do not understand that one but, it works so I leave it alone. It might be module specific, in my case. Hope that gives you some ideas. :)

SEBASTIAN MERLO

More than a month ago #Permalink
He had the same problem, solved by inserting the image before reading more. Greetings and I hope they serve.
Sorry for the English

nextphase

More than a month ago #Permalink
Is it somehow possible to show the image even when I use Word limit or Character limit??

Kawshar Ahmed - Senior Staff

More than a month ago #Permalink
Why not? Just use character limit and enable image show from the module parameter.

nextphase

More than a month ago #Permalink
Yeah, sorry. I realized I had the old version, downloaded the new one and everything worked perfectly. Thanks!

Dean Martin

More than a month ago #Permalink
I am having a similar problem but, in my case, images in new articles are not appearing. I had five articles on my site working fine. I added a sixth, and the image does not show. All images are JPG in the same directory. I updated to version sp_j15.zip, but it did not solve my problem.

Dean Martin

More than a month ago #Permalink
I discovered the cause and was able to fix it. You could see the image in the article view, but Free Slider would not recognize it. What I discovered is that images that appeared correctly had src="images/stories/image.jpg" as the path, and images that didn't display had src="/images/stories/image.jpg" . I don't know why the forward slash in front of images is now being added, but you have to remove it in order for Free Slider to find the correct directory.

krimoon

More than a month ago #Permalink
Hi everybody

I just faced this problem today and i solved it

As some of u said the problem came from : helper.php

so all u have to do is just go to this part of code [246] :
	function getImages($text) {  

preg_match('/< *img[^>]*src *= *["\']?([^"\']*)/i', $text, $matches);

//If no image found
if (!isset($matches[1])) {
$matches[1]='modules/mod_freeslider_sp1/assets/images/no-image.jpg';
}

if (!file_exists($matches[1])) {
$matches[1]='modules/mod_freeslider_sp1/assets/images/no-image.jpg';
}

return $matches[1];
}



And replace it by this new on :


	function getImages($text) {  

preg_match_all('/<img.+src=[\'"]([^\'"]+)[\'"].*>/i', $text, $matches);

//If no image found
if (!isset($matches[1][0])) {
$matches[1][0]='modules/mod_freeslider_sp1/assets/images/no-image.jpg';
}

return $matches[1][0];
}


Enjoy ; )

hkimi ridha

More than a month ago #Permalink
just add <img><p>

in helper.php

case 2 :
$allowed_tags = '[color=#ff0000]<img><p>[/color]<b><i><a><small><h1><h2><h3><h4><h5><h6><sup><sub><em><strong><u><br>';
$text = strip_tags( $text, $allowed_tags );
$text = $text;
break;

Protopia

More than a month ago #Permalink
If you want tags in articles to be used to format the description then:

In default.php change the p tag to a div as follows (brackets changed to curly so that code is shown correctly):

{p class="fs-sp1-intro"}{?php echo $item->introtext; ?}{/p}


to


{div class="fs-sp1-intro"}{?php echo $item->introtext; ?}{/div}


AND in helper.php add a p tag to the list of allowed tags:

case 2 :
$allowed_tags = '{b}{i}{a}{small}{h1}{h2}{h3}{h4}{h5}{h6}{sup}{sub}{em}{strong}{u}{br}';

with:

case 2 :
$allowed_tags = '{p}{b}{i}{a}{small}{h1}{h2}{h3}{h4}{h5}{h6}{sup}{sub}{em}{strong}{u}{br}';


P


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Leaderboard (30 days)

Sifat

Sifat

Total Accepted Answers: 134
Paul Frankowski

Paul Frankowski

Total Accepted Answers: 125
Toufiq

Toufiq

Total Accepted Answers: 64
Pavel

Pavel

Total Accepted Answers: 5
M

Mel

Total Accepted Answers: 2

100+

Templates

200,000+

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us