Support Forums

Support Online : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Inline SVG files have stopped working

Featured Lock Resolved Bug
Hi

Think this may be a bug or issue?

Previously I had happily used inline SVG within Raw HTML Addon. Example code would be....

<a href="work">
<div class="txtwrapper">
<div class="txtcardnooverlay width100pc">
<div class="header1 dark-grey">think<br>create<br>drive<br>transform</div>
<div class="cta fluxx-blue">OUR WORK<svg class="cta-icon-gap cta-icon-fluxx-blue" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
viewBox="0 0 26 23" style="enable-background:new 0 0 26 23;" xml:space="preserve">
<title>arrow_13_</title>
<desc>Created with Sketch.</desc>
<g id="Page-1">
<polygon id="arrow_13_" points="14.1,0.5 25.1,11.5 14.1,22.6 14.1,13.6 0,13.6 0,9.5 14.1,9.5 "/>
</g>
</svg></div>
</a>
</div>
</div>


However each time I am saving this code the resultant saved code appear to be inserting the "-" into the <title> element. Result looks like this...

<t-itle>arrow_13_</title>

And SVG does not display properly.

Please help me to resolve this bug/issue?

Thanks
Pete

13 Answers

Paul Frankowski - Staff

More than a month ago #Permalink
I disabled one rule from RSFirewall for SP PB only, and now all html5/SVG marks should be ok

just check your home page ... "-->" is there.
Case fixed & closed. Relax & Have fun !
---
BTW
You had this same case before, please be more focus! This issue was not related with our tool. In custom module you would have this same problem probably.

Attachments (2)

  • ok.jpg
    ok.jpg 58.8 KB
  • rsfirewall.jpg
    rsfirewall.jpg 72.2 KB

Toufiq - Staff

More than a month ago #Permalink
Hi,

Please share your SVG file for download. I will let you know after check out your SVG file.

-Thanks

Peter Hay

More than a month ago #Permalink
Hi Toufiq

I am using inline SVG code which I added in the original post above.

Thanks
Peter

Peter Hay

More than a month ago #Permalink
Something looks to be going wrong in the way the editor is now saving the raw html code

Toufiq - Staff

More than a month ago #Permalink
Hi,

Please share your original svg file. I will check after download.

-Thanks

Paul Frankowski - Staff

More than a month ago #Permalink
I tested your code and is working OK, on my site.
There was no differences in RAW addon since v 2.3.5.

Paul Frankowski - Staff

More than a month ago #Permalink
On your site title tag is broken, correct it

Attachments (1)

  • title-tag.jpg
    title-tag.jpg 66.6 KB

Toufiq - Staff

More than a month ago #Permalink
Hi,

Please following the instruction.

Add this code inside raw html addon

<svg class="cta-icon-gap cta-icon-fluxx-blue" version="1.1" id="Layer_1"
xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
viewBox="0 0 26 23" style="enable-background:new 0 0 26 23;" xml:space="preserve">
<title>arrow_13_</title>
<desc>Created with Sketch.</desc>
<g id="Page-1">
<polygon id="arrow_13_" points="14.1,0.5 25.1,11.5 14.1,22.6 14.1,13.6 0,13.6 0,9.5 14.1,9.5 ">
</polygon>
</g>
</svg>


Note: I have checked my end & working fine
http://js.shobkhanei.com/helix_v1.9/index.php?option=com_sppagebuilder&view=page&id=8

-Thanks

Peter Hay

More than a month ago #Permalink
Hi

As per DM with both you and Paul I have tried pasting this code in and when I click save and then re-open the raw HTML the title tag has reverted to <t-itle> again.

Toufiq - Staff

More than a month ago #Permalink
Hi,

Thanks for your pm. Please check your pm. I have sent login details for live check.

-Thanks

Peter Hay

More than a month ago #Permalink
I disabled one rule from RSFirewall for SP PB only, and now all html5/SVG marks should be ok

just check your home page ... "-->" is there.
Case fixed & closed. Relax & Have fun !
---
BTW
You had this same case before, please be more focus! This issue was not related with our tool. In custom module you would have this same problem probably.

Paul you are an absolute legend! Thanks so much for helping me resolve this issue. Much appreciated and would never have worked out it was an RSFirewall issue without your help.

Paul Frankowski - Staff

More than a month ago #Permalink
Thanks a lot :)


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Sifat

Sifat

Total Accepted Answers: 119
Paul Frankowski

Paul Frankowski

Total Accepted Answers: 110
Toufiq

Toufiq

Total Accepted Answers: 89
Kamruzzaman Alam

Kamruzzaman Alam

Total Accepted Answers: 4
FUTURECLIENT

FUTURECLIENT

Total Accepted Answers: 2

115

Templates

296107

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us