Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Internet Explorer won't load site

Featured Lock Resolved Issue
Hello support,

On site launch, I tested various browsers for compatibility and had no issues.

However, I've just had a site visitor report that the site was refusing to load in IE. I've been able to confirm this, but the IE console shows no errors, just the pre-loader spinning away endlessly? (see attached image).

Unsure if this is an issue with Helix Ultimate or SP Page Builder.
I have made no major changes to my content on the homepage, only recent upgrades to the template and Page Builder component.

Any idea on what might be causing this?

Attachments (1)

  • ie-wont-load.jpg
    ie-wont-load.jpg 98.8 KB

6 Answers

Paul Frankowski - Staff

More than a month ago #Permalink
Hi, Try those options:
1) Disable "Preloader animation" from Helix settings, IE doesn't like it
Or
2) In the main.js from Helix Ultimate contain on line 207:


scrollBar.css({width: `${scrollPercent}%` })

Change to

scrollBar.css({width: "${scrollPercent}%" })



It should solve load issue in IExplorer 11 / Edge

[email protected]

More than a month ago #Permalink
UPDATE: forcing the browser to use IE's compatibility mode, I get the following errors referencing; 'jQuery' is undefined

Attachments (1)

  • ie-results.jpg
    ie-results.jpg 689.6 KB

[email protected]

More than a month ago #Permalink
Hi, Try those options:
1) Disable "Preloader animation" from Helix settings, IE doesn't like it
Or
2) In the main.js from Helix Ultimate contain on line 207:


scrollBar.css({width: `${scrollPercent}%` })

Change to

scrollBar.css({width: "${scrollPercent}%" })



It should solve load issue in IExplorer 11 / Edge




Thanks for the prompt reply, Paul!

I disabled the pre-loader and this seemed to work. However, I'd prefer to use this feature.
Instead, I opted to make the code modification you outlined above.

Interestingly, when I loaded this file into DreamWeaver, it immediately flagged line 207 as a "syntax error".
Changing this to the code listed above made both IE and DreamWeaver happy. :)

Curious? Is this change 'upgrade safe' or will the next Helix Ultimate update overwrite these changes to Main.js?

Thanks again for your assistance!

Paul Frankowski - Staff

More than a month ago #Permalink
it should be fixed in next helix update

[email protected]

More than a month ago #Permalink
it should be fixed in next helix update


Many thanks, Paul! :)


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 107
Toufiq

Toufiq

Total Accepted Answers: 66
Sifat

Sifat

Total Accepted Answers: 47
Mehtaz Afsana Borsha

Mehtaz Afsana Borsha

Total Accepted Answers: 21
Rashida Rahman

Rashida Rahman

Total Accepted Answers: 17

118

Templates

305705

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us