Support Forums

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

jce does not save again in the page builder

Featured Lock Resolved Bug
Hi
the editor jce does not save again in the page builder

18 Answers

Paul Frankowski - Staff

More than a month ago #Permalink
Hi,
I tried yesterday with JCE 2.6.23 and was OKAY.

martin

More than a month ago #Permalink
hi paul,
i ve the same version. but it doesent work.. sorrry

Paul Frankowski - Staff

More than a month ago #Permalink
what about JCE 2.6.22

martin

More than a month ago #Permalink
ive got it ... the bug is...

when you re in the code-view, and you change in it, i doesnt save.

i tried 2.621, 2.622 and 2623

Paul Frankowski - Staff

More than a month ago #Permalink
Thanks.
It looks like JCE issue.

Stefano

More than a month ago #Permalink
Same problem for me
JCE 2.6.23, SP Page Builder 3.0.3

JCE is working properly within Joomla articles.

Any updates?

Paul Frankowski - Staff

More than a month ago #Permalink
If you do not switch into Code mode and save in this position all is working perfect.

It can be also JCE problem, why we are always guilty?
----
Just save each time in WYSIWYG/Visual Mode, and won't be any problem. That's all.

martin

More than a month ago #Permalink
Sorry, you offer a service, a good one. I'm glad if I'm aware of a mistake. some people who post here also want to help you. Unfortunately, the code mode is important to me.

Stefano

More than a month ago #Permalink
Code mode is important to mee too and I guess to many other people.
It's the only way to get access to font awesome, specific styles and much more ...
There is a workaround which is to switch to another editor , change the code, and switch back to JCE (which in the pro version has a very good code editor) but it' a bit annoyng afer a while expecially while developing new pages and contents.
I guess it could be a JCE problem however as I said before it works properly with Joomla core and other components and it appears the problem is confied using SP Page Builder.
I realize it's a small problem but neverthless my opinion is that it should be fixed.

thanks

Raju Ahmmed

More than a month ago #Permalink
Hello,

Yes, This is JCE problem. All problem is not created by us. We are catching content on the onChange event. But when you go to code mode they don't fire onChange event. If they don't fire the onChange event then how can I catch them? Please ask them to fire onChange event it will be fixed.

Thanks

Stefano

More than a month ago #Permalink
Hi,
searching on the JCE forum I discovered JCE team has been made aware of the problem already.

If it can be of any use that's their answer:

The SPPageBuilder developers have seen fit to change the custom methods they used to load and save the editor data, thereby breaking the solution I came up with to deal with these methods.

I am looking into a new solution for this, and will include it in a new update when it is available.


So I guess we have to wait for the next JCE update.

Thanks
Stefano

Paul Frankowski - Staff

More than a month ago #Permalink
From my today test: https://youtu.be/MEgA_0BgenE
so yes, only saved in code mode makes problems.

martin

More than a month ago #Permalink
Sorry, we miss us. in the clip you show us, what's up with us too. if you are in code mode directly z.b. <div class = "..."> ...... </ div> enters and then goes to save, it does not save.

Paul Frankowski - Staff

More than a month ago #Permalink
have you switched to Visual mode after, I mean before Save ?

martin

More than a month ago #Permalink
i go in sppb, open eg. tab, than "text block", than on code, entry <p blaa ....> than on save

Stefano

More than a month ago #Permalink
I did a bit of testing, switching to visual mode is not enough.
After you did the changes in the code editor you need to switch to visual mode and do some changes (say press the space bar and then delete). The modification highlight the undo button and bring back focus on visual mode. If you save now it keeps the changes.

Paul Frankowski - Staff

More than a month ago #Permalink
I have to agree sometimes is works sometimes is not.
But when I used Preview button = changes were saved.

Video: https://youtu.be/AVAD557ahas

martin

More than a month ago #Permalink
thanks for this tip, stefano, :D


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Leaderboard (30 days)

Sifat

Sifat

Total Accepted Answers: 118
Paul Frankowski

Paul Frankowski

Total Accepted Answers: 91
Toufiq

Toufiq

Total Accepted Answers: 32
Pavel

Pavel

Total Accepted Answers: 3
Al Mamun

Al Mamun

Total Accepted Answers: 3

100+

Templates

200,000+

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us