Support Forums

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Joomla article integration not showing content

Featured Lock Resolved Issue
Hi there,

On forum here: https://www.joomshaper.com/forums/k2-integration-makes-k2-articles-not-showing-its-text you offered solution for issue with Joomla article and K2 integration with two changed PHP files, but this is not the best solution.

I have very practical question: why don't you update k2 integration and Joomla (article) integration files on your server? You have two files that are updated every time we "install" Joomla article or K2 integration: https://www.joomshaper.com/updates/pagebuilder/content/plugin.zip and https://www.joomshaper.com/updates/pagebuilder/k2/plugin.zip. Here, in forum, you offered this two fixes: k2_integration.zip and joomla_integration.zip and the text is showing in Joomla article, which is fine, but when I uninstall "integration" and install it again, it is installing from your server (https://www.joomshaper.com/updates/pagebuilder/content/plugin.zip) again and there is no point to "fix" (install) this files manually.

I hope you understand my point? We shouldn't wait for next SP Page Builder update, when you can update this immediately on your server.

7 Answers

Nayem Majhar - Staff

More than a month ago #Permalink
Sorry for inconvenience.
I understand your point. We will update this file soon ( within friday ). Thank You.

Martin Seidl

More than a month ago #Permalink
aplikko wrote:

Hi there,

On forum here: https://www.joomshaper.com/forums/k2-integration-makes-k2-articles-not-showing-its-text you offered solution for issue with Joomla article and K2 integration with two changed PHP files, but this is not the best solution.

I have very practical question: why don't you update k2 integration and Joomla (article) integration files on your server? You have two files that are updated every time we "install" Joomla article or K2 integration: https://www.joomshaper.com/updates/pagebuilder/content/plugin.zip and https://www.joomshaper.com/updates/pagebuilder/k2/plugin.zip. Here, in forum, you offered this two fixes: k2_integration.zip and joomla_integration.zip and the text is showing in Joomla article, which is fine, but when I uninstall "integration" and install it again, it is installing from your server (https://www.joomshaper.com/updates/pagebuilder/content/plugin.zip) again and there is no point to "fix" (install) this files manually.

I hope you understand my point? We shouldn't wait for next SP Page Builder update, when you can update this immediately on your server.

Martin Seidl

More than a month ago #Permalink
Hi Guys,

my prob is: I integrated SP Page Builder into Joomla article because I want to have caegory view for certain SP Pages. Prob is: the articles are not visible in menu type/category blog. I can show single articel but not category blog. see here: http://www.kulturmarketing-muenchen.de/berlin

Aplikko

More than a month ago #Permalink
Hi there,

It is now worst then before after updating to SP Page Builder 2.1. I can see that you have updated Joomla article integration: https://www.joomshaper.com/updates/pagebuilder/content/plugin.zip, but it is showing 1064 error (see attached screenshot).

Can't you just fix this file (https://www.joomshaper.com/updates/pagebuilder/content/plugin.zip) on your server? Hey, you don't even need to update whole SP Page Builder, just update this file (fixed of course). Every time you "install" Article integration, it installes this (wrong) file.

This is your present code, which is wrong:

function onContentPrepare($context, $article, $params, $page) {
$input = JFactory::getApplication()->input;
$option = $input->get('option', '', 'STRING');
$view = $input->get('view', '', 'STRING');
$task = $input->get('task', '', 'STRING');

if(($option == 'com_content') && ($view == 'article')) {
$article->text = SppagebuilderHelper::onIntegrationPrepareContent($article->text, $option, $view, $article->id);
}

if(($option == 'com_j2store') && ($view == 'products') && ($task == 'view') && ($context == 'com_content.article.productlist')) {
$article->text = SppagebuilderHelper::onIntegrationPrepareContent($article->text, 'com_content', 'article', $article->id);
}
}


I suppose that you will react quickly, because this is quite big problem (issue), that you have right now.

Kind regards,

Aplikko team

Attachments (1)

  • 1064-Error.jpg
    1064-Error.jpg 105.1 KB

Nayem Majhar - Staff

More than a month ago #Permalink
aplikko wrote:

...........

Aplikko team


Could you send your site URL, admin access in PM?

Aplikko

More than a month ago #Permalink
Hi Nayem Majhar,

I don't want to be mean to you, but this issue has nothing to do with "...site URL, admin access in PM", this is an issue on every website that installs SP Page Builder 2.x.

You should go to your website, the one where you're testing SP Page Builder or "live website", it doesn't matter. This is an issue with the files that are on your server, not on anyone's server (locally). The file that is affected is: https://www.joomshaper.com/updates/pagebuilder/content/plugin.zip, and it is on your server (Joomshaper's). Again, this file installs automatically every time you "install" Joomla Article integration plugin. It is not "local" file, it is on your server.

This is third time I am trying to explain that you have big issue here! It is stated on your latest blog page: https://www.joomshaper.com/blog/sp-page-builder-2-1-arrives-with-bug-fixes-and-performance-improvements, at "Version 2.1 Changelogs" section, this Joomla article integration plugin is "improved", but it is now worst then before after updating to SP Page Builder 2.1.

Why don't you go to your website, where you have SP Page Builder 2.1 and install again (which means to first uninstall, if you have Joomla Article integration plugin already) and see what happens?

Tell me please Nayem Majhar, should I contact somebody else for this? I already contacted your support via email, but they directed me to you again. This is serious issue that you need to fix ASAP, othervise, articles will not work on all of our websites!

Kind regards,

Aplikko team

Nayem Majhar - Staff

More than a month ago #Permalink
aplikko wrote:

Hi Nayem Majhar,

...........

Tell me please Nayem Majhar, should I contact somebody else for this? I already contacted your support via email, but they directed me to you again. This is serious issue that you need to fix ASAP, othervise, articles will not work on all of our websites!

Kind regards,

Aplikko team


I think I got your point. Working on it.


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 138
Toufiq

Toufiq

Total Accepted Answers: 61
Shibbir

Shibbir

Total Accepted Answers: 27
Rifat Wahid Alif

Rifat Wahid Alif

Total Accepted Answers: 5
Pavel

Pavel

Total Accepted Answers: 4

100+

Templates

200,000+

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam