Support Forums

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Label tooltips with mootools-more

Featured Lock Resolved Bug
I'm having difficulties with Startup Biz -template and labels in a form. Labels with tooltips disappear after mouseout because labels are getting 'style="display: none;"' added to them for some reason.

This is happening on a (self developed) custom component where I have several forms. Problem occurs only on forms where "behavior.modal" is loaded. I did some tests with different libraries, and it seems that there is a conflict with the mootools-more.js-file and Startup Biz -template. With ("behavior.framework";) labels work just fine, but with ("behavior.framework","more";) they disappear. This doesn't happen with other templates.

Could you please fix this? I'm sure I'm not the only one with this problem.

13 Answers

Alex Smirnov

More than a month ago #Permalink
Hi there,

Sorry but we provide support only for Joomshaper produced products. Custom developed and third party developed extensions and templates are outside of the scope of our support. Many thanks in advance for your understanding.

Regards,

Alex

boatbond

More than a month ago #Permalink
Alex Smirnov wrote:

Hi there,

Sorry but we provide support only for Joomshaper produced products. Custom developed and third party developed extensions and templates are outside of the scope of our support. Many thanks in advance for your understanding.

Regards,

Alex


Hi,

Thank you for your reply!
This problem is not only with my custom component but also in Joomla components. You can test it with a fresh Joomla installation with demo content and Startup Biz template installed. It happens for example in the article edit form in frontend, see attached pictures. This doesn't occur on a site created from the quickstart-package.

Tested with Joomla 3.4.4 and IE11+Chrome.

boatbond

More than a month ago #Permalink
Unable to attach pictures...

Alex Smirnov

More than a month ago #Permalink
Hi Lauri,

I received your PM, thank you.

From my end I've just managed to edit your /park-home page from front end with no issues (under Chrome). Works like charm to me.

Regards,

Alex

boatbond

More than a month ago #Permalink
Hi Alex,

There is no problem with actual editing or saving the edits, problem is with the labels. In article edit form (frontend) you can test it.

On the Content tab "Title *" -label disappears after hovering. And when you go to Publishing tab, the whole Content tab disappears. Also all the labels on Publishing tab behave the same way "Title *" -label does. And when you move on to Language tab, Publishing tab disappears.

Lauri

boatbond

More than a month ago #Permalink
Picture with the title-label:
http://lauri.paloa.fi/bizdemo/images/startup1.PNG

Picture after hovering the title-label:
http://lauri.paloa.fi/bizdemo/images/startup2.PNG

boatbond

More than a month ago #Permalink
Problem is there also with Safari 8.0.8 on Yosemite 10.10.5.

Alex Smirnov

More than a month ago #Permalink
Thanks, I'll do more testing on your site later for us.

Regards,

Alex

boatbond

More than a month ago #Permalink
Hi Alex,

Do you have any updates on this?

boatbond

More than a month ago #Permalink
Alex Smirnov wrote:

Thanks, I'll do more testing on your site later for us.

Regards,

Alex


Have you found anything on this?

LouisRLinux

More than a month ago #Permalink
Add the following in the custom css section:

.hasTooltip, time {
display: inline !important;
}

ul.nav-tabs li a {
display: block !important;
}

You will most certainly need to expand the above overrides, but this should get you started.

This is a known problem with bootstrap that just happened on a new install of the latest Joomla and Helix3. Interestingly, another site I installed last week on the same server does not show this error - although I have since moved that site to another server. When I get the time I will install another site and add the components I use one at a time to see what is doing this.

This is also a recurring problem that has been discussed on other sites for over a year now. Google "Joomla bootstrap tooltips" for more information.

boatbond

More than a month ago #Permalink
Great!! Thank you very much, this will certainly get me started!!

LouisRLinux wrote:

Add the following in the custom css section:

.hasTooltip, time {
display: inline !important;
}

ul.nav-tabs li a {
display: block !important;
}

You will most certainly need to expand the above overrides, but this should get you started.

This is a known problem with bootstrap that just happened on a new install of the latest Joomla and Helix3. Interestingly, another site I installed last week on the same server does not show this error - although I have since moved that site to another server. When I get the time I will install another site and add the components I use one at a time to see what is doing this.

This is also a recurring problem that has been discussed on other sites for over a year now. Google "Joomla bootstrap tooltips" for more information.

RemusBalan

More than a month ago #Permalink
RemusBalan wrote:

Hey guys .. I found this fix ... worked for me hope it works for you.
This is a general Joomla! Mootools vs jquery bug ...



window.addEvent('domready', function(){
if (typeof jQuery != 'undefined' && typeof MooTools != 'undefined' ) {
Element.implement({
slide: function(how, mode){ // fix for carousels
return this;
},
hide: function () { // helped me with tooltip applied on labels
return this;
},
show: function (v) {// helped me with tooltip applied on labels
return this;
}
});
}
});




Forgot to tell you to put this code in your custom.js file


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Leaderboard (30 days)

Sifat

Sifat

Total Accepted Answers: 122
Paul Frankowski

Paul Frankowski

Total Accepted Answers: 115
Toufiq

Toufiq

Total Accepted Answers: 62
Pavel

Pavel

Total Accepted Answers: 4
W

woonydanny

Total Accepted Answers: 2

100+

Templates

200,000+

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us