Support Forums

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Logo works in Top1-position, but not in Logo-position

Featured Lock Resolved Issue
Hi, strangely enough our logo is not appearing when placed into the Logo-position (it used to). Screenshots below. It does work in the Top1 position, but that implies loss of real estate space. Am I missing something?

Mobile version is working fine.

Many thanks for any advice!

Regards,

Dan

J3.8.8
Helix3
Pagebuilder 3.2.1 lite
PHP 7.2

Attachments (3)

  • logo in Top1.PNG
    logo in Top1.PNG 111.7 KB
  • logo in Logo.PNG
    logo in Logo.PNG 86.9 KB
  • logo backend.PNG
    logo backend.PNG 87.5 KB

11 Answers

Daniel Huedig

More than a month ago #Permalink
Why you added this inside the header class ???

#sp-header { height: 90px } animated menu-fixed-out

this same mistake you made for page-title

this is not place for it !! Use custom.css file for custom CSS code
---
I thought I saw all users mistakes, and you came :p


Yeah, my bad. Overlooked the class part in Custom CSS Class. Took it out. But it did not make a difference.


I don't see any logo column in your layout.


That's odd. Please see screenshots. In mobile it works, in desktop not, but both looking at the same code.


Via Chrome's developer mode, when I select:


<img class="sp-default-logo hidden-xs"
src="/images/fluechtlingshilfe-schweich/logo_breit.png"
alt="Flüchtlingshilfe Schweich">


and the delete it, or put it to "auto", the display part here:


@media only screen and (-webkit-min-device-pixel-ratio: 1.5),
not all, not all, not all
#sp-header .sp-default-logo {
display: none;
}


then the logo shows. When I do the same with img class="sp-default-logo hidden-xs", then the logo appears twice.


It is odd, because beyond the erroneous but now deleted class thing that you pointed out above, I am not aware of having made any adjustments to the default template.

Thanks for bearing with me!

Dan

Attachments (3)

  • logo position.PNG
    logo position.PNG 92.8 KB
  • logo position in layout.PNG
    logo position in layout.PNG 15.8 KB
  • div_logo.PNG
    div_logo.PNG 21.9 KB

Paul Frankowski - Staff

More than a month ago #Permalink
Hi again,
Do you have logo position in the layout structure?
logo.jpg

If yes, please check if you did not click Hide on Desktop: Yes - in settings.

logo2.jpg

Attachments (2)

  • logo.jpg
    logo.jpg 95.8 KB
  • logo2.jpg
    logo2.jpg 116.4 KB

Daniel Huedig

More than a month ago #Permalink
Hi Frank, yes, all as suggested. Images attached. Pretty odd ...

By the way, when I select the text option instead of the logo, the text appears in the right position.

Attachments (2)

  • logo position.PNG
    logo position.PNG 92.8 KB
  • logo no hide.PNG
    logo no hide.PNG 57.6 KB

Paul Frankowski - Staff

More than a month ago #Permalink
To help you more, I need entrance to your Joomla admin, or at least to see front-end URL.

Daniel Huedig

More than a month ago #Permalink
To help you more, I need entrance to your Joomla admin, or at least to see front-end URL.



Hi Frank, the page is https://www.fluechtlingshilfe-schweich.de. I am now using the Top1 position.

I have updated both the template and the Page Builder (no impact).

I can send admin access via PM if necessary.

Many thanks and regards,

Dan

[Did some edits above, got two different threads mixed up.]

Paul Frankowski - Staff

More than a month ago #Permalink
You asked for logo, not about off-canvas menu.
---
Why you added this inside the header class ???

#sp-header { height: 90px } animated menu-fixed-out

this same mistake you made for page-title

this is not place for it !! Use custom.css file for custom CSS code
---
I thought I saw all users mistakes, and you came :p

Paul Frankowski - Staff

More than a month ago #Permalink
Beside
I don't see any logo column in your layout.

Paul Frankowski - Staff

More than a month ago #Permalink
Now you have a logo on desktop and mobile - so I guess, you found out what was wrong.

Paul Frankowski - Staff

More than a month ago #Permalink
p.s.
We have 2019, Joomla 4.0 is just around the corner, I wonder that why you chose Helix 3, instead of Helix Ultimate who will be the first to receive support for the Joomla version, because it support bootstrap 4.

Daniel Huedig

More than a month ago #Permalink
p.s.
We have 2019, Joomla 4.0 is just around the corner, I wonder that why you chose Helix 3, instead of Helix Ultimate who will be the first to receive support for the Joomla version, because it support bootstrap 4.


I know I know. This was something that has been dragging on forever, across update cycles.

Now you have a logo on desktop and mobile - so I guess, you found out what was wrong.


I have not really figured out how to fix this. The CSS-changes that I apply in the browser development mode do not take effect via the custom CSS. But I'll figure it out.

What I find odd though is that this happens at all, given that I did not apply any changes to the template. The only thing I changed was to upgrade the PHP on the host.

Anyways, thanks for the support that you have given! Very much appreciated!

Regards,

Dan


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 127
Sifat

Sifat

Total Accepted Answers: 89
Toufiq

Toufiq

Total Accepted Answers: 45
Pavel

Pavel

Total Accepted Answers: 6
Sohan

Sohan

Total Accepted Answers: 5

114

Templates

292736

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us