Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Mega Menu not working on iPad

Featured Lock Resolved
Hi!
We encountering some problems in using Mega Menu on iPad, it's not working! I read trough all the other articles with similar questions but didn't find any solution.

Can you please have a look and tell me, what's wrong? Thanks in advance!

http://www.aagg.ch

Kind regards

10 Answers

Rifat Wahid Alif - Staff

More than a month ago #Permalink
Hi,
i saw responsive menu is ok.

MonicaKeist

More than a month ago #Permalink
Hi!

Thanks very much for your quick answer. Well, the responsive Menu is working fine on iPhone and other Smartphones. The problem is only on iPad (regular Menu, not responsive menu), Pop-Down Menu is not working on iPad.

Regards

Rifat Wahid Alif - Staff

More than a month ago #Permalink
could you please tell me about your pad regulation ?

MonicaKeist

More than a month ago #Permalink
Hi, thanks!

Sorry, I don't understand: Do you mean Template Settings or iPad Settings? Or iPad iOS version / iPad Version?

Regards

Rifat Wahid Alif - Staff

More than a month ago #Permalink
i was mean your ipad screen size

MonicaKeist

More than a month ago #Permalink
Screen of the IPad 2 is 9,7“. Resolution: 2048x1563 pixels at 264 ppi. iOS version 7.1.1 (11D201). Modell MD369FD/A

MonicaKeist

More than a month ago #Permalink
Hi again, here some additional information:

Clicking on a menu item doesn't trigger the drop-down menu: it just directly opens the linked page. So, on an iPad, visitors can not get on any subpage.

Is there any solution?

Thanks in advance!

Kind regards

Rifat Wahid Alif - Staff

More than a month ago #Permalink
Hi MonicaKeist,
well, you can increase the right icon width for that replace this css in 'menu.less' file:

.sp-mobile-menu ul li span.sp-menu-toggler {
display: block;
width: 30px;
float: right;
cursor: pointer;
color: #fff;
line-height: 40px;
text-align: center;
}


to

.sp-mobile-menu ul li span.sp-menu-toggler {
display: block;
width: 50%;
float: right;
cursor: pointer;
color: #fff;
line-height: 40px;
text-align: right;
padding-right: 10px;
}

MonicaKeist

More than a month ago #Permalink
Hi, thanks!

Sorry, still the same problem...

MonicaKeist

More than a month ago #Permalink
Ok, just to let you know, I solved the problem by myself:



$( document ).ready(function() {
$(".menu-item .parent";).removeAttr("href";);
});



I'm just removing the href attribute from the parent menu-items. Now it works fine.


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 119
Mehtaz Afsana Borsha

Mehtaz Afsana Borsha

Total Accepted Answers: 58
Ofi Khan

Ofi Khan

Total Accepted Answers: 50
Rashida Rahman

Rashida Rahman

Total Accepted Answers: 49
Toufiq

Toufiq

Total Accepted Answers: 43

121

Templates

319083

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us