We’re with you. JoomShaper is offering a 20% Discount on all plans due to the impact of COVID-19.

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Menu in the other language is not displayed

Featured Lock Resolved Issue
Hi there

Here's the LINK

The menu in the English language is not displayed. Why not? I can't find the error.

Domi

12 Answers

Dominik

More than a month ago #Permalink
Solution (with helix ultimate template):

- Make 2 templates - each for every language
- Don't forget the Menu assignment (Deutsch: Menüzugehörigkeit): Extensions - Templates - Menu assignment
- Select menues to the languages: Extensions - Templates - Template Options - Navigation - Select --> Main Menu ("Language";)

Hope it helped...

Domi

Ofi Khan - Staff

More than a month ago #Permalink
Hello Dominic,
Thank you for your question. Please check your main menu items and set languages to all for each menu.

- Best regards

Dominik

More than a month ago #Permalink
Hi Ofi

Please look at the Screenshots:

https://prnt.sc/t8invp

https://prnt.sc/t8iopa

https://prnt.sc/t8ip1w

I created modules:

https://prnt.sc/t8ipte

Did I forget something?

Domi

Dominik

More than a month ago #Permalink
Is there a solution? Thank you... :)

Domi

Ofi Khan - Staff

More than a month ago #Permalink
Apology for the delay. You need to set the association. Please see this screenshot.
Screenshot_2.png
This is English menu item and it has associations with other two languages. When language switches to French (for example), the menu item will be changed to French menu item. Please try this way. Hopefully, it will solve your issue.

- Best regards

Attachments (1)

  • Screenshot_2.png
    Screenshot_2.png 34.1 KB

Dominik

More than a month ago #Permalink
Apology for the delay. You need to set the association. Please see this screenshot.
[attachment]Screenshot_2.png[/attachment]
This is English menu item and it has associations with other two languages. When language switches to French (for example), the menu item will be changed to French menu item. Please try this way. Hopefully, it will solve your issue.

- Best regards


Hi Ofi

Please look at my screenshots in my posts before. I think I have done all you said...

Domi

catrophy

More than a month ago #Permalink
Same Problem here...

(@Dominik Konntest du das Problem lösen?)

Dominik

More than a month ago #Permalink
Same Problem here...

(@Dominik Konntest du das Problem lösen?)


Nein, leider nicht...

catrophy

More than a month ago #Permalink
i think this topic must be answered in detail and adequately. the standard phrase with the reference to this link is unsatisfactory -->( https://www.joomshaper.com/blog/step-by-step-tutorial-for-creating-a-multilingual-joomla-site ), because this is the topic with SP Page Builder. The menu does not change when you change the language, the content does.

Ofi Khan - Staff

More than a month ago #Permalink
Solution (with helix ultimate template):

- Make 2 templates - each for every language
- Don't forget the Menu assignment (Deutsch: Menüzugehörigkeit): Extensions - Templates - Menu assignment
- Select menues to the languages: Extensions - Templates - Template Options - Navigation - Select --> Main Menu ("Language";)

Hope it helped...

Domi


Thank you for sharing your solution.

- Best regards
Hello Ofi Khan
Tanks for your support. This is not working here... May i give you Access and you can have a look?


There are no replies made for this post yet.
Be one of the first to reply to this post!

126

Templates

333617

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us