Support Forums

Support Online : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

New release of page builder crashes my site

Featured Lock Resolved Bug
Hello
When I install the latest vesrion of sp page builder on my site
http://www.griffinshill.com.au.
Do you know what may cause this issue




screenshot_181.png screenshot_182.png

Attachments (2)

  • screenshot_181.png
    screenshot_181.png 177.3 KB
  • screenshot_182.png
    screenshot_182.png 432.7 KB

27 Answers

Paul Frankowski - Staff

More than a month ago #Permalink
Hi,
looking about your 1st screen - It may be Joomla cache problem.
As I remember Your server offers super cache for websites, please refresh/clean cache.

about 2nd, hard to say...
1) From which version you updated?
2) What template you have there?
3) You have to check server logs.

Frank

More than a month ago #Permalink
Hi Paul
Thanks for your reply.
I am not sureif it is a cache problem, as the first screen shot is after I upgrade pagebuilder from 3.4.1 to 3.4.2. I have tried a few of times and it always breaks up my site.
When I reinstall backup fromm cpanel all works again so I think there must be some incompatibility issue or something else happening
The template I am using is Helix Ultimate
There don't seem to be any error logs in the cpanel

Markus

More than a month ago #Permalink
I also have a problem after updating. links don't work anymore and reload the current page. Unfortunately I didn't take a backup before updating. Can I maybe install the older version of Page Builder again?

Paul Frankowski - Staff

More than a month ago #Permalink
You hosting provider have a backup, if not ..change hosting company.
---
In most cases, it's very easy to fix a problem with links

.sppb-row-overlay {z-index: 0;}


must be added in CSS of a page where you have problems, OR in global custom CSS for whole website

Paul Frankowski - Staff

More than a month ago #Permalink
Version 3.4.2. is an improved version of 3.4.1, we added an option to clear CSS and fixed styles problem for modules.
Maybe you have to disable Production Mode.
---

If you have Akeeba Tools
AB.jpg

Attachments (1)

  • AB.jpg
    AB.jpg 138.3 KB

Frank

More than a month ago #Permalink
Thanks Paul
I don’t have alerts tools. So that can’t be the problem
Where do I add the custom css
.sppb-row-overlay {z-index: 0;}
for global as all the pages links don’t work with the latest sp page builder update?
Are you planning to resolve this issue with the next update?
Thanks and regards
Frank Jesse

Paul Frankowski - Staff

More than a month ago #Permalink
Frank, do you really never seen our documentation section? This joke is not funny.
This fix is ONLY for links problems when you cannot click them.

Frank

More than a month ago #Permalink
Hi Paul
I understand that it can be frustrating answering all the many questions you get.
But my question related to an update to SP pagebulder that crashed my site and I dont think it is a joke also.
I did clear the cache after the update and the cache on my web browser ( as suggested in your docs) and I still have the problem of all the pages of the web site breaking up.

Frank

More than a month ago #Permalink
Hi Paul
I HAVE MADE A STAGED COPY OF THE WEB SITE AND UPGRADED SPPAGE BUILDER CLEARED CACHE ON SITE AND BROWSER AND I AM STILL GETTING THE SAME PROBLEM
https://staging1.griffinshill.com.au
https://www.griffinshill.com.au
IF YOU LOOK AT BOTH SITES YOU WILL SEE THAT THE UPGARDED SITE IS NOT RENDERING PROPERLY
I HAVE EVEN TRIED IT ON A DIFFERENT BROWSER TO NO EVAIL

Paul Frankowski - Staff

More than a month ago #Permalink
Frank, to be honest, I don't see big design differences between those sites. Firefox.
The main problem is DUPLICATED two rows "We make it easy to relax" and testimonial and faq

Does it mean that you have this same rows (twice) 2x in a layout? please check. Thanks

---
I recorded short video as evidence : https://youtu.be/xW_2uJECh-4

Frank

More than a month ago #Permalink
Thanks Paul
For looking into this I am sorry the Home page and the blog page work but all the others that have Sp tabs enabled are broken in the stage site. When I diable the sp tabs module in SP page builder the page loads but without the tabs content See https://staging1.griffinshill.com.au/teacher-training however the page doesnt load with tabs enabled see https://staging1.griffinshill.com.au/about-us.
I am trying hard to resolve this myself in the stageit enviroment but if you have any ideas it would be much appreciated
And thanks for pointing out the duplicate content on the home page

Paul Frankowski - Staff

More than a month ago #Permalink
Thanks.
Hopefully, somehow you are still online, even though you have a different time zone. AU - EU
Can you...

1) Disable Preloader from template settings (it only slow loading process)
2) Enable Error to MAX (screenshot)
3) Answer me (sorry if I may ask again):
a) On SPPB 3.3.8 was OK?
b) On SPPB 3.4.1 was OK?
c) Do you still have site backup based on 3.3.8 to update directly to 3.4.2

Frank

More than a month ago #Permalink
Hi Paul
The live site https://www.griffinshill.com.au is using SPPB 3.4.1 and is working perfectly.
I dont think I have a backup now of 3.3.8 and I have changed quite bit on the site since that release.
I have enabled error to max and diabled preloader.
Regards Frank

Frank

More than a month ago #Permalink
Hi Paul
I have just understood what you mean by duplicate content on the home page. In fact the content is triplicated under the "what is Iyengar yoga tab" and the "Learn more about Griffins Hill Retreat"
Very strange!
The live site is working perfectly in this regard

Frank

More than a month ago #Permalink
Hi Paul

I have just made another staged copie of the web site https://staging2.griffinshill.com.au
I updated the regular labs component before updating sp page builder and it seems to have fixed some of the problems?!! Except for three pages
https://staging2.griffinshill.com.au/yoga-classes
https://staging2.griffinshill.com.au/teacher-training
https://staging2.griffinshill.com.au/about-us
The home page is loading now without the duplicates however the about us page is making the duplicates
So I think it must be a conflict between Sp Page Builder 3.4.2 and Components Anywhere (by regular Labs https://www.regularlabs.com/extensions/componentsanywhere)

Attachments (1)

  • screenshot_185.png
    screenshot_185.png 407.6 KB

Frank

More than a month ago #Permalink
Update:
I have contacted regular labs. They suggested playing with the settings, which I did without any improvement.
If I turn the component off pages load but without the content in the tabs. So there definitely is a conflict with that component and SP page Builder 3.4.2

Media_PTW

More than a month ago #Permalink
Hi everybody,

I've got the same issue here, but when all cacheing plug-ins have been turned off the issue is gone.
Even when I turn on the joomla system page cache plug-in the problem appears. Also with all regular labs plug-ins turned off no change, the issue still persists. Therefore in my opinion this is an caching issue.

Paul Frankowski - Staff

More than a month ago #Permalink
Thanks Media_PTW
---
We cannot save the world, that's why conflicts between extensions are beyond support.
Indeed, cache plugin and code compression plugins may also cause problems.

Frank

More than a month ago #Permalink
Hi Paul
I have spent quite a few hours trying to solve this conflict.
My website works perfectly with SP Page Builder 3.4.1 and the regular labs component plugin but breaks when I update to pagebuilder 3.4.2. Same with 3.4.3.
There must be a change to the structure of the updated page builder that is conflicting with regular labs components! I have tried changing the settings in in regular labs plugin to no avail.
Is there a fix to make regular labs component plugin work or can please fix it before the next update?

Paul Frankowski - Staff

More than a month ago #Permalink
Components Anywhere - You have installed Free or Pro version?

Frank

More than a month ago #Permalink
Components Anywhere - You have installed Free or Pro version?


Free version but happy to purchase pro if that would solve the issue

Paul Frankowski - Staff

More than a month ago #Permalink
The last questions:
1) On how many subpages you use (or have to use) Components Anywhere?
2) Do you really need to use Components Anywhere?
There is no other way, for example, to use SPPB module instead.

---
The rule is simple, the more hacks you install the bigger the possibility that something else may go wrong.

Frank

More than a month ago #Permalink
Hi Paul
Thanks for getting back.
I have tried using SPPB module instead but ran into some difficulties
1)Some the pages did not display in the mobile view via the modules in sp tabs
2) I found it dificult to adjust the width of the diplayed module page
3) I also display the pages built in page builder on the home page by a button and a link to the url.
For example https://www.griffinshill.com.au/seven-day-autumn-retreat is displayed via the button link on the home page and via sptabs on the retreats page: https://www.griffinshill.com.au/seven-day-autumn-retreat
I would be happy to beable to do it another way that would work as efficiently as possible but nothing I have tried so far works except regular labs and SPPB 3.4.2
[attachment]Home Page.png[/attachment]
[attachment]Retreat page with tabs .png[/attachment]
As in screen shot both the circled button on the home page and the circled tab on the retreats page need to dislpay the same content
https://www.griffinshill.com.au/three-day-retreats

Regards

Frank Jesse


[attachment]Home Page.png[/attachment] [attachment]Retreat page with tabs .png[/attachment]

Paul Frankowski - Staff

More than a month ago #Permalink
No screenshots :(
---
Sorry as you know extension conflicts are beyond support. Every update is a risk, Joomla has 7000 extensions. Always there is (and will be) a problem with something.
----
I will send this topic to our developer, but personally, I cannot do more.
---

Frank

More than a month ago #Permalink
Well I do hope you can fix it or find a way to get sp tabs to display contents of sp pages as neatly as components anywhere does, otherwise I will not be able to update and get the latest features of sp pagebuilder.

Paul Frankowski - Staff

More than a month ago #Permalink
Sorry, but you have to keep an old version of SPPB on that site.
Or find freelancer developer who will write you a hack code.

Frank

More than a month ago #Permalink
Hi Paul
Thanks for all your help. I have actually resolved the isse by using group buttons as a module and publishing that on each page. Not quite as neat solution as showing all the pages in tabs but it does mean that my page loads faster and I am not using any hacks.


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 135
Sifat

Sifat

Total Accepted Answers: 86
Toufiq

Toufiq

Total Accepted Answers: 53
Pavel

Pavel

Total Accepted Answers: 6
Rifat Wahid Alif

Rifat Wahid Alif

Total Accepted Answers: 5

114

Templates

293079

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us