Support Forums

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

OG Image reads the thumbnail

Featured Lock Resolved Bug
When inserting an Open Graph image through page options Facebook detects the thumbnail not the actual image itself.

https://irez.cc/images/2017/11/16/_spmedia_thumbs/fb-og.jpg

9 Answers

Paul Frankowski - Staff

More than a month ago #Permalink
Hi,
I checked SPPB 3, and OG image is set as it should be :

<meta content="http://domain.com/images/chosen.jpg" property="og:image" />


Sorry, but we cannot change behavior of Facebook bot is it's too stupid to recognize image set according to Facebook manual.

typvsns

More than a month ago #Permalink
I am having a similar issue. I have told PageBuilder the correct graphic I want to use but it keeps putting in the thumbnail instead. I want Facebook to pick up the larger image to make a wide image post. PageBuilder, as you can see, tells it to pick the thumbnail.


<meta content="http://www.inventright.com/images/2017/12/08/_spmedia_thumbs/osi-fb-graphic3.jpg" property="og:image" />


Any idea how to tell PageBuilder to list the full size graphic as the og:image?
Thanks!

Paul Frankowski - Staff

More than a month ago #Permalink
But you choose OG image manually here (screenshot) for each Page separately.
So select bigger image.

Attachments (1)

  • img.png
    img.png 14.9 KB

typvsns

More than a month ago #Permalink
Yes, I selected the image there but it puts in the Thumbnail (see the code I posted above). I found a way around it with another extension that puts in the tags for me. I would however like to just do it in PageBuilder.

Paul Frankowski - Staff

More than a month ago #Permalink
We may consider changes, but not in December.

typvsns

More than a month ago #Permalink
Oh I see it defaults to the thumbnail. Great. Ok. Yes please put that as a future change. That would be helpful. Once I was able to put the right graphic in with the other extension It worked fine. See attachment.

Attachments (1)

  • screenshot.jpg
    screenshot.jpg 50.6 KB

teddirez

More than a month ago #Permalink
It's not really a change, but a bug fix. Paul you provided an example of what it should do, but it doesn't. Facebook is only detecting what the template is outputting.
I added the image as you described, but for some reason the output keeps reverting to the thumbnail directory.

I've had to resort to using a 3rd party plugin to resolve the issue for now..

Paul Frankowski - Staff

More than a month ago #Permalink
ok, I will check it again.

Paul Frankowski - Staff

More than a month ago #Permalink
I can confirm, it's issue.
I will ask for update/fix


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 145
Sifat

Sifat

Total Accepted Answers: 91
Toufiq

Toufiq

Total Accepted Answers: 59
Rifat Wahid Alif

Rifat Wahid Alif

Total Accepted Answers: 15
Pavel

Pavel

Total Accepted Answers: 6

100+

Templates

200,000+

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us