We’re with you. JoomShaper is offering a 20% Discount on all plans due to the impact of COVID-19.

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Page Builder does not load Integration options for Joomla Articles

Featured Lock Resolved Issue
I have created a fresh Joomla 3 website. Installed latest version of JCE editor and SP Page Builder.

However, when I go to the Integrations tab I get the following error message " 0 Call to undefined method SppagebuilderHelperIntegrations::getCurlData()" and then asked to return to control panel.

However, on another website it downloaded both the Joomla Articles and K2 integration options.

Assistance urgently required.

16 Answers

Robert Hicks

More than a month ago #Permalink
Uff.. if any will appear let us know.


I discovered what the issue was - changing the PHP setting in CPanel from 7.0 (native) to 7.0 as default rectified the issue ... Integrations now are made visible in Page Builder.

Works like a dream now ....

Paul Frankowski - Staff

More than a month ago #Permalink
Hi,
do you have " ...getCurlData()" error on TinyMCE as well?
If not please use that editor it until on Monday our developer will check a reason.
What is weird I don't remember that anybody before you had this issue.

Paul Frankowski - Staff

More than a month ago #Permalink
Please use hosting support and ask them if you have enabled/installed cURL library !!!
check all settings from here: https://www.joomshaper.com/documentation/sp-page-builder/sp-page-builder-2-x#technical-requirements-php-settings

Robert Hicks

More than a month ago #Permalink
Hi,
do you have " ...getCurlData()" error on TinyMCE as well?
If not please use that editor it until on Monday our developer will check a reason.
What is weird I don't remember that anybody before you had this issue.


The same error message occurs when TinyMCE is set as the default editor too. I dowloaded a "fresh"copy of SP Page Builder and re-installed and checked it on both Safari and Google Chrome ... but same error

"An error has occurred.
0 Call to undefined method SppagebuilderHelperIntegrations::getCurlData()" and does not show the integration options.

Most frustrating!!

Paul Frankowski - Staff

More than a month ago #Permalink
I believe, but please compare our technical requirements with your server.
---
have you got 2nd server, maybe localhost to check it there as well, you will see ...

intodanish.com

More than a month ago #Permalink
I have PHP 7.x and meet all of the requirements including SP latest version and cURL and still get the error :/ and have TinyMCE as the default and for the user. ;(

Paul Frankowski - Staff

More than a month ago #Permalink
Ok, I will ask developer

Brian Baldwin

More than a month ago #Permalink
Same problem here, I am looking to use K2 and found this thread and said ok this is how I do it. When I go to integrations I get the same error

0 Call to undefined method SppagebuilderHelperIntegrations::getCurlData()

I am not sure why the editor matters since shouldn't be calling up the editor but TinyMCe, as well as JCE 2.6.15, tried and same result.

I run the server I am using, php 7x with Curl is enabled.

Paul Frankowski - Staff

More than a month ago #Permalink
I cannot help, all team is OUT till 3.07.2017.
---
1) maybe switch to PHP 5.6 and check thsi settings again
2) K2 - really, you have to be brave or ___ ?
Are you sure that you want to use K2 component which is almost not developer anymore (last update was 1 year ago).
But OK it's your choice, but I warned you.

Brian Baldwin

More than a month ago #Permalink
I have over 2000 articles in K2 on a very popular news website getting over 400,000 unique views a year, the return is through the roof. Ive enjoyed all the additional plugins, integrations and customizations. One thing I notice today on a new website I am building that to attach an image to a Joomla article I have to do so many more steps and to get it to where I would want it. It's cumbersome.

Paul Frankowski - Staff

More than a month ago #Permalink
Yes, now I understand. Migration can be painful. But you have to also look 2 steps behind, what happen if K2 will be not compatible with J 3.8, hmm.
---
please check (1) from my last post.

Robert Hicks

More than a month ago #Permalink
I just started my site from scratch and there is no problem with the new install.

Paul Frankowski - Staff

More than a month ago #Permalink
Uff.. if any will appear let us know.

Brian Baldwin

More than a month ago #Permalink
Basically what I have found is that the integrations portion of Page builder does not work unless it is 5x it does nto work for 7x and that is not just for K2, if I switch down to 5x I can see articles as well as K2.

This is not just about K2, the integrations does not work in 7.0 environment.

Paul Frankowski - Staff

More than a month ago #Permalink
I use Article Integration with PHP 7.0.x ,
K2 I do not touch anymore ..am not so desperate to use software update once a year.


There are no replies made for this post yet.
Be one of the first to reply to this post!

126

Templates

333946

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us