Support Forums

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Page Templates in Page Builder Pro not loading

Featured Lock Resolved Issue
Hi there,

In one of our other sites, we use Page Builder Pro and when we click on Page Templates we get a bunch of choices in a window that opens.

In the site we are working on now, when we click on Page Templates, the modal window starts to open, but it's just a thin white strip across the top and does not load any Page Layout Template choices. How can we get these choices?

Thanks

Attachments (1)

  • ScreenShot3082.jpg
    ScreenShot3082.jpg 97.2 KB

24 Answers

Paul Frankowski - Staff

More than a month ago #Permalink
Hi,
1) Check server settings according to SPPB Manual.
2) Enable GZip for website
3) Try from 2nd browser

Chris M.

More than a month ago #Permalink
Hi Paul,

Thanks so much for your reply.

I will do that right now. Although, we never had to do that with our other site, and it works fine. I'll report back though.

Thanks so much,

-Chris

Chris M.

More than a month ago #Permalink
Okay, Still doesn't work.

We're all set on everything all the things you said to check, I think, except for allow_url_fopen = On When I enabled that, it brought down our whole site, so I had to turn it back off.

What is that for anyway?

I also don't understand, because none of this is necessary on the other instances of Page Builder Pro and the Page Templates load fine. All these sites are on the same server.

Is there anything else I can try?

Thanks so much,

-Chris

Paul Frankowski - Staff

More than a month ago #Permalink
Maybe you have enabled:
extra security layer for this domain, I mentioned about it here in yellow box (scroll down):
https://www.joomshaper.com/documentation/sp-page-builder/sp-page-builder-2-x#technical-requirements-php-settings

Chris M.

More than a month ago #Permalink
Okay, we'll try. Thank you very much for your assistance.

Cheryl

More than a month ago #Permalink
Good Day,

I have installed the pro version and followed all instructions but i am getting a white blank screen when trying to add a page or template or even eidt an existing page

Paul Frankowski - Staff

More than a month ago #Permalink
Hi again,
please check point by point "PHP configuration" from : https://www.joomshaper.com/documentation/sp-page-builder/sp-page-builder-3#general

last 3 points are very important.

glenanPL

More than a month ago #Permalink
Hi
I have tested all the solution of this page but with some website, the template is not loading, just turn!
With another website it’s OK!
What can I do?
Regards,
PL

Attachments (1)

  • sp-page-builder-bug-template.png
    sp-page-builder-bug-template.png 51.4 KB

Paul Frankowski - Staff

More than a month ago #Permalink
This section is loaded from our API, there is a possibility that it's banned from your country.
Some users from RU had this problem.
Can you try edit site using a VPN? For example, the Opera browser has this option.

Ralph-Uwe Scherer

More than a month ago #Permalink
Interesting. Did my IP get banned? 108.28.178.207

I am having the same issue all of a sudden. This was working fine a couple of days ago and now none of my sites are allowing me to import any templates. I just get a spinning wheel of Joomshaper death. :-)

Ralph-Uwe Scherer

More than a month ago #Permalink
Just started working after I renewed my DHCP Lease or perhaps you whitelisted my IP?

Ralph-Uwe Scherer

More than a month ago #Permalink
Just in case this helps I am documenting the PHP exception that occurred when I was not getting the templates to load. Maybe it's a Cloudflare thing since they are a proxy?



Exception Type: Exception
File: /home/raaffxa/public_html/libraries/src/MVC/Controller/BaseController.php
Line: 594
Message: View class not found [class, file]: sppagebuilderViewajax, /home/raaffxa/public_html/components/com_sppagebuilder/views/ajax/view.json.php

#0 /home/raaffxa/public_html/libraries/src/MVC/Controller/BaseController.php(841): Joomla\CMS\MVC\Controller\BaseController->createView('ajax', 'sppagebuilderVi...', 'json', Array)
#1 /home/raaffxa/public_html/libraries/src/MVC/Controller/BaseController.php(621): Joomla\CMS\MVC\Controller\BaseController->getView('ajax', 'json', 'sppagebuilderVi...', Array)
#2 /home/raaffxa/public_html/components/com_sppagebuilder/controller.php(39): Joomla\CMS\MVC\Controller\BaseController->display(false)
#3 /home/raaffxa/public_html/libraries/src/MVC/Controller/BaseController.php(710): SppagebuilderController->display()
#4 /home/raaffxa/public_html/components/com_sppagebuilder/sppagebuilder.php(26): Joomla\CMS\MVC\Controller\BaseController->execute('')
#5 /home/raaffxa/public_html/libraries/src/Component/ComponentHelper.php(402): require_once('/home/raaffxa/...')
#6 /home/raaffxa/public_html/libraries/src/Component/ComponentHelper.php(377): Joomla\CMS\Component\ComponentHelper::executeComponent('/home/rffxahmi/...')
#7 /home/raaffxa/public_html/libraries/src/Application/SiteApplication.php(194): Joomla\CMS\Component\ComponentHelper::renderComponent('com_sppagebuild...')
#8 /home/raaffxa/public_html/libraries/src/Application/SiteApplication.php(233): Joomla\CMS\Application\SiteApplication->dispatch()
#9 /home/raaffxa/public_html/libraries/src/Application/CMSApplication.php(196): Joomla\CMS\Application\SiteApplication->doExecute()
#10 /home/raaffxa/public_html/index.php(49): Joomla\CMS\Application\CMSApplication->execute()
#11 {main}
Request information

GET variables

Array
(
[option] => com_sppagebuilder
[view] => ajax
[format] => json
[callback] => pre-page-list
[editarea] => frontend
)
POST variables

Array
(
)
COOKIE variables

Array
(
[__cfduid] => da992569a829e74a320e1a120c7fdb4831551211734
[__atuvc] => 35|12,0|13,116|14,52|15,46|16
[_ga] => GA1.2.946452629.1551211741
[cookieconsent_status] => allow
[__atssc] => google;17
[e59cfc2522edf90c2ea939a4a5808da1] => __SITE__656
[23ce7822bd0c9924aafe98e681e4c730] => 0
[8195ee7bd1507d32590d6bd5b657668c] => 51cd371f780592c6a7e960569676eb7f
[4392c6f6a1d17ab3fd45c12d5f3b1f0a] => a1ebec07d0925018fa8094e5785c2193
[__atuvs] => 5cb8aa07d56832b7025
[_gid] => GA1.2.705892987.1555606025
)
REQUEST variables

Array
(
[option] => com_sppagebuilder
[view] => ajax
[format] => json
[callback] => pre-page-list
[editarea] => frontend
[__cfduid] => da992569a829e74a320e1a120c7fdb4831551211734
[__atuvc] => 35|12,0|13,116|14,52|15,46|16
[_ga] => GA1.2.946452629.1551211741
[cookieconsent_status] => allow
[__atssc] => google;17
[e59cfc2522edf90c2ea939a4a5808da1] => __SITE__656
[23ce7822bd0c9924aafe98e681e4c730] => 0
[8195ee7bd1507d32590d6bd5b657668c] => 51cd371f780592c6a7e960569676eb7f
[4392c6f6a1d17ab3fd45c12d5f3b1f0a] => a1ebec07d0925018fa8094e5785c2193
[__atuvs] => 5cb8aa07d56832b7025
[_gid] => GA1.2.705892987.1555606025
[Itemid] =>
)
SERVER variables

Array
(
[PATH] => /bin:/usr/bin:/usr/local/bin
[HTTP_ACCEPT] => application/json, text/javascript, */*; q=0.01
[HTTP_ACCEPT_ENCODING] => gzip
[HTTP_ACCEPT_LANGUAGE] => en-US,en;q=0.5
[HTTP_CONNECTION] => Keep-Alive
[CONTENT_TYPE] => text/plain;charset=UTF-8
[CONTENT_LENGTH] => 15
[HTTP_COOKIE] => __cfduid=da992569a829e74a320e1a120c7fdb4831551211734; __atuvc=35%7C12%2C0%7C13%2C116%7C14%2C52%7C15%2C46%7C16; _ga=GA1.2.946452629.1551211741; cookieconsent_status=allow; __atssc=google%3B17; e59cfc2522edf90c2ea939a4a5808da1=__SITE__656; 23ce7822bd0c9924aafe98e681e4c730=0; 8195ee7bd1507d32590d6bd5b657668c=51cd371f780592c6a7e960569676eb7f; 4392c6f6a1d17ab3fd45c12d5f3b1f0a=a1ebec07d0925018fa8094e5785c2193; __atuvs=5cb8aa07d56832b7025; _gid=GA1.2.705892987.1555606025
[HTTP_HOST] => http://www.wrmea.org
[HTTP_REFERER] => https://www.wrmea.org/administrator/index.php?option=com_sppagebuilder&view=page&layout=edit
[HTTP_USER_AGENT] => Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:66.0) Gecko/20100101 Firefox/66.0
[HTTP_X_FORWARDED_FOR] =>
[HTTP_CF_RAY] => 4c98cc3e0b78cf62-IAD
[HTTP_X_FORWARDED_PROTO] => https
[HTTP_CF_VISITOR] => {"scheme":"https"}
[HTTP_X_REQUESTED_WITH] => XMLHttpRequest
[HTTP_CF_CONNECTING_IP] =>
[HTTP_CDN_LOOP] => cloudflare
[DOCUMENT_ROOT] => /home/raaffxa/public_html
[REMOTE_ADDR] =>
[REMOTE_PORT] => 19416
[SERVER_ADDR] =>
[SERVER_NAME] => http://www.wrmea.org
[SERVER_ADMIN] => [email protected]
[SERVER_PORT] => 443
[REQUEST_URI] => /index.php?option=com_sppagebuilder&view=ajax&format=json&callback=pre-page-list&editarea=frontend
[PROXY_REMOTE_ADDR] =>
[HTTPS] => on
[UNIQUE_ID] => [email protected]
[SSL_PROTOCOL] => TLSv1.3
[SSL_CIPHER] => AEAD-AES128-GCM-SHA256
[SSL_CIPHER_USEKEYSIZE] => 128
[SSL_CIPHER_ALGKEYSIZE] => 128
[SCRIPT_FILENAME] => /home/raaffxa/public_html/index.php
[QUERY_STRING] => option=com_sppagebuilder&view=ajax&format=json&callback=pre-page-list&editarea=frontend
[SCRIPT_URI] => https://www.wrmea.org/index.php
[SCRIPT_URL] => /index.php
[SCRIPT_NAME] => /index.php
[SERVER_PROTOCOL] => HTTP/1.1
[SERVER_SOFTWARE] => LiteSpeed
[REQUEST_METHOD] => POST
[X-LSCACHE] => on
[PHP_SELF] => /index.php
[REQUEST_TIME_FLOAT] => 1555613137.6664
[REQUEST_TIME] => 1555613137
)

c

4 weeks ago #Permalink
I have the same problem all of a sudden. Tempates can't load. Local i get a white screen. On the server get the message: lay-out not found when i try to import

Paul Frankowski - Staff

4 weeks ago #Permalink
@C
Have you updated SPPB Pro in meantime?
Please check if you have this same problem with SPPB 3.4.7 / 3.4.8
Hi
I have the same problem Page Templates doesn't load with SPPB I tried version 3.4.8 and 3.4.9
It was working fine previously and I haven't changed anything on my website.
I don't use that feature very often but isn't it strange it is not working anymore ?
Hope you can help

Paul Frankowski - Staff

4 weeks ago #Permalink
@Sophie
worked with SPPB 3.4.7 ?

c

4 weeks ago #Permalink
@C
Have you updated SPPB Pro in meantime?
Please check if you have this same problem with SPPB 3.4.7 / 3.4.8

I'm on 3.4.9
@Sophie
worked with SPPB 3.4.7 ?


I can't remember if it did as I don't use this feature very often.
I am going ti re-install SPPB Pro 3.4.7 on my local server and I'll let you know asap
@Sophie
worked with SPPB 3.4.7 ?


I've re-installed all versions back to 3.3.8 and Page templates aren't working in any of the versions !!
I am positive that it did work with a SPPB 3.4.x version as I used a page template not long ago.

Furthermore the Sections Library isn't loading either but My Sections are loading.
I tried with Firefox and Chrome same problem ...
I am on Joomla 3.9.5 and Helix Ultimate
Hope you can fix it
Thanks
Sophie
I have a feeling Joomshaper is working on a fix but it might take a while and they just don't know how long so perhaps no news is good news? But if no news is good news does that mean good news is no news?:D ;)

Fabio

3 weeks ago #Permalink
Hello,
same problem here.

Templates In Page Builder Pro Not Loading.

Helix and Page Builder updated at last versions.

Thanks for your attention, have a nice day.

rbi

One week ago #Permalink
Hi,
Any news on the matter, not working for me neither with v3.4.10
Thanks

Paul Frankowski - Staff

One week ago #Permalink
I have a fix. I will send if you want to be beta testers before the official update.

some volunteers here?
I have a fix. I will send if you want to be beta testers before the official update.

some volunteers here?


Yes, I want, I need this correction.


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Leaderboard (30 days)

Sifat

Sifat

Total Accepted Answers: 114
Paul Frankowski

Paul Frankowski

Total Accepted Answers: 113
Toufiq

Toufiq

Total Accepted Answers: 58
Pavel

Pavel

Total Accepted Answers: 4
Peter Atkin

Peter Atkin

Total Accepted Answers: 2

100+

Templates

200,000+

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us