We’re with you. JoomShaper is offering a 20% Discount on all plans due to the impact of COVID-19.

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

PageBuilder is very, very, very slow trying to save or load a page.

Featured Lock Resolved Issue
PageBuilder is very, very, very slow trying to save or load a page.

I've seen some posts with the same problem but no solution. I have everything in current versions.

Is a video showing how I'm waiting for content to load and then a long time to save:

16 Answers

Paul Frankowski - Staff

More than a month ago #Permalink
Hi,
I guess it wasn't like that since beginning?
---
PHP version?
Hosting company name?
---
Remember! Hosting (Server) should work in the Fast CGI mode or in FRN mod.
Hi,
I guess it wasn't like that since beginning?
---
PHP version?
Hosting company name?
---
Remember! Hosting (Server) should work in the Fast CGI mode or in FRN mod.


Yes. It wasn't like that before.

PHP 7.2 (ea-php72). Smarthost polish hosting company.
On the same server we have other websites that work normally.

How can we deal with this? This is a serious problem for us. :(

Paul Frankowski - Staff

More than a month ago #Permalink
1) Try with PHP 7.3, for SPPB is OK.
2) Yes, I know Smarthost, also his owner we met many times on Joomla events.
I mentioned about them in my book about Wordpress & Joomla security, wyd. Helion.
Maybe you have seen/read: https://helion.pl/view/3926o/jowozr.htm

I will ask our developer

Paul Frankowski - Staff

More than a month ago #Permalink
BTW
For sure delete (!) addons that you don't use anymore on each page.
Simple Disable won't help.

Gianluca Pantaleo

More than a month ago #Permalink
Hi, same problem here: sp page builder is very slow while opening, and saving pages.

SP page builder: 3.7.2
Joomla: 3.9.16
Php: 7.3

In my error logs I got:
Sat Apr 18 13:13:08.876119 2020] [fcgid:warn] [pid 4137:tid 47016283920128] [client 185.81.4.195:42698] mod_fcgid: can't apply process slot for /usr/local/cpanel/cgi-sys/sp-ea-php73

Paul Frankowski - Staff

More than a month ago #Permalink
Ask hosting support about that error message,
we cannot do that instead of you, sorry.

Gianluca Pantaleo

More than a month ago #Permalink
They told me to ask to the SP page builder developer team.

Paul Frankowski - Staff

More than a month ago #Permalink
I understand, ping-pong game rule. It's quite common from hosting support.
---
Please answer to that questions:
1) Do you have this same problem if the Page is very basic with 2-or-4 addons only?
2) Can you switch to PHP 7.2 and test again this same problematic page?
3) DO you have this problem since the beginning or it started after __(what)__ ?

---
Today is Saturday, tomorrow Sunday...
and the developer office is opened on Monday so I cannot help more during the weekend.

Gianluca Pantaleo

More than a month ago #Permalink
1) Yes, I do. Same problem if a page has 20 o 2 addons. I also created a page without addons and the problem exists. The problem starts also from the beginning when I click on "new page" also the creation of a new page is slow.
2) Switched from PHP 7.3 to 7.2 and 7.1, problem persist.
3) No, I don't. The problem started when I upgraded SP page builder from 3.7.1 to 3.7.2
I'll give you SuperAdmin and FTP password in DM.

Paul Frankowski - Staff

More than a month ago #Permalink
Please switch to PHP 7.2 or PHP 7.3 and send me access as Super User.

(Click to my avatar to see Private Message button)

Gianluca Pantaleo

More than a month ago #Permalink
Already sent to you yesterday.

Gianluca Pantaleo

More than a month ago #Permalink
Please switch to PHP 7.2 or PHP 7.3 and send me access as Super User.

(Click to my avatar to see Private Message button)


Hi, any news, please? I sent access to you. Thanks

Paul Frankowski - Staff

More than a month ago #Permalink
Thanks,
I didn't forget about you, I just wait as you for the developer respond.

Gianluca Pantaleo

More than a month ago #Permalink
Ok, thank you very much. In the meantime I'm talking with my hosting provider and they told to me about a few woarning:
mod_fcgid: can't apply process slot for /usr/local/cpanel/cgi-sys/sp-ea-php73
and about PHP process simultaneus limit. I can't know what they mean because I'm not a developer.

Gianluca Pantaleo

More than a month ago #Permalink
Hi, I haven't heard you for a few days, problem persist here, have you any news, please? Thanks

Paul Frankowski - Staff

4 weeks ago #Permalink
We can help only with our software, not about hosting issues.
You have to talk with them about why there is a big delay during save etc..

You can install your website on localhost software to check how it works,
it would be the best way to check on which side the problem may be.


There are no replies made for this post yet.
Be one of the first to reply to this post!

126

Templates

333678

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us