Support Forums

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Person addon styles not applied

Featured Lock Resolved Issue
I have an SP page builder page that presents profiles of members of the board using the 'person' add-on.
The problem is that any styling applied in the 'Style' tab of the add-on does not get applied.

If you go to https://dev.vicsim.org/index.php/about-us/board-of-management you will notice that there is no margin between the Karen Livesay and John Doe profiles. Neither is text color, background color or border applied.

The 'board of management ' attachment shows the page and the problem.
The other attachment shows the style settings for the Karen Livesay person addon.

There is no other styling being applied in any custom css for this addon that could be causing a problem.

I've used the developer tools to inspect the add-on and it seems to be missing the reference to the css that I've seen in other add-ons. eg #sppb-addon-1529374582703{ }

The site is operating on:
2.5.3 helix
3.2.3 sp page builder
Joomla! 3.8.8 Stable

Attachments (2)

  • Board of management.png
    Board of management.png 807.8 KB
  • SP-Page Builder-Edit Page-Style-Karen Livesay.png
    SP-Page Builder-Edit Page-Style-Karen Livesay.png 20 KB

6 Answers

Al Mamun - Staff

More than a month ago #Permalink
Hi,
This is not actually SPPB problem, 2.5.3 and 3.x is fully different. If you see 2.5.3 is working actually not. If you use 2.5.3 you will not get front live editing feature.
Thanks,
Mamun

Al Mamun - Staff

More than a month ago #Permalink
Hi,

I have check my PC those option are working fine. Please take look the attachment. Can you please give site login details in PM. So, I can check what is happening.

Thanks,
Mamun

Attachments (1)

  • Screenshot_6.png
    Screenshot_6.png 292.5 KB

vladm

More than a month ago #Permalink
Further investigation reveals that its a combination of the Aplikko.com Flex template and SP page builder 3.2.3 that creates this problem. The testing I've done shows the following:

Flex 2.7 + SPPB 2.5.3 = OK
Flex 3.0.3 + SPPB 2.5.3 = OK
Flex 2.7 + SPPB 3.2.3 = Problem
Flex 3.0.3 + SPPB 3.2.3 = Problem
Protostar + SPPB 3.2.3 = OK

Al Mamun - Staff

More than a month ago #Permalink
Hi,

Thanks for co-operation. I have checked that you override Pagebuilder addons in your template. Can you please delete override "Person" addon from template folder then clear the cache and check that addon working fine or not.
Please make sure backed the addon before delete.

Thanks,
Mamun

vladm

More than a month ago #Permalink
I can confirm that your solution does fix the problem.

However, it doesn't explain why the problem doesn't occur with SPPB 2.5.3.

It seems like that this is still a SPPB problem rather than a template problem.


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Leaderboard (30 days)

Sifat

Sifat

Total Accepted Answers: 137
Paul Frankowski

Paul Frankowski

Total Accepted Answers: 123
Toufiq

Toufiq

Total Accepted Answers: 64
Pavel

Pavel

Total Accepted Answers: 5
W

woonydanny

Total Accepted Answers: 2

100+

Templates

200,000+

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us