Support Forums

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Problems with URL's Friendly and SP Property

Featured Lock Resolved Issue
When I have the Friendly URLs activated in the SP Property module, I get the following error: Error 404 "Call to a member function get () on null" error! When I do not have the Friendly URLs activated, the problem does not appear.

Reviewing the forum, I read that the property and agent menus should be created:

Please make sure that you have assign menu for SP Property » properties and SP Property » agents if you don't want to show in the menu the make it hide or create a hidden menu for this.


So create both as you can see in the attached images, but the problem continues.

What other detail should I review?

I have PHP7.2 and Joomla 3.9.

Attachments (3)

  • Menu_Module.jpg
    Menu_Module.jpg 36.7 KB
  • No_URL_friendly.jpg
    No_URL_friendly.jpg 51.1 KB
  • URL_friendly.jpg
    URL_friendly.jpg 32.6 KB

4 Answers

Please login to view replies.

Leaderboard (30 days)

Sifat

Sifat

Total Accepted Answers: 167
Paul Frankowski

Paul Frankowski

Total Accepted Answers: 107
Toufiq

Toufiq

Total Accepted Answers: 48
Pavel

Pavel

Total Accepted Answers: 7
Tabassum

Tabassum

Total Accepted Answers: 5

100+

Templates

200,000+

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us