Support Forums

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Remove buttons from Preview/Category View

Featured Lock Resolved
Currently on my website which is using K2 to publish, and the plugin is working as it should, however the social buttons are appearing in both category listing and item view of my articles. The thing is, I don't want them to appear in the category listing as it's causing some overlay problems in IE9 for my template.

You can find my site over at this link. Click on home K2 and see the two sample MacDonald article I'm using for testing.
http://sg.greatwalldeals.com/index.php?option=com_k2&view=itemlist&layout=category&task=&id=&Itemid=604" target="_blank" rel="nofollow noreferrer">My website

It's abit hard to explain, but what happen is my site is set to display the preview when the image/article is hovered upon which works fine in FireFox. However in IE9, when I move my mouse down towards the social buttons in the preview, the preview disappears because there's another article behind that.

Apart from that, the buttons doesn't display properly in IE9 as well if you compare with FireFox, u will see that some buttons are missing from the preview in category view. The digg button doesn't display as well in IE9.

Either way, I think the fastest way to fix the problem is to remove the social buttons from appearing in preview for category listing, but I can't find an option in the plugin for that. Could you help me with that? It would be much appreciated.

5 Answers

Kawshar Ahmed - Senior Staff

More than a month ago #Permalink
Add this code any of your css file if you do not want to show SP Share in category listing page.
#k2Container .itemListView .spshare {display:none}

Stephen Goh

More than a month ago #Permalink
Hi, I tried adding that code at the top of K2.css however the buttons are still showing up in item list view.

Kawshar Ahmed - Senior Staff

More than a month ago #Permalink
Oops my mistake. Try now.
#k2Container.itemListView .spshare {display:none}

Stephen Goh

More than a month ago #Permalink
Awesome! It works beautifully now. Thanks so much for the help!

The digg button still doesn't show up in IE9. But I can just disable that button in the plugin so it doesn't affect much. Still might be a problem for ppl who would like to use digg. Just providing feedback. But if you have the fix for that as well, I'll be more than happy to implement that.

Kawshar Ahmed - Senior Staff

More than a month ago #Permalink
The problem not with the plugin but with the API of facebook, twitter etc.


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Sifat

Sifat

Total Accepted Answers: 119
Paul Frankowski

Paul Frankowski

Total Accepted Answers: 110
Toufiq

Toufiq

Total Accepted Answers: 89
Kamruzzaman Alam

Kamruzzaman Alam

Total Accepted Answers: 4
FUTURECLIENT

FUTURECLIENT

Total Accepted Answers: 2

115

Templates

296154

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us