Support Forums

Support Online : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Simple Image Gallery slimbox light box not working

Featured Lock Resolved
Hi i have installed Simple Image Gallery on my Joomla 1.6 site on a custom template and when clicking on the images the slimbox isn't working and it just loads in a new browser window.

When i remove my script includes for JQuery in the head of the html document it works but when they are included i get one error as follows:

slimbox.js (line 6): $(document.body).adopt is not a function

I need to keep the jquery script for other features on the site.
Is there anything i can do to get around this issue?

Thanks in advance for your help.

Alex

(attached image of html head) http://www.joomshaper.com/media/kunena/attachments/legacy/images/Screen_shot_2011_01_21_at_16-20110121.png

Attachments (1)

  • Screen_shot_2011_01_21_at_16-20110121.png
    Screen_shot_2011_01_21_at_16-20110121.png

6 Answers

Kawshar Ahmed - Senior Staff

More than a month ago #Permalink
You need to make your jQuery script noConlict. Search google for jQuery noconflict

alex

More than a month ago #Permalink
Thanks man, really appreciate it.

I've found an answer for if you want to put use JQuery within a module or component but i want to use it in the main template index.php file and can't figure where to put it to get it working... Not a javascript man in the slightest, so if you have any ideas i would be grateful.

Thanks,

Alex

alex

More than a month ago #Permalink
Ok i wanted to do it manually but couldn't be bother with the hassle in the end.

So you can use this extension for 1.6 jqueryintegrator

and errors still outstanding in any of your jquery scripts afterward, you can wrap this around the code:

This before -

( function($) {

This at the end


} ) ( jQuery );

This should protect any code within from being confused with other libraries.

Hope this helps some people,

Alex

Dror Lamdan

More than a month ago #Permalink
adding $.noConflict(); at the top of slimbox.js kept having errors reported on firebug.
however the, slimbox is opened correctly.

thought it would be helpfull tomeone

Rob

More than a month ago #Permalink
I had the same problem and used jQuery Easy before. I am using joomla 3,latest dutch, Helix3 and pagebuilder. Becaus the Page builder offers no Gallery for me ( there is an option in pagebuilder wich in find not right for the job).
I downloaded SP Simple Gallery and after installation and some test the pictures did not show up. After some more test and try outs I figure that the problem maybe lies somewhere in Jquery.

I just followed the Solution from Alex and downloaded the jqueryintegrator he advised.
After installation and activating the problem was gone. No scripting was needed!

Maybe you want to build "it" in a newer helix3 version? Or a better gallery with more options in a newer version pagebuilder?

Thanks!

rajputanalogin

More than a month ago #Permalink
I am facing the same problem


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Sifat

Sifat

Total Accepted Answers: 133
Paul Frankowski

Paul Frankowski

Total Accepted Answers: 94
Toufiq

Toufiq

Total Accepted Answers: 28
Pavel

Pavel

Total Accepted Answers: 4
Al Mamun

Al Mamun

Total Accepted Answers: 3

113

Templates

289931

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us