Support Forums

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Simple Portfolio causing "1054 Unknown column 'enabled' in 'where clause'" error.

Featured Lock Resolved Bug
After updating, i can't load my home page. An error that states "1054 Unknown column 'enabled' in 'where clause'" appears.

How do I fix this?

Any help is appreciated.

Attachments (1)

  • Screen Shot 2017-05-04 at 3.33.16 PM.png
    Screen Shot 2017-05-04 at 3.33.16 PM.png 78.4 KB

23 Answers

udi

More than a month ago #Permalink
After updating, i can't load my home page. An error that states "1054 Unknown column 'enabled' in 'where clause'" appears.

How do I fix this?

Any help is appreciated.


Have the same problem - site is DOWN !!!!

Please provide link to the previous version.

regards,
Udi

basucka

More than a month ago #Permalink
After updating, i can't load my home page. An error that states "1054 Unknown column 'enabled' in 'where clause'" appears.

How do I fix this?

Any help is appreciated.


Its a bug in the in sp simple portfolio.

panassidi

More than a month ago #Permalink
i have the same problem

Felipe

More than a month ago #Permalink
Same problem....

SITE DOWN

gpitaru

More than a month ago #Permalink
Did anyone find a fix for this? If so, please share.

Felipe

More than a month ago #Permalink
Hello

I dísable simple portfolio and remové from the mail menu (erase the rows with the component) but lost the last sabes version.

Django

More than a month ago #Permalink
Hi
I had the same problem (error 1054), and it was solved after updating SP Simple portfolio.

Ahmed Balfaqih

More than a month ago #Permalink
Hi
I had the same problem (error 1054), and it was solved after updating SP Simple portfolio.


Unfortunately for me, the problem occurred after the update.

Django

More than a month ago #Permalink
Did you fix the database too ? (Extensions/Manage/Database) + empty the browser cache.

With the last version of everything (Joomla, Helix, SP Pagebuilder, SP Simple portfolio ...), it should work.

basucka

More than a month ago #Permalink
it works, Update the com and mod of simple portfolio

Bart

More than a month ago #Permalink
it works, Update the com and mod of simple portfolio


How do you mean ? i'm having the same problem after simple portfolio update

Kawshar Ahmed - Senior Staff

More than a month ago #Permalink
Please make sure that the module is also updated.

Thanks

gpitaru

More than a month ago #Permalink
Literally, download the files from the download section. Install the downloaded files.

pepperstreet

More than a month ago #Permalink
Please make sure that the module is also updated.


BTW, I recently updated some older local quickstart installations. And I ran into the same error:
"1054 Unknown Column 'Enabled' In 'Where Clause'"

Since Joomla offers the new Update feature, most people get used to it and tend to rely on it...
I remember my older SimplePortfolio showed-up in the update list,
and it seemed to be updated to version 1.5.

PROBLEM:
Apparently the updater installed the latest component only, but not the site module!
(screenshot 1)

Unfortunately, the user does not recognize any issue, because J! states everything is up-to-date.
(screenshot 2)

As soon as you switch to the frontend, the old module causes the critical 1054 error!
(screenshot 3)

SOLUTION:
I had to download the comp and module installer from your site.
Then upload and install them manually!!!
(screenshot 4)

Hope this clarifies and helps somebody.

Attachments (4)

  • module_v120_not_updated.png
    module_v120_not_updated.png 51.4 KB
  • updater_pretends_everything_ok.png
    updater_pretends_everything_ok.png 28.1 KB
  • frontend_error.png
    frontend_error.png 24.4 KB
  • module_v150_after_manual_install.png
    module_v150_after_manual_install.png 45.9 KB

Christian Burger

More than a month ago #Permalink
Hi pepperstreet,
thx your solution works fine for me:D

paul

More than a month ago #Permalink
Hi
I had the same problem (error 1054), and it was solved after updating SP Simple portfolio.


Unfortunately for me, the problem occurred after the update.


Hi. Did you fix your problem yet ? I also got a very similar problem afetr upgrading simple portfolio to the current versions. Deleting tables, uninstalling com and mod and reinstalling the com and mod still has the same error for me.

Selecting the 'fix' option under the database tab in the extensions menu made no difference to mine either.

I usually have no problems with my joomshaper templates and upgrades. Till now.

My post hasn't been responded to yet ( by the support team ).

Really does look like there's a major issue with the Simple Portfolio com and / or mod, going by the number of repeated problems posted in the forums.

pepperstreet

More than a month ago #Permalink
Deleting tables, uninstalling com and mod and reinstalling the com and mod still has the same error for me.


Are you sure everything has been deleted/removed?

May I ask how you re-installed the extensions? Did you download, upload and install it manually?

paul

More than a month ago #Permalink
Deleting tables, uninstalling com and mod and reinstalling the com and mod still has the same error for me.


Are you sure everything has been deleted/removed?

May I ask how you re-installed the extensions? Did you download, upload and install it manually?



hi

If by manually you mean using the joomla updater / installer in the extensions tab, then yes.

My final steps and where I'm up to is here

So, I currently have a successful and clean install of the com and mod, but as I'd deleted the tables ( after exporting the table contents through phpMyadmin ), I have no content remaining in them. Pretty sure I deleted everything. I completely deleted the table, not just the content ( which I tired first, but that made no difference to the problem ).

--------------------------------------------------------

[ I think I also still have the 'can't access' all the joomshaper xmls / updaters happening when I try to 'find updates', but that error is not affecting the com / mod install.] - this particular issue appears to be rectified with the clean install.

-------------------------------------------------------

paul

PS but now, it appears the com is not recognising selected categories. or any selected item, for display ( but I may be doing it wrong )

pepperstreet

More than a month ago #Permalink
So, I currently have a successful and clean install of the com and mod, but as I'd deleted the tables ( after exporting the table contents through phpMyadmin )


The new and empty SimplePortfolio works? Without any DB errors?

Now, you want to re-import your old data?

paul

More than a month ago #Permalink
It would be a lot less work than a convenient db file upload.

Is it possible to do that ? Have tried uploading but it won't accept it as the process tries to recreate a table that's already there from the new install ( if I've remembered the error message correctly after attempting that ).

Will some kind of renaming of a table or file somewhere possibly work ?

Virgin territory for me, working in phpMyadmin.

Paul Frankowski - Staff

More than a month ago #Permalink
Table for SQL is/was inside component package
admin\sql\install\mysql\install.sql
You have to :
1) Compare if you have all rows in that table as they are inside file, if not add missing or rename old.
2) Then , uninstall component and install it again.

Rob

More than a month ago #Permalink
Please make sure that the module is also updated.


BTW, I recently updated some older local quickstart installations. And I ran into the same error:
"1054 Unknown Column 'Enabled' In 'Where Clause'"

Since Joomla offers the new Update feature, most people get used to it and tend to rely on it...
I remember my older SimplePortfolio showed-up in the update list,
and it seemed to be updated to version 1.5.

PROBLEM:
Apparently the updater installed the latest component only, but not the site module!
(screenshot 1)

Unfortunately, the user does not recognize any issue, because J! states everything is up-to-date.
(screenshot 2)

As soon as you switch to the frontend, the old module causes the critical 1054 error!
(screenshot 3)

SOLUTION:
I had to download the comp and module installer from your site.
Then upload and install them manually!!!
(screenshot 4)

Hope this clarifies and helps somebody.


Good work Sherlock Pepperstreet! I downloaded the module from joomshaper installed it and it's working. I was trying the pagebuilder 3 beta on a test server. and after installing I also had this error!

APD

More than a month ago #Permalink
Just download SP Simple Portfolio module / update manually https://www.joomshaper.com/downloads/extension/sp-simple-portfolio


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Paul Frankowski

Paul Frankowski

Total Accepted Answers: 127
Sifat

Sifat

Total Accepted Answers: 83
Toufiq

Toufiq

Total Accepted Answers: 71
Pavel

Pavel

Total Accepted Answers: 6
Rifat Wahid Alif

Rifat Wahid Alif

Total Accepted Answers: 5

114

Templates

293291

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us