Support Forums

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Smart Search "Finder Tokens table full" error

Featured Lock Resolved Bug
I've enabled Smart Search on our site which uses a mix of Articles (some with SPPB plugin, others without) and SPPB pages for the content.

When I tried to run an initial index using Smart Search I kept getting the error "'#__finder_tokens' is full" after only maybe around 10 seconds or so. I disabled the SPPB Finder plugin and ran it again and it went fine, but as soon as I re-enable the SPPB Finder plugin I get the indexing error again and when I check the terms table it's stuffed full or partial and incorrect looking terms.

I upgraded to the latest SPPB (3.3) and disabled/uninstalled the SPPB Article Plugin then re-enabled and reinstalled it but it didn't seem to make a difference?

36 Answers

Simon Logan

More than a month ago #Permalink
Are you able to get back to me about this one? At present indexing any SPPB content isn't possible because of this and the indexed terms don't look right to me.

Toufiq - Staff

More than a month ago #Permalink
Hi there,

I have checked two sites. But, Helix quickstart pack got the issue & Joomla doesn't have this issue.

-Thanks

Simon Logan

More than a month ago #Permalink
Hi Toufiq

Sorry but I'm not clear on what your response means?

Toufiq - Staff

More than a month ago #Permalink
Hi there,

I have checked the Helix3 quickstart package with page builder latest version & it's working fine here.

-Thanks

Simon Logan

More than a month ago #Permalink
Okay, that doesn't really help however as it doesn't answer the question of why the tokens table is getting stuffed full of seemingly incomplete terms once Finder tries to index SPPB content.

I realise that any given site might have other extensions which could conflict or cause issues but to just write off the problem simply because you don't experience it on the single instance you have tested it on doesn't really help the problem get solved.

There's obviously something going on which prevents the indexing from taking place, or which is causing a problem for the indexer in the first place, and I don't mind looking at solutions myself however I'd fully expect at least a bit of guidance from the JoomShaper support team as to what might be causing the issue or what to check for, whether that means granting you admin access to that you can check the site or not.

Toufiq - Staff

More than a month ago #Permalink
Hi there,

Could you send me your site administrator access via PM?

-Thanks

Simon Logan

More than a month ago #Permalink
Sure, will do that now.

Toufiq - Staff

More than a month ago #Permalink
Sure, will do that now.


Hi, I have replied to your pm. Thanks

Gary

More than a month ago #Permalink
I have the same issue. If I enable the smart search pagebuilder plugin it fails to index and results in the error

An Error Has Occurred
The table '#__finder_tokens' is full

What is the fix for this?

Toufiq - Staff

More than a month ago #Permalink
Hi there,

We are working on it. Please hold on for the next update.

-Thanks

AFRINIC Webmaster

More than a month ago #Permalink
Hi there,

We are working on it. Please hold on for the next update.

-Thanks


Still no updates, please? having the same issue here.

verticl

More than a month ago #Permalink
Hi Toufiq,

I am facing same issue, Hope this time page builder team will help me on time and able to fix this issue. My last issue page not going to save I have fixed by myself after struggling more than a month with Page builder team.

Thanks,

Attachments (1)

  • sp-pagebuilder-error.png
    sp-pagebuilder-error.png 125.2 KB

Toufiq - Staff

More than a month ago #Permalink
Hi Toufiq,

I am facing same issue, Hope this time page builder team will help me on time and able to fix this issue. My last issue page not going to save I have fixed by myself after struggling more than a month with Page builder team.

Thanks,


Hi there, We have fixed the issue. Today will release the new version. Thanks

verticl

More than a month ago #Permalink
Great to here Toufiq. I need to upgrade SP Page builder version? It didn't effect my work done so far? Please make me clear

Toufiq - Staff

More than a month ago #Permalink
Great to here Toufiq. I need to upgrade SP Page builder version? It didn't effect my work done so far? Please make me clear


Hi there,

Don't worry it won't be the problem. Before the upgrade the page builder, please keep a backup of your site.

-Thanks

verticl

More than a month ago #Permalink
Thanks Toufiq for your quick response.

Toufiq - Staff

More than a month ago #Permalink
Thanks Toufiq for your quick response.


Hi there, You are most welcome & Thanks

AFRINIC Webmaster

More than a month ago #Permalink
I upgraded SPPB to the latest version but I still get the same error when launching a smart search indexing. Am I missing anything here?

Hi Toufiq,

I am facing same issue, Hope this time page builder team will help me on time and able to fix this issue. My last issue page not going to save I have fixed by myself after struggling more than a month with Page builder team.

Thanks,


Hi there, We have fixed the issue. Today will release the new version. Thanks

Gary

More than a month ago #Permalink
I've upgraded as well and also upgraded the helix template and the same issue presists. Trued different browsers, different computers, cleared all temp files and the issue still presents itself. I'm at the point where I'm just going to turn the smart search off.

verticl

More than a month ago #Permalink
HI Gary,

I have fixed this issue by increasing max heap table size 64 MiB, tmp table size 64 MiB on server.

Hope so this will helpful for you.

Gary

More than a month ago #Permalink
Can't do this on my server as it's a shared host. So this needs to be addressed by support and it shouldn't need to hog that many resources. Every other smart search plugin works except for page builder.

Gary

More than a month ago #Permalink
Hey, have you guys got this fixed yet!!! Ridiculous that this is still ongoing!

Toufiq - Staff

More than a month ago #Permalink
Hi there,

You have to increase max_heap_table_size value.

For mamp server solution

Download the attachment and keep it on the file location
/Applications/MAMP/Library/support-files/my-small.cnf
/Applications/MAMP/conf

Don't forget to restart the mamp server

-Thanks

Attachments (1)

  • max_heap_solution.zip 1.9 KB

Toufiq - Staff

More than a month ago #Permalink
Hi there,

You have to increase max_heap_table_size value.

For mamp server solution

Download the attachment and keep it on the file location
/Applications/MAMP/Library/support-files/my-small.cnf
/Applications/MAMP/conf

Don't forget to restart the mamp server

-Thanks

Attachments (1)

  • max_heap_solution.zip 1.9 KB

Pavel

More than a month ago #Permalink
How to calculate the size for this? For example, on my server the default value is max_heap_table_size = 16Mb - this allows me to index one sp pb page and nothing else. After this, the error #__finder_tokens' is full. If I set max_heap_table_size = 64Mb, it allows indexing six sp pb pages and nothing else. I think you guys need to do something to fix it without having to change max_heap_table_size

Toufiq - Staff

More than a month ago #Permalink
How to calculate the size for this? For example, on my server the default value is max_heap_table_size = 16Mb - this allows me to index one sp pb page and nothing else. After this, the error #__finder_tokens' is full. If I set max_heap_table_size = 64Mb, it allows indexing six sp pb pages and nothing else. I think you guys need to do something to fix it without having to change max_heap_table_size


Hi there, Thanks for your reply. We can't breakdown the Joomla content table of Database. Thanks

Pavel

More than a month ago #Permalink
Hi there, Thanks for your reply. We can't breakdown the Joomla content table of Database. Thanks

But after all, standard articles of jomomla are indexed without any problems in any quantity - only text is indexed. When sp pb pages are indexed, it seems that everything is fully indexed — text, css, code — the entire page. Do not you think that you can take a closer look at this, that would understand the reason?

This is how much is in the table. #__finder_tokens with SpPB smart search plugin enabled
http://dl3.joxi.net/drive/2019/01/09/0008/0401/545169/69/11d8cc5ebb.png
This table is completely empty if you turn off the SPPB smart search and index only standard articles.

Simon Logan

More than a month ago #Permalink
If it is the case that all of this data is being indexed by Smart Search, would it be possible/advisable to try and exclude everything except the text-based values such as TITLE and TEXT plus (potentially) any other addon values which might contain text values (such as Modal popup content)?

Gary

More than a month ago #Permalink
I stopped using the smart search because of this issue as sp pagebuilder is simply a hog on the resources for smart search. Like many I cannot adjust server side settings to allocate more resources as we are on a shared host. Not only that, the support response simply is lacking clarity and corrections to this issue. Not to happy about this at all but like many what's my options, stick with pager builder or drop it and go with another that works and has better support.

Everything else we sue works with smart search, but I've simply disable the search function all together for the time being.

Al Mamun - Staff

More than a month ago #Permalink
Hi,

From now I will follow this thread and I am not confirm yet but I hope within next two or three Page Builder release we will try to fix this issue and really sorry for long waiting.

Thanks,
Mamun

pepperstreet

More than a month ago #Permalink
(Following…)

Giles T

More than a month ago #Permalink
Hi,

From now I will follow this thread and I am not confirm yet but I hope within next two or three Page Builder release we will try to fix this issue and really sorry for long waiting.

Thanks,
Mamun


Following

Al Mamun - Staff

More than a month ago #Permalink
Hi Giles T,

This issue is fixed.

Thanks,
Mamun

Giles T

More than a month ago #Permalink
Thanks Al
:)

Tuan

4 weeks ago #Permalink
Hi Giles T,

This issue is fixed.

Thanks,
Mamun


Hi Mamun,

I still have the issue.

I am on,


  • Helix Ultimate Framework 1.0.5
  • SP Page Builder Pro 3.4.3
    Joomla 3.9.2


I have enabled, "Search - SP Page Builder" in Plugins and when I try to "Index" I see the error, "An Error Has Occurred
The table '#__finder_tokens' is full"

Can you please advise?


Thanks.

Al Mamun - Staff

3 weeks ago #Permalink
@Tuan,
Please create a new forum post for your issue our support team will help you.

Thanks,
Mamun


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Leaderboard (30 days)

Sifat

Sifat

Total Accepted Answers: 113
Paul Frankowski

Paul Frankowski

Total Accepted Answers: 108
Toufiq

Toufiq

Total Accepted Answers: 37
Pavel

Pavel

Total Accepted Answers: 4
J

johnny

Total Accepted Answers: 3

100+

Templates

200,000+

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us