We’re with you. JoomShaper is offering a 20% Discount on all plans due to the impact of COVID-19.

Support Online : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Smart search indexer fails if page builder plugin is activated

Featured Lock Resolved Bug
If the smart search finder for sppb ist turned on, the indexer hangs. If turned off, everything works fine.
Facts: Single language content CH-de , Language Filter is off
SPPB: 3.7.2 Joomla:3.9.16 Helix Ultimate 1.1.2 PHP:7.2.26


Call to undefined method Joomla\CMS\Application\AdministratorApplication::getLanguageFilter()
/web/administrator/index.php?option=com_finder&tmpl=component&format=json&4f531b6e9dfae9c75dd8dee96daf4ec5=1&task=indexer.batch:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)
Uncaught SyntaxError: Unexpected token < in JSON at position 0
at JSON.parse (<anonymous>;)
at Function.d.parseJSON (jquery.min.js?fdf635ce4ff72778b8b18864388ebb7d:2)
at Function.a.parseJSON (jquery-migrate.min.js?fdf635ce4ff72778b8b18864388ebb7d:2)
at Object.handleFailure [as error] (indexer.js?fdf635ce4ff72778b8b18864388ebb7d:66)
at u (jquery.min.js?fdf635ce4ff72778b8b18864388ebb7d:2)
at Object.fireWith [as rejectWith] (jquery.min.js?fdf635ce4ff72778b8b18864388ebb7d:2)
at C (jquery.min.js?fdf635ce4ff72778b8b18864388ebb7d:2)
at XMLHttpRequest.n (jquery.min.js?fdf635ce4ff72778b8b18864388ebb7d:2)

17 Answers

Al Mamun - Staff

More than a month ago #Permalink
Hi,

Can you please send me your website details in private message. To send a private message click in the profile image.

Thanks,
Mamun

Pavel

More than a month ago #Permalink
Confirm. If Smart Search - SP Page Builder disabled, then all is well indexed, including articles created through SPPB.
When enabled, indexing does not work completely.
Looks like this plugin simply is not necessary. :)

Al Mamun - Staff

More than a month ago #Permalink
Hi @Pavel,

Can you please give your website backup data. So I can test. In my server, I can't produce the issue.

Thanks,
Mamun

Pavel

More than a month ago #Permalink
Sorry, Al. It's site of my client. He did not give permission to do so.

I can explain more. Do you go the same steps?

Smart Search - SP Page Builder plugin - > ON
Press "index" button in Smart Search Component - it opens popup with the progress bar and nothing else happens.

Smart Search - SP Page Builder plugin - > OFF
Press "index" button in Smart Search Component - works well including all SPPB pages and
(made via SPPB editor) articles.

Pavel

More than a month ago #Permalink
Using the context of this topic, I would like to suggest improved features smart search for SP PB.

It would be nice to have translate publication value from SPPB page to smart search.
1.jpg

Attachments (1)

  • 1.jpg
    1.jpg 326.4 KB

Pavel

More than a month ago #Permalink
UPD

2.jpg

Smart Search - SP Page Builder plugin - > ON
Press "index" button in Smart Search Component - it opens popup with the progress bar and nothing else happens.

Smart Search - SP Page Builder plugin - > OFF
Press "index" button in Smart Search Component - indexing all including articles made via SPPB editor. But excluding SPPB pages.

I think the fix indexing problems with SPPB articles created a problem with indexing of SPPB pages.

Attachments (1)

  • 2.jpg
    2.jpg 77.3 KB

Al Mamun - Staff

More than a month ago #Permalink
Hi Pavel,
For page index you need to change this settings check here

Thanks,
Mamun

Pavel

More than a month ago #Permalink
Hi, Al. I do not quite understand. If indexing is running, it is enabled by default. I sent you an access in PM.

Al Mamun - Staff

More than a month ago #Permalink
Hi Pavel,

As far I know you need to enable that option. Thanks for your help will let you know when I find the solution.

Thanks,
Mamun

Grzegorz

More than a month ago #Permalink
I have the same problem.
I'm sure, that some bug(s) is in SPPB 3.7.2. - under 3.7.1 is OK.


I found another problem in 3.7.2 - when I save a page in SP PB - for some pages the "dotted circle" in the green "Save" button stays permanently - I don't know when the page was saved.
Under 3.7.1 is OK.

Al Mamun - Staff

More than a month ago #Permalink
Hi,

We are checking this issue. I will update about this.

Thanks,
Mamun

gourou

More than a month ago #Permalink
any news on this problem ?

Al Mamun - Staff

More than a month ago #Permalink
Hi gourou,

I sent you a private message.

Thanks,
Mamun

gourou

More than a month ago #Permalink
Hi Al Mamun

any news on this issue ? still no solution how to fix it ?

Al Mamun - Staff

More than a month ago #Permalink
Hi Al Mamun

any news on this issue ? still no solution how to fix it ?


Hi,

Did I sent you a message or not? Please check that and reply there.

Thanks,
Mamun

Sean Mellis

More than a month ago #Permalink
Any update on this issue?


There are no replies made for this post yet.
Be one of the first to reply to this post!

124

Templates

331571

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us