Support Forums

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

SP Page Builder 2.3 Module Stripping Tags Inside "Text Block" And "Raw HTML" Addons

Featured Lock Resolved Bug
Hi

This issue has been raised previously in relation to SP Page Builder 2.1 (https://www.joomshaper.com/forums/sp-page-builder-2-1-module-strip-the-tags-inside-text-block-and-raw-html-addons).

It appears to still be a problem in SP Page Builder 2.3. For me personally I am trying to add Raw HTML Addon within a module using <svg> and </br> tags and both are getting stripped when I save.

Please can you provide a timeline on when this issue might be resolved as it makes using Page Builder for modules almost unusable at present.

Many Thanks
Peter

18 Answers

Paul Frankowski - Staff

More than a month ago #Permalink
solved, you had old version of SPPB Pro installed. 2,3 not 2.3.5, please be more careful next time.;) ;) ;)

Paul Frankowski - Staff

More than a month ago #Permalink
Hi,
word "unstable" is bad in that case, but sure
I suggest to ask directly our developer https://www.joomshaper.com/forums/profile/57836-rifatwahid

Peter Hay

More than a month ago #Permalink
Hi Paul

I sent a message directly to the developer but received no reply. Any update on a timeline for when this issue will be fixed please?

Thanks
Peter

Paul Frankowski - Staff

More than a month ago #Permalink
I didn't got response as well. sorry. I will ask.

Paul Frankowski - Staff

More than a month ago #Permalink
I tested </br> and <br> - and working well. nothing is cut off from source code.

Attachments (1)

  • br.png
    br.png 9.5 KB

Paul Frankowski - Staff

More than a month ago #Permalink
i tested <svg> :

<svg width="100" height="100">
<circle cx="50" cy="50" r="40" stroke="green" stroke-width="4" fill="yellow" ></circle>
</svg>


also wasn't cut off...
what now, hmm!
please share your <svg> code which was "probably" cut off in Raw html addon only !!

Attachments (1)

  • svgpng.png
    svgpng.png 24.4 KB

Peter Hay

More than a month ago #Permalink
Hi

See attached before and after files. These are from when I try to add Raw HTML into a module called "Global Footer" that I have created using SP Page Builder

Attachments (1)

  • RAW HTML files.zip 3.3 KB

Paul Frankowski - Staff

More than a month ago #Permalink
important question, do you have installed RSfirewall or other firewall component there ?

Paul Frankowski - Staff

More than a month ago #Permalink
I had ... and my code was damaged each time, because of firewall rules , you have to modify them and ... will be OK, of course you have to work under icon size, but this is not my task.

Attachments (1)

  • ok.png
    ok.png 27.7 KB

Peter Hay

More than a month ago #Permalink
Do you mean something in the settings of my Windows Firewall is preventing the code from saving properly? Why does it then allow the code to save when I create a page using SP Page Builder that is not within a module?

Paul Frankowski - Staff

More than a month ago #Permalink
Nope.
Code is saved, so probably is damaged after... somehow.
can you give me more details what is cut off , whole code or maybe parts ??

Peter Hay

More than a month ago #Permalink
Hi Paul

See attached screenshots which show the code I try and paste into the Raw HTML addon within the Module built using SP Page Builder and then the code after I have saved and closed the module and then re-open it.

Attachments (2)

  • Code after save, close and reload of SP Page Builder Module.jpg
    Code after save, close and reload of SP Page Builder Module.jpg 198 KB
  • Code pasted into Raw HTML Addon within SP Page Builder Module.jpg
    Code pasted into Raw HTML Addon within SP Page Builder Module.jpg 279.4 KB

Paul Frankowski - Staff

More than a month ago #Permalink
What editor you are using TinyMCE, JCE ..other as a default ?
please switch to TinyMCE or MirrorCode and check again.
----
sorry I am trying guess a reasons.

Peter Hay

More than a month ago #Permalink
How do I know which Editor I am currently using?

Peter Hay

More than a month ago #Permalink
Found setting and currently using TinyMCE

Peter Hay

More than a month ago #Permalink
Thanks for this. Installed the v2.3.5 update and all now working. Really really appreciated your Support on this.

Paul Frankowski - Staff

More than a month ago #Permalink
I made this before you, hahah
welcome


There are no replies made for this post yet.
Be one of the first to reply to this post!

Leaderboard (30 days)

Sifat

Sifat

Total Accepted Answers: 121
Paul Frankowski

Paul Frankowski

Total Accepted Answers: 110
Toufiq

Toufiq

Total Accepted Answers: 82
Kamruzzaman Alam

Kamruzzaman Alam

Total Accepted Answers: 5
FUTURECLIENT

FUTURECLIENT

Total Accepted Answers: 2

115

Templates

296327

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us