We’re with you. JoomShaper is offering a 20% Discount on all plans due to the impact of COVID-19.

Support Offline : Mon - Fri / 10am - 6pm (GMT +6)

Your Time: Our Time:

Sp Page Builder: does not load the admin side languages. Warning: file_get_contents (): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP?

Featured Lock Resolved Bug
Hi, Sp Page Builder: does not load the interface languages on the back end and front end sides.
on the admin side, the following warning returns:

Warning: file_get_contents(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in E:\Program Files (x86)\...\revibePro\administrator\components\com_sppagebuilder\helpers\languages.php on line 18

Warning: file_get_contents(https://sppagebuilder.com/api/languages/languages.json): failed to open stream: No such file or directory in E:\Program Files (x86)\...\revibePro\administrator\components\com_sppagebuilder\helpers\languages.php on line 18

Warning: Invalid argument supplied for foreach() in E:\Program Files (x86)\...\revibePro\administrator\components\com_sppagebuilder\helpers\languages.php on line 27

the following screenshot explains better:

Attachments (1)

  • SpPageBuilder.jpg
    SpPageBuilder.jpg 318.7 KB

13 Answers

Paul Frankowski - Staff

More than a month ago #Permalink
Hi.
do you use localhost?

On normal hosting all should be OK.

Andreas Sölkner

More than a month ago #Permalink
Hi,

I have the same problem. I did a new installation of joomla, sb pagebuilder and helix ultimate. I tried to change the language and get following warning:

Warning: file_get_contents(http://sppagebuilder.com/api/languages/languages.json): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /home/.sites/759/site1143204/web/administrator/components/com_sppagebuilder/helpers/languages.php on line 18 Warning: Invalid argument supplied for foreach() in /home/.sites/759/site1143204/web/administrator/components/com_sppagebuilder/helpers/languages.php on line 27

When I'm using the url in a browser, I get some information and even a downloadlink.
I also tried to download the .zip language file but I'm not able to import this file

Maybe I did something wrong?! (newbie!!) :o)

Thanks
Andi

Paul Frankowski - Staff

More than a month ago #Permalink
Two options
1) Wrong PHP settings, please compare with those from manual
https://www.joomshaper.com/documentation/sp-page-builder/sp-page-builder-3#getting-started
OR
2) Hosting provider block access to our API

What language you need, I can send you file package, so you will be able to copy via FTP

Andreas Sölkner

More than a month ago #Permalink
Hi,

I need the german language package, but I think I have this file. Is it "de-DE.com_sppagebuilder.zip"?

Andreas Sölkner

More than a month ago #Permalink
...unfortunatelly it seems it's not the only problem I have :(

when I push the bottom "integration" I get following warning:

Warning: file_get_contents(http://sppagebuilder.com/api/integrations/integrations.json): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /home/.sites/759/site1143204/web/administrator/components/com_sppagebuilder/helpers/integrations.php on line 22 Warning: file_get_contents(http://sppagebuilder.com/api/integrations/integrations.json): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden in /home/.sites/759/site1143204/web/administrator/components/com_sppagebuilder/helpers/integrations.php on line 30 Warning: Invalid argument supplied for foreach() in /home/.sites/759/site1143204/web/administrator/components/com_sppagebuilder/helpers/integrations.php on line 33

PHP Version is 7.3

Paul Frankowski - Staff

More than a month ago #Permalink
Language files (from last year) use FTP to copy files.

Attachments (1)

  • SPPB-DE-unzip.zip 27.1 KB

Paul Frankowski - Staff

More than a month ago #Permalink
Have you checked and compared PHP settings as I asked from manual?

cURL library** - your server must work with curl or url_fopen.
OpenSSL must be enabled.
PHP file_get_contents() function must be available/unlocked.

Cmakay

More than a month ago #Permalink
I guys,

LAnguage and integartion defaults since i buyed and installed SP pagebuilder pro 3.6.5 in joomla 3.9.13

I have checked all php parameters but just not know whrere change :
"PHP file_get_contents() function must be available/unlocked."

I need le French language

thanks

Paul Frankowski - Staff

More than a month ago #Permalink
FR
use FTP to copy files.

Attachments (1)

  • FR-SPPageBuilder_UNZIP.zip 30.3 KB

Cmakay

More than a month ago #Permalink
I
FR
use FTP to copy files.


I am using a localhost site an using wamp php server

Paul Frankowski - Staff

More than a month ago #Permalink
In that case, use Windows File Manager

Cmakay

More than a month ago #Permalink
Sorry but i dont see how to do the verification/or the editing of this function.

On the other hand, I downloaded and installed the zip files present here:

http://sppagebuilder.com/api/languages/languages.json
http://sppagebuilder.com/api/integrations/integrations.json

The installation went well, but when I click SP PageBuilder/Languages ​​or SP PageBuilder/Integrations, I always get the same error errors.

"Je suis perdu et presque désespéré!"

SOS!

Paul Frankowski - Staff

More than a month ago #Permalink
In general, it's still something with PHP settings, have you asked them for help/support.
Yes, show them what you need and wait for respond

I cannot edit that, it's on your side only.


There are no replies made for this post yet.
Be one of the first to reply to this post!

124

Templates

330788

Community Users

Newsletter

Don’t miss any updates of our new templates and extensions and all the astonishing offers we bring for you.
We never spam

Joomla! ® name is used under a limited license from Open Source Matters in the United States and other countries. JoomShaper.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Connect Us